Automation triggert by json via MQTT, Value 0E0443

Try to set up an automation based on MQTT.
This works well as with several values but one is driving me crasy.

Via MQTT I get json as following:

In automation I add (and the same is true via automation.yaml)

After saving it and do a try run it looks like this:

Tried it via automation.yaml but also there the 0E0443 is marked in blue with the same effect.
Reopen the file and it turned to 0

Found meanwhile that 0E0 in json is equal 0, need therefore a workarround that this not interpreted…
Source: Is 0E0 a valid JSON number - Stack Overflow

Any hint or workarround would be nice.
Thank you in advance


Plz format the yaml code, helps debugging a lot more then screenshots.

Your payload:


Has the Data as a string, note that 0E0443 is between quotation marks, so you just need to quote the payload.

payload: "0E0443"

Dear @Dujith
THX it works well, still not got why in the other cases the “” where not necessary.

May I send you a “Glühwein” ?

Best Regards

The other cases might have been presented as a number.
And no thnx, i’m driving atm.

Thank you, thank you, thank you,
May I spend you a “Glühwein” ?
Best Regards