Best hardware combination for HA?

I actually have an Acer Revo RL85 but its a celeron processor so was a bit worried it wouldn’t be powerful enough, I’ll see if I can get that powered with 12V I can use that then.

OK, so for those interested the Acer Revo RL85 (well the Celeron anyway) is not an option at all, I tried a few times to install Ubuntu and it just hung throughout the various installation stages, I just dont think there is enough horsepower in this package to run Ubuntu and ultimately Home Assistant. I literally had this laying around the house and remember why I never used it, its painfully slow!

It also does not power up at 12V it needs 19V, I sourced a 12V to 19V 5A convertor which I can use elsewhere so it is possible to power it from a battery with this converter.

I then came across a really good deal on an Intel Nuc I3 with 256gb SSD, 8gb ram, keyboard, mouse and mini dp to hdmi convertor for around USD185 so it was a no brainer, I’ll obviously not use anything apart from the NUC itself but still a worthy deal.

I installed Ubuntu on it and was super impressed by how fast it was, best money I’ve spent in a while.

I’ve got home assistant installed under a docker and will play around with it, I like the docker option because I get to play around with a Linux environment again and the NUC comfortably has the capabilities to do other things apart from being dedicated to HA but do think the Hassio image may be the option for me I like the add-ons etc… and also running this on my RPI so would prefer to be able to restore a snapshot.

Anyway I shall continue experimenting and report back for those interested but on face value the NUC is the perfect beast for Home Assistant.

If you are interested in using your NUC for other things, I can recommend Proxmox for running VMs. You then run Home Assistant in a VM and run other VMs as you desire. For example I just recently setup up a instance of Home Assistant (formerly as a test environment for helping others here on the forum and to see how I like the add-ons etc. Then I have my production VM on which I run Home Assistant Core in docker and a “development” VM on which I run Home Assistant Core in docker where I test new things before they go into production.
A nice plus with Proxmox is that you can easily do a full backup. You backup (on a schedule if you want to) the VM and if your NUC ever dies (we hope not :sweat_smile: ), you install proxmox on a new machine, load the backup and you are back exactly where you left off.

Thanks for this post, I installed Proxmox this morning and busy setting up VM’s now, definitely a better option for me as it gives me a lot more versatility and I can play around with the different install types and then stick with the one that I like best.

1 Like

@Burningstone sorry I know this is off topic but you mentioned that you have both and Core installed.

I got core working quite easily using a docker but I am struggling to get the image working and am quite sure I’m doing it right.

I’ve downloaded the image from here

Booted using a live CD with Ubuntu and copied the image to the disk confirm file integrity and then write it using DD to the disk (/dev/sda)

gunzip -c /home/ubuntu/Downloads/hassos_intel-nuc-3.10.img.gz | sudo dd of=/dev/sda 

It writes with no errors but when I reboot the VM instance it doesn’t boot, just gets to the part after the BIOS and says booting from hard disk.

Any ideas on where I’ve gone wrong perhaps?

I’d prefer to run the image, I’m not big on the idea of having Home Assistant installed under a docker under a VM, it would also make it simpler with copying a snapshot across from my RPI install.


Possibly the unrar process didn’t complete successfully? Can you try dd specifying img file (if=hassos…img)?

How about boot method for VM? is it UEFI?

OK let me try specify IF and see if it makes a difference although I’m piping the output of gunzip to DD.

No boot method isn’t UEFI I did try enable that but it said I need a disk that supports it, check online help etc…

My other instances of Linux boot but obviously their install process was different.


I installed Ubuntu so that I could make use of the disk space, copied the image file and stipulated it as the input file with DD but same result

I’m going to call it a day with this approach

Sorry can’t help you on this one, I installed Home Assistant (formerly on top of ubuntu because I like to have full access to the host system.

This is getting painful :smiley:

So I cannot mount a USB card on the Ubuntu live CD for some reason so I setup a share on my network with the gzip file which is small, when I try gunzip it to get access to the .img file to specify that with DD it tells me there is not enough space on the drive :rofl: I’ll try use the network share but not sure how it gets mounted I was accessing it through the GUI.

OK no problem and thanks anyway. I can try installing Home Assistant under Ubuntu if I don’t get this working.

I installed a HassOS vm in Proxmox as well but I used whiskers script. Check drzsss youtube for Proxmox videos and follow the link to the script. I didn’t use the lxc container version… just the vm one.

If you can’t find it let me know and I can post a link when I am at my computer.

I also have a debian plus ha supervised in another vm.
here is the link:


@DavidFW1960 thank you very much that worked perfectly.

1 Like

Home Assistant is working well on the NUC and I restored a snapshot from my PI, changed IP of NUC to be the same as what the PI was rebooted and all devices are working as they should.

The only issue I noticed is that it does not have the Bluetooth drivers and reading on the forum and elsewhere it seems like its quite difficult to get this working, I hope to find a solution as I have some Bluetooth temp / humidity sensors.


There doesn’t appear to be a solution to get the onboard Bluetooth working with the Home Assistant installation i.e. not under a docker and even then it appears to be a hit and miss affair.

I had a USB Bluetooth adapter laying around so I connected it to the NUC and added it as a passthrough USB port on Proxmox and happy to report that its working and my Bluetooth sensors are functioning as required, I have now fully ported across from my RPI to the NUC with everything in tact and operating as I wanted.

Thanks to all of those that assisted with my troubleshooting.

I think too many people over-complicate Home Assistant. If you want a device setup as an Appliance, that is dedicated to Home Assistant, it depends on the size of your installation and what you are running.
A small installation, with half a dozen Zwave devices a few Zigbee devices and an RM Pro will work happily on a Raspberry Pi 3B+ with 1GB RAM and the automations will tend to work instantly and the Web Interface will be smooth. It will just take a few minutes to do a restart if needed.
If you go for a bigger setup, then you are moving to an Intel Nuc or similar.
Now you have to decide, is it an appliance or are you going to use the machine for other purposes.
If it is dedicated to HA and running like an appliance, I would recommend Supervised Home Assistant install, using Home Assistant, formerly HassIO. This gives you the most appliance like setup and is pretty easy to get running. Use the Nuc install file and be done. In this form, a dual core processor is more than ample and I would even say 4GB RAM is more than sufficient for a buttery smooth interface and smooth automations. Disk space, 64GB is more than enough. Just keep your log database under control.
If you want to do more than one thing with the machine, then I would suggest an i5 or whatever suits your other applications. In this case, I would suggest virtualisation. Something like ProxMox, a bare metal hypervisor, would be ideal and you can run up a Windows VM if you really need it.
I know a lot of people like to tinker, and that’s great. That is what leads to development and improvements, but if you just want a smooth, end user style Home Automation platform, Home Assistant (formerly HassIO) is simple to install and easy to maintain.

My setup is a Core i5 4790 with 24GB RAM, a 480GB SSD and 8TB HDD. The reason mine is so excessive? I virtualise some things as my machine does more than one task.
I run Home Assistant in a VM with 4GB RAM, 2 Cores and 64GB disk space. I also run a NAS (OpenMediaVault), my NVR (Blue Iris) and a PLEX Media Server as separate VM’s.

Overthinking and trying to be too complex is the thing that can lead to Home Automation not being as accepted by other people. WAF is often used as a term, Wife Acceptance Factor. If it becomes more work maintaining the system and it doesn’t bring you the freedom and benefits, then it is not worth the time.


Using Odroid N2 here with eMMC module.
Runs fast, but it is still a beta release when using HassOS so problems can be expected there.

1 Like

It’s in spanish, but you’ll find hardware comparative table with support and cost criteria: Mejor hardware para usar Home Assistant - Paciencia Digital. Domótica, Estadística y Datos

I am completely new to home assistant, and I am completely satisfied with it. What a great experience to easily create a dashboard and connect different platforms. I am an Industrial software engineer myself and I renovated my house 10 years ago and of course I wanted to automate everything haha. But then the best choice for me was to program my house in a siemens S7-1200 (knx system was too expensive for me). This has been working perfectly for 7 years now, and I bought a raspberry pi 3b+ 3 years ago to experiment with and to not expose my plc to the internet. Recently I was browsing on my raspberry and I saw Node-Red integration and I started experimenting with this and ended up on youtube where someone was talking about home assistant. So I thought I should try this too, and guess what I’ve been doing the past two weeks, just completely addicted to home assistant haha. But I have also completely grown out of my Rpi 3b+.

I think @brendan answer is a very good one that made me think for a while and actually you probably already answered my question what is the best choice at the moment. I have a Dell Optiplex lying around with an i5-6600T and 8GB RAM. And I took the same route as you to this guide:

And it now works great again but has to start all over again, but if it was worth doing the first time, it’s the second time to haha.

I hope this isn’t too long a post
greetings, Toine

1 Like

It could also be worth looking at the Home Assistant Yellow now if you are interested in a dedicated Home Assistant device.
Home Assistant Yellow | Crowd Supply
This is a hardware option the Home Assistant development team have been working on and has now started shipping. It could be an alternative to running a computer 24/7 unless the computer is running other services you need 24/7 also.

You should be able to export or download the previous backups of Home Assistant to install on a new installation also. Usually, if you have the SAMBA addon, you can download them off your Home Assistant instance by going to the share and they should all be in the Backup folder.

Another option, if you have a Google Drive account, is to use the Home Assistant Google Drive Backup add-on. GitHub - sabeechen/hassio-google-drive-backup: Automatically create and sync Home Assistant backups into Google Drive

I still use a virtual machine setup as I also have CCTV software and a couple of Linux VM’s that I run 24/7 so it makes it worth while for me running a PC 24/7.

Yes that’s right and that all looks very good, I was also very interested in it but it is not available now (and the CM4 is also a thing) otherwise I would have bought one for sure. Second problem I have is that I have multiple networks: Vlan01 is the general network with internet access. Vlan02 is the network that includes my PLC’s and HMI and it has no internet access. First I solved this to enable wifi on Vlan02 in the router and access it with the pi via wifi. But after your post I am more convinced of the server application in my case. Thanks again for that haha.

Now that I have the proxmox server running on the DELL mini pc and the Home assistant VM on it and I must say that it is now very smooth compared to the pi 3b+. I also tried to put a usb to etherter adapter on the pi but it didn’t accept the adapter as a network port. But that’s all resolved now as the server now manages the drivers. Also to backup and restore is much easier I must say and have already had to use it twice, very handy.

Energy consumption is also not that bad, it consumes approximately between 35 and 50 watts on average during the day, which results in an average of 1 KWh per day. If I would have used my desktop wouldn’t have been very attractive with the current energy prices haha

Also because of my work I have a little bit of experience with VMs because most of the visualization is on a VM because of machine downtime’s and the easy switching of hardware.

Brief summary of my experience so far:

Home Assistant on a pi, absolutely amazing how simple you can add things both hardware and dashboard and it just (almost always) works well. Of course, Home Assistant on a pi is the same as on a VM.

Home Assistant on a Proxmox Server as a VM, in my case really a solution. And I think anyone who knows a bit about server / VM’s, this is a very nice option that offers a lot of flexibility. And @brendan has actually already given the perfect description. And I’m also going to run a VM for NVR software just like you. But also a machine on which I have an AI running that keeps an eye on news and other topics and with that draws up a daily plan for charging and discharging my ESS (energy stroge system), and in the meantime also monitors everything and then adjust accordingly.

But all in all a very nice experience both on the pi and on the proxmox server :slight_smile:

1 Like

Because of a crash of my Home Assistant setup on my Pi 3B+ I was looking for a better solution for a dedicated HASIO server. Main problem was the very limited RAM of the Pi 3B+. With only HASIO and ESPHome compiling the Supervisor crashed because the RAM was full… So my dream would be to let it run in a VM, but for now I decided to get the “biggest” Compute Module 4 which surprisingly was not that much more overpriced like all the Raspberry Pi 4.

Or in other word: Even the biggest CM4 with 8GB RAM, 32GB Flash, WLAN + BT (~115 €) and the Waveshare Mini Base Board B (~40 €) did cost the same as the biggest Pi 4 with 8 GB RAM at the moment (~150 €) without SD card. But with the CM4 and the Mini Base Board B you have a M.2 Slot with PCI-Express available so you can plug in a NVMe storage (Western Digital PC SN520 256GB M.2 2242 in my case) or a M.2 SATA card, to use e.g. SATA SSDs even in a RAID! Even when using the eMMC of the CM4 the speed boost is insane. And when using a NVMe its even faster! You done want to get back to a SD card after you experienced that performance :wink: