Binding IKEA Tradfri 5 button remote with IKEA FLOALT via zigbee2mqtt (UI)

What a great instruction - and noone liked it or said “Thank you” so far :open_mouth:
Though it took me (absolute Zigbee2mqtt beginner) a while to understand and follow it worked in the first try!
I didn’t finish it completly, I didn’t yet implement the light color changing part but will try this as soon as possible.

Thank you very much! :+1:

1 Like

@kotrfa : I needed a 2nd light with a 2nd remote in a different room and used ID 65288 (instead of 65289) and everything is working as expected. I mention this because I thought your explaination would only work with the particular ID you mentioned.
Maybe someone else would like to know this :slight_smile:


Oh. Interesting. I thought it’s a limitation of the firmware, maybe new versions do support it? Anyway, the z2m docs should be probably updated

Just wanted to say this was super helpful. Thank you!

1 Like

thanks <3 after 2 days my dimmer work, thx

1 Like

Works great, but I didn’t get the description in 3. Can it have any ID, or does it have to be 65289. If it’s the latter, what does the ID mean?

I think it doesn’t have to be 65289 anymore, but I haven’t tested it and rather put it there.

I have linkind 1 button switch and am triyng to bind with sengled non-colored bulbs. I created a group, random number and binded with linkind everything was sucessful but it does not work. Linkind has a default group 16394 number wonder if i have to create with that or add it as a scene?
Edit: Very new to zigbee2mqtt, just migrating things from ZHA so using the UI.

This is about IKEA, not some other brands. Open a new topic.

Note that not all devices support binding, so have no idea if your does.

Thanks will open a new topic. It supports binding but kinda confused why it does not with zigbee2mqtt, ui seems straightforward.

Is anyone else experiencing unreliable results? For button and lights with the same hardware and firmware Im getting different results. Sometimes binding works, sometimes it does not. Changing to a different type of button often works.

And a question, is there any difference between creating a group with one light in it and binding to the group, vs binding directly to a light (without putting it in a group)?

Binding works reliably for me just fine on all IKEA FLOALTs, controllers and bulbs (sometimes there is a delay for e.g. one light in the group, but that’s fine).

And a question, is there any difference between creating a group with one light in it and binding to the group, vs binding directly to a light (without putting it in a group)?

At least in the past it wasn’t possible to bind to a light, but only a group id could be specified. Now it seems to be possible to bind directly, apparently.

Ha, so I am experiencing unreliable results with the same hardware models (and same FW versions). Specifically, the new Styrbar and IKEA LED2003G10 control via MQTT | Zigbee2MQTT . I am able to bind it for On/Off and Brightness, but can’t make the scenes work. Specifically, if I change the color to something random and if I then press any of the scenes button (left or right), it gets into the warmest white and just sits there :-/ . Works for other pair of styrbar and color bulb (same models + firmwares) without issues :cry:

It seems it almost seems that it only remembers just one scene :man_shrugging: .

Probably related: IKEA Remote Color switching doesn't work (even with group 65289) · Issue #13151 · Koenkk/zigbee2mqtt · GitHub IKEA bulbs (LED2003G10) can't switch scenes with IKEA Styrbar remote when binding · Issue #14684 · Koenkk/zigbee2mqtt · GitHub

OK, I am lost…

I have tried to repeat the same process and now it’s working again. I don’t know why, I really really followed did the same thing as I had done twice before that…

So the takeaway for others stumbling upon this: keep trying shrug …

Quick Question is it possible to bind the same remote to multiple groups? For me it is doable on the UI but only the first Group is getting controlled.

I followed this tutorial and my remote doesn’t seem to do anything?? Super frustrating. Not sure where to find out why.

Note that I am also not able to get it working with my Sonoff dongle (but I am able to do it with Slaesh stick).

I was using the same method for pairing covers with the remote, but it doesn’t work the way presented here anymore IMHO.

Remote version:


When bind to the group with the blind, it doesn’t react. I had to bind it DIRECTLY to the device, e.g. this way:

Agrees with Upgraded ikea switch, now no binding to group so automation issues - #3 by duck304

Hi, I have button with firmware 24.4.5 and I am unable to make it work, in Logs I could see all buttons are working, but when I create a group to control my light it do nothing. Appreciate any help

Hey, sorry, can’t see anything obvious… I am afraid the guide doesn’t work anymore for new HW/versions :cry: