Bricked again after 0.118.5 Update

Hey now! The size and operating principle of core rope memory has its advantages in high-radiation environments.

If anyone is interested in watching the restoration of an Apollo Guidance Computer (AGC) here’s a heroic, and ultimately successful, attempt described in 34 parts. You don’t need an electrical engineering background (but it helps) to appreciate the persistence and ingenuity of the AGC’s restoration team and its original hardware and software designers. It culminates in a presentation of the AGC controlling a simulated landing for one of its surviving designers.

Apollo Guidance Computer Restoration

Here’s the episode explaining ferrite core memory.


I liked his latest effort to get the HP clock modules working. And the fancy computing pants.

Sorry you’re having so many problems but I just wanted to respond to this as I had the same experience. Just constantly rebuilding my Pi instance after every few updates. Same exact thing. Would do the update and would then find the machine completely unresponsive. Had to replace my sd card a few times. After doing some research I decided that the problem might be hardware related. So, I migrated my setup to my windows server using Virtualbox. I had a server already so this was easy and cheap for me but so far it’s been absolutely bulletproof. Once I received an error because I ran out of space but I just very quickly added more space and it fixed the problem. I think Raspberry Pi’s are a very low cost, easy way to run a server but there are reliability issues using SD Cards. If you search the community you’ll find some information about reducing the logs as the constant writing to the SD cards tends to kill the cards. Also, you could try an SSD as it’s now supported on Pi. As far as Home Assistant goes though, I do not find that the update schedule is the problem. I think they do a really good job of making sure that the releases are really ready for release.


Just need to find the root of the problem. In my case this best practice work like a charms…

  1. remove/delete all home-assitant.* files before you upgrade
  2. remove/delete all pycache directory from all of your custom_components

Then bring up the new home-assistant, if there are breaking changes then yes you will required to fixed it. But other then that you should be all sets.

P.S. I used docker on my end, so downgrade is as simple as removing docker and reinstall

need to bootup from USB instead of microSD, this topic have been discussed so many times. And pi3B+ dont have enough hardware to support our power hungry applications. Furthermore its not all about CPU and memory but the input and output need to be changes in order to support multiple API you will required to make HA great. I even move my HA from RPI 4 to Synology NAS and it change the entire system.

OK, if SSD’s are supported, please provide a link to the offical guide for HassOS.

HA is not a ‘Power Hungry’ application… My Pi3 has a 15m load average of 0.1 with the 1m load average ‘sometimes’ briefly peaking at 0.9, memory is never over 45% (out of 1Gb), so its massively underutilised.

I was writing communications system software in the 1980’s for phone and satellite systems, and this trend of just throwing more CPU and memory at the problem instead of writing performant code is getting ridiculous.

How do you install your HA? Are you running supervised? There should be some guide for 3B+ for booting from SSD instead of microSD

I’m using HassOS, so supervised, and there is no official guide on how to boot from SSD, so as far as I can make out, its not supported.

follow those guide to enable you to boot from USB and then put your img into your SSD instead of microSD and boot away from SSD

Yes, there are guides on how to boot a Pi from and USB SSD, but thats not what I want, I want an install for HassOS from a SSD which is supplied as a downloadable boot image. Simply writing this image to an SSD and plugging it into a Pi will not work…

I don’t understand why it shouldn’t work. I converted Rpi4 to SSD a few months ago and I’m very happy. The HassOS system runs flawlessly and reliably all the time.

If you have followed the correct procedures to enable USB boot, then the only other possibility is the USB drive/adapter you are using is not supported.

See here for info that may help you with that. It applies to Pi3 and 4.

I can confirm that USB boot of HA OS on a Pi3 works, so it’s either your hardware, or user error.

From what I understand you need to set up the pi to load from USB. Since there is not firmware GUI you need to update it using an OS. So first you need to enable booting from USB and then this pi will load from USB if there is a bootable USB device.