Broadlink RF Codes

I started trying the Broadlink component for an RM2. I have been able to make it work great for IR and simple RF devices like Etekcity outlets.

I tried to use it for an universal ceiling fan controller, I was able to sniff the codes; however it seems like every time I try the same button the sniffed code is different. When trying to send the commands back nothing happens; however, I am sure it is not an RM2 issue because I can control them with the iOS app. Has anyone noticed similar behavior? Any suggestions?

try to be very close to the broadlink with your remote when in learn mode?

Tried literally an inch from it. Tried taps and long presses too.

Any outputs in the log?

Nothing out of the ordinary. I can see it capturing and sending with no issues just the codes seem to be changing and thus not working

Hmm, you can try to report it as bug in the library we are using:

Not yet. Was waiting to see if someone else was facing something similar.

Hi, got a similar issue, I reported it there :

Edit: My rm is in firmware v20022, just saw an update v20025 with this comment : “Improve RF learning performance”, I’ll make new tests once updated.

Edit2 : just confirming firmware update solved the issue :slight_smile:

Would you please post how you make it work for IR?Thanks a lot

not sure about your question. I can add that I got best results when pressing the IR button (while in learning mode) for a short time, like less then half a second. If pressed longer time, like a second or more it would not learn or incorrectly.

There is currently a bug in the library, when sending long rf signals:
So setting the timeout to 3 seconds my help:

Daniel - quick question since you seem expert with this component.

I am “sniffing” the RF packets but they are in hex. How do I convert the HEX to Base 64 so I can use Homeassistant to control the RF switches (TC2) I have?


Good find Claudio, I’ll try this - I need first access to an Android Phone to dump the HEX codes from the app.

Backup plan is to use a Universal RF remote cloner, intercept the command from the RM2, and send it back while in learning mode.

I’ll keep you guys posted!


Hey weissblut, I’m looking into ordering a Broadlink. Just curious what gear allowed you to view/dump the hex codes of the IR captures you sniffed?

I’m also interested if anyone knows whether the encoded IR packets / IR hex codes are sent between the Broadlink’s mobile device app and the Broadlink before the Broadlink fires them – if so, I could intercept them with Wireshark. (In other words: Does the Broadlink mobile app store the hex values after the Broadlink RF records?)

you can use the broadlink app to store all remote commands, and when you have all the commands you like in e-control you can easily move them to HA.

1 Like

Anyone find a solution? I am using a Hampton Bay remote/receiver. After learning the code for medium fan on, I was able to get the fan to turn on one time after pressing it few times and I never got it to turn on again.

Hi, sorry im new to this. Can you tell me how to get the commands/code from e-control?

follow the instructions from the docs (broadlink component)
but read the link ik gave for what to do different, to get easy YAML code.

Sorry who is ik? Can you give me the link to the thread?

sorry, i meant i :wink:

here is the thread.