Brultech GreenEye Monitor and ECM-1220/1240 integration

Is there an known method to have mutiple monitor to send data to HA?

They can actually all send to the same port. The packets have the monitor serial number in them, so the integration is able to route them appropriately.

So I’ve configured both GEM today to send packets to the same port. It’s finding on one of them, even though both are configured with the same settings. Also, when configuring using the UI, after asking me for the 4th pulse sensor, it just hangs there. So far the only part where I was successful was to create the entities in the YAML config and let it import what it found.
Am I doing something wrong?

I would double check that both gems are configured identically in terms of packet format and network settings. If that doesn’t work, head over to the GitHub repo and file an issue, including all of the logs and so on info that the template will request: GitHub - jkeljo/hacs-greeneye-monitor: HACS version of the Home Assistant Core greeneye_monitor component. For beta-testing and faster deployment of changes.

I was told that in dashbox there is a way to adjust some kind of error ratio from the sensor reported energy usage per sensor (its called multiplier I think). I see right now there is about a 2% error with the energy reported by my energy provider and the GEMS. Is this something that could be done within the add-on or you see it differently?

Interesting, that’s potentially not all that hard to add. Do you have any docs on how that works for dashbox?

In the meantime, Home Assistant itself has ways to add sensors that compute their value from the values of other sensors (they’re called template sensors). But if there’s a standard adjustment that needs to be applied to all channels, that would be much easier to just do in this integration.

A friend of mine sent me this screenshot from his dashbox. Apparently on the dashbox you can set the multiplier to any value you want. So he adjusted the “error margin” using that. In the GEM box you can only toggle this “multiplier” on or off which will either leave it as it or multiply it by 2.

I haven’t found anything relevant in the documentation. I’ve written to Ben from Brultech and waiting for a reply.

I added the custom repo to HACS, downloaded, and then installed the integration. I even restarted HA just in case, but I’m just seeing this. Did I miss a step? Just to add - I’m using a Dashbox, and set port forwarding to the HA server on port 8000.

That’s a known issue when you click the configure button; there’s nothing left to configure after you’ve added the integration. Once it receives a data packet from your DashBox it will add entities for all of the sensors. So it seems that something is not quite right with the GEM/DashBox setup, such that packets aren’t arriving at whatever port the integration is configured to listen on, or else the packets aren’t of the right format (they need to be one of the BIN formats). If you double check all of the configuration and it’s still not working, file an issue over at the GitHub page for this integration, making sure to include all of the diagnostic information that the issue template asks for, and we’ll go from there!

Ok - thanks for the response. I suspect it’s the wrong format packets. I need to get into the GEM to check that, but it’s been YEARS since I did that, and the credentials I expect should be working are not. That has nothing to do with this integration though, and I’ll figure it out eventually or ask for help on the Brultech forum. I’m excited to get this integration working.

With much help from Ben, I got my GEM and Dashbox updated to the latest software / firmware, and got the integration installed. It’s working, but I’m seeing something very odd. I enabled the current sensor on one channel, and it’s showing the correct value. The energy sensor though is crazy high (all of them appear to be) and I have no idea why. Am I reading this incorrectly?

I just noticed something else really odd. This is the exact same sensor as the previous screenshot, but the current draw is lower (and matches what the Dashbox page is showing). BUT - I just noticed that the energy reading is still exactly the same.

It’s just reporting whatever the GEM is. I believe you can reset the energy counters in the GEM itself, but I wouldn’t bother. Home Assistant’s energy dashboard looks at how much the energy value changes per time period, and doesn’t care about absolute values.

Re the energy sensor not changing:

  1. At 1-2A, it’ll take somewhere between 2 and 10 hours to use a kilowatt-hour of energy, depending on what the voltage is
  2. The energy sensors are only updated once every 30 minutes so as not to overwhelm Home Assistant’s database while still giving plenty of data for the energy dashboard.

Got it - that makes sense. Thanks! :slightly_smiling_face:

Any thoughts about using the Brultech “Engine Software” to send ECM-1240 packets to this plugin? I’ve tried multiple configurations under the home automation config (to forward data to a host), but with no success so far.

I’m using two older ECM-1240s with a serial-to-ethernet server. I have the ‘Engine’ running on a Windows host, and it’s receiving packets from the ECM-1240s without issue. But I’m not seeing any recognition from the plugin on the Home Assistant side. I’ve confirmed that port 8000 is open on the HA host, but I’m not seeing any traffic.

Just want to be sure this is feasible before I sink too much more time into it. I’d rather not sink more money into buying dash box unless I absolutely have to…

First I’ve heard of this engine software; if it’s able to forward packets, though, I would expect it to be able to work. When I wrote the ECM-1240 support I had a serial to Ethernet bridge configured in client mode to send packets directly to my Home Assistant instance; you might try that as a troubleshooting step. The Brultech forums are also super helpful.

Thank you for the quick response. I’m going to try and see if I can set up my serial to Ethernet device to forward packets directly. It looks like I can via “connect” mode - I’ll try that this evening. It’s a Lantronix PremierWave XN (these units are dirt cheap on eBay and are very full-featured).

I’d definitely prefer not to use the “Engine Software” as it’s just another failure point in the chain, and it very much appears to be old software and no longer maintained (though you can still download it on Brultech’s website).

Also, thank you for your work on this integration. Looking forward to getting it working. I’m donating my old ECM-1240 and picked up a second one on eBay to monitor energy usage at a community swim club.