Build error on 'homeassistant-pyozw'


totally new to home assistant, but got it running with

Want to use a zwave usb stick, but it does not work because of following build error:

2018-11-25 18:27:48 ERROR (Thread-11) [homeassistant.util.package] Unable to install package homeassistant-pyozw==0.1.1: Failed building wheel for homeassistant-pyozw
Command "/srv/homeassistant/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-1mhuz4an/homeassistant-pyozw/';f=getattr(tokenize, 'open', open)(__file__);'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-w92v6y2g/install-record.txt --single-version-externally-managed --compile --install-headers /srv/homeassistant/include/site/python3.5/homeassistant-pyozw" failed with error code 1 in /tmp/pip-install-1mhuz4an/homeassistant-pyozw/
2018-11-25 18:27:48 ERROR (MainThread) [homeassistant.requirements] Not initializing zwave because could not install requirement homeassistant-pyozw==0.1.1
2018-11-25 18:27:48 ERROR (MainThread) [homeassistant.setup] Setup failed for zwave: Could not install all requirements.

Have no clue, whats going wrong here. Any hints how to solve this?


1 Like

You’re missing setuptools: pip3 install setuptools unless you’re using then best check on discord.

Thanks for your fast reply.

But that is not the problem…

(homeassistant) homeassistant@smarthome:/srv/homeassistant$ pip3 install setuptools
Requirement already satisfied: setuptools in ./lib/python3.5/site-packages

Removed completely “/srv/homeassistant” and repeated the installation, after starting ‘hass’ the same error raises up again.

Any other hints? What do you mean with “check on discord”?


Give sudo apt-get install libudev-dev a shot


@firstof9: you made my day!

Installed “libeudev-dev” (eudev replaces udev in devuan, Now it works.

I try command sudo apt-get install libudev-dev
but ask me for password for SUDO. What is a pass for sudo in virtualenv python.

You don’t execute it in the venv

same here on upgrading home assistant to 0.105.3. Solution helped! thanks!

1 Like