Camera not working - but only in notifications

So I’ve successfully got my Amcrest camera working using my low res sub stream for speed. It’s mjpeg format, which is what the dynamic notifications seem to require.
When I’m in the app - it loads just fine.
But when I try to set up a dynamic notification, it’ll hang like this indefinitely:

My camera’s setup is like so:

- alias: Garage opened
    platform: state
    entity_id: binary_sensor.garage_door_sensor_25_0
    state: 'on'
    service: notify.ios_notmyrealdevicename
      title: 'Garage opened'
      message: 'at {{now().strftime("%H:%M:%S")}}'
          category: camera
        entity_id: camera.garagecamera

And the camera like so:

 - platform: amcrest
   host: notmyip
   username: notmyusername
   password: notmypassword
   name: GarageCamera
   resolution: low
   stream_source: mjpeg

Am I missing anything basic here, or is this a weird edge-case type of bug?

This just got fixed in today’s build, thanks to you and @infamy reporting it to me!

Works perfect now - thanks for the fix! This feature is awesome - better than any security system out there today.

I have this same problem, and I’m on the latest app version and HA 0.38.2.

I tried with an MJPEG camera (and an RTSP/FFMPEG camera). The camera image is showing in the front end. In the iOS app, I just see “State”, no image; not sure if that’s supposed to work.
My config:

#in cameras.yaml
- platform: mjpeg
  name: Kitchen

#in automation.yaml
- alias: 'Movement Living Room'
  - platform: state
    entity_id: binary_sensor.motion_living
    to: 'on'
    service: notify.ios_lwi6
      title: "Movement in the living room"
      message: "Check it out"
          category: camera

My screen looks the same as in @greco’s original post.
Have I got something wrong? Thanks!

Update. After reading this:

I changed my camera from an internal IP to a public URL (port forwarded from dynamic DNS provider), with no difference. I still get the eternal spinning wheel.

your camera ip should be internal. no reason for a public URL.

This is working for me without any issues.

What version of the ISO app are you running.

I’ve changed it back to the internal IP address, thanks.
The iOS app is the current one, 1.0 (51).

The camera IP doesn’t need to be externally accessible as Home Assistant has a built in proxy. Home Assistant itself is the only thing that needs to be externally accessible and you should use an externally accessible address in the iOS settings for everything to work properly outside of your home.

If you are still having issues feel free to PM me the address you are entering into settings and I can manually confirm that everything is correctly setup.

How is it possible that I can get notifications even if my HA isnt’t accessable from outside? And shouln’t the video go the same route?

Notifications are their own connection initiated by home assistant to amazon to then send the notification.

Loading video would then a connection from your phone back to home assistant.

I think location updates would also require Hass open to the web. (passworded of course)

Hi Robbie. Thanks for your offer! I tested it again tonight, and it worked.
I had just upgraded to 0.39.1, but I don’t know if that’s what the difference was. It could have been a number of things, I guess. Anyway, that’s very nice now :slight_smile:

Funny thing now is mine stopped working. I no longer get even the spinning logo just a Big white space in the message where the camera should be.

For more information about how Push works see this page. But @rabittn is right, notifications are transferred via Amazon which just forwards them to Apple’s APNS system. Your devices maintain a connection with APNS which alerts the phone to new notifications. There is no way for me to send any data other than simple text over that connection. Your HASS must be directly accessible from your device to be able to use the camera or any other media that you send in the payload that comes from your HASS.

I am have a config similar to these post but I do not receive any camera stream on my iOS device when I get notification. I looked as the config example for the camera stream notification but it does not work. My Hass is access able from the outside and both my cameras are visible in the app but I get not streams from any of them with notifications.

I am running the latest install.

@robbiet480 what am I missing?

Hmm, it’s seems like i need to use the force touch to see the stream, but it only works 1 time. I tried first from my wifi and got the stream ok. Tested again on 4G and got the spinning circle, connected back to my wifi, still the spinning.
Rebooted my phone and used 4G, got the stream fine. Connected to wifi, no stream, back to 4G and still no steam.

I just get the spinning circle like this:

It seems like some kind of bug.

     category: camera
     entity_id: camera.BackCamera

Hi! I had a similar problem and the stream was not being displayed because for some reason, HA, uses lowercase. I notced this on the log file, and changed the entity_id in my situation to “camera.backcamera” and it’s working great!
Note: In the camera definition i still kept the “B” and “C” with uppercase.

I am having the same issue with current iOS app public build.
Both in safari and chrome in the iPad the stream opens correctly, but from the app it just doesn’t load.