Camera: only getting one image every 5 seconds or so

I have setup my IPCam using this:

  - platform: mjpeg
    name: IPCam

I have tried using the Picture Entity Card & Picture Glance Card, I get a picture, but it updates REALLY slowly, every 5 secs or so. I wasn’t able to get it to work using the “generic” platform, and my IPCam doesn’t listen on port 554, so I assume it won’t support RTSP. It’s an old 720P camera.

To help further, here’s what I get when I connect to the HTTP server of the cam:

I got the mjpeg URL by going into the “No Plug-In Mode (for smartphone browser–JPEG)” and then right clicking on the image “copy image address”. Note that the framerate in the web browser is very acceptable, about 5-10 fps. I get the same URL for “Server Push Mode (For FireFox, Google Browser)”, altho the “pwd” is a different string every time I copy it. I’m not too sure how pwd works.

I have tried a different approach with

  - platform: mjpeg
    name: IPCam
    username: 'admin'
    password: ''

… I never got it to work.

The camera is a SriCam SP014. I have tried the ONVIF integration, supplying the host’s IP and port 81, not being even sure if the camera does support it (alibaba and some amazon listings are saying yes), but I get an “zeep.exceptions.Fault: Unknown fault occured”, with no real clues in the logs as to why it occurred.

To be honest, I’m not sure where to start, as most online posts seem to suggest that RTSP is the way to go, but i’m not sure how to check for sure if the camera supports it …

Any help appreciated!

I would try the onvif integration or ffmpeg with the RTSP url… there may be some info here:

Put the ‘Fing’ (Android link, pretty sure you can get it on IOS too) app on your phone and search your network. The camera will come up and show you what ports it is providing a service on. That will give you some clues as to what the camera can do for you

No luck, only telnet (23) , which is the typical chinese backdoor access, and 81, the web access … But nice tool!

Unless I can find an open port for RTSP, I can only assume it doesn’t have it.

How come mjpeg only shows one frame once in a while? Can’t we increase that with some parameter in HA ? I’ve tried opening the stream with VLC, just to isolate HA from the rest of the problem. I can open a stil lpicture with VLC, but that’s it.

I have a vstarcam which has a nearly identical interface with the browser selection… when you go into the settings of the cam and set the ip to static the open ports will stop changing randomly… Fun had with Vstarcam C7837WIP

Prior to that I kept doing a port scan because it kept changing

Also here for more sricam specific info

Well, I don’t have ports randomly changing, they’re not open to begin with :slight_smile:

Does it let you open them?

The web interface on port 81 doesn’t have kind of option for opening ports or to configure the ports …

For those wondering, I installed MotionEye in Home Assistant, connected to my cam as a network camera, and I get full FPS with motion detection.

I am a WYZE user and while there is no direct integration, I did find that with TinyCam Pro on a Fire Tablet and running the web server, I can add a generic camera entity and tell it to use the MPEG url and get live camera views in Lovelace. didnt have to flash to the RSTP firmware, so I still have the full wyze functionality