Can I rename a zwave entity id?

There doesn’t seem to be a way to change the entity Id of a zwave device. I used to use services zwave rename node, switched to using configuration / zwave rename node, and even edited the entity registry file. While I get the friendly name to change, I can’t get the actual entity id to change and am left with long ugly default names.

You can edit the entity_registry.yaml file and change the entity_id portion of the name (not sure about the domain) for your zwave devices.

3 important notes

  1. Shutdown home-assistant before editing the file
  2. Make a safe copy of the file first
  3. Do not edit the unique_id value for the device
1 Like

the name in the UI also pulls from the ‘name:’ in the entity_registry

you can click on the zwave item and click on the cog in the corner and rename it there.
i know 3 places to rename it is not ideal

What I do is use the z wave config UI to rename the node. Then I delete or rename the entity_registry file. Then I restart HA. It will then rebuild the entity_registry from the z wave controller using the node name as the base for the entity names.


worked like a charm, thanks

I’m running 0.86.1 and the rename node button is not available anymore, is there some other way to perform this action? renaming all entities related to all my zwave nodes will be a lot of work. Only changing the ‘parent’ sounds good (i managed to rename it in ‘Node information’ but that does not affect the releated entities

not within home assistant anymore…:frowning_face:

I’ve been saying the same thing for months but nobody seems to care. :frowning_face:

Yup same deal, also discussed here. They made the change to make Z-wave renaming similar to other items, without regard that it made renaming significantly harder, and they simply don’t care. More or less "you only set it up once so don’t complain. I just had to setup a new zwave network and rename a couple hundred things manually, super annoying, especially when you know how well the old method worked.


Use the find and replace function in VisualStudio Code on the core.entities file:)

I was experimenting to check whether HA is a good Domoticz replacement. I really like the release schedule, community, dedicated developers, wide hardware support etc. But I do use z-wave, which is more user friendly on Domoticz. I’ll check back in a couple of months (and keep following the podcasts).