Can I update Home Assistant via Docker?

I have been stuck on version 113.3 with an error that I can’t seem to get rid of:

[supervisor.utils] Can't execute update while a task is in progress

I have tried some fixes found here (mainly deleting disabling config, then updating, then adding back one at a time.) Let’s just leave it at, that did not go well. Had to reload my snapshot.

Forgive my docker-noobness, but can’t I just update via docker? As in, outside of Home Assistant? Isn’t that kinda the point of Docker?


Are you using HASSIO? If so i think you should be able to do via

ha core update # Updates HA
ha supervisor update # Updates Supervisor
ha host update # Updates OS
ha host reboot # After your comands reboot your system

For more information:

If not tell me and i will help you!

I’m glad to help!

1 Like

Are you using HASSIO

No? I don’t believe I am.

I can’t find my install notes so I’m not 100% sure, but I think I used the directions here: Absolute Beginners guide to installing HA on Intel NUC using Docker (Specifically: Installing Docker on Ubuntu). That being said, I do have add-ons and I thought that meant it IS hassio. I kinda lost the thread during the changeover with the naming scheme and the ‘official’ install methods that happened in the last few months. Now I’m completely lost.

I do remember running commands like

docker run -d --name="home-assistant" --restart unless-stopped -v /srv/homeautomation/hass-config:/config -v /etc/localtime:/etc/localtime:ro --net=host homeassistant/home-assistant

(or something similar)

Thanks for the help!

I am using docker-compose, and just updated last night:

docker-compose down
docker-compose pull
docker-compose up -d build --homeassistant

it is much easier than standard docker commands
take down your instance with

docker stop home-assistant

based on your docker command, i think you can make the following docker-compose.yml

version: '3'
    container_name: home-assistant
    image: homeassistant/home-assistant:stable
      - /srv/homeautomation/hass-config:/config
      - /etc/localtime:/etc/localtime:ro
    restart: always
    network_mode: host


My tips is running docker-compse just like @richieframe said. Beacause it’s easier to maintain.

My docer-compose.yml file looks like:

version: "2"
    image: homeassistant/home-assistant
    container_name: home-assistant
    network_mode: "host"
    restart: always
      - /srv/homeautomation/hass-config:/config
      - /etc/localtime:/etc/localtime:ro
##    devices:
##      - /dev/ttyACM0:/dev/ttyACM0
apt-get install docker docker-compose -y # Install required packages
docker-compose up -d # Start the compose file
docker logs -f home-assistant # Checking logs

When you found an solution:

:two::one: Somebody’s answer solved it!


Now, before you go… please take the time to mark that as the answer, you do that by selecting the three dots under the post:


Then select the check box:


Don’t forget too while you’re down there to click the heart to like the post, as a way of saying thank you.

Taken from: How to help us help you - or How to ask a good question

That wasn’t my docker command. That was just copied from the walkthrough example. I can’t find my notes so do not recall exactly the commands I did use. Which drives me batty because I take extensive notes typically.

Additionally, while looking at Portainer, I’m seeing hassio containers, so maybe I was mistaken. One being hassio_cli so maybe @vermium-sifell initial idea will work?

If not, is there somewhere I can look to ensure I have the right docker commands?

As always, thanks for the help.

Some research has led me to the following. Just want someone else’s eyes on it before I bork my setup.

via (specifically ‘updating’)

docker pull homeassistant/intel-nuc-homeassistant:stable

docker stop homeassistant 

docker rm homeassistant 

docker run -d --name="homeassistant" -v /home/user/docker/hassio/homeassistant:/config -v TZ=America/New_York --net=host homeassistant/homeassistant:stable  

I had to make some changes, it looks like there is a NUC specific build, as you can see in the first command.

The biggest piece I’m unsure of is the docker run command. Did I set that up correctly? I pulled the config location from Portainer and guessed at the timezone portion.


I just stumbled across a solution accidentally.

I ran the docker pull homeassistant/intel-nuc-homeassistant:stable command just for shits and giggles then clicked the Update button in Home Assistant and it worked. Didn’t expect that. Just was playing around waiting to get some confirmation on this post.

I’m guessing the initial [supervisor.utils] Can't execute update while a task is in progress error was docker related. I assumed it was hass related.

Thanks @vermium-sifell & @richieframe for the help!

This is popping back up again, and my fix from last time is not working. Must have been a coincidence that whatever the running task was had stopped. (And actually, twice because I was able to update normally once after this).

So I’m back to where I think I needed to be in my prior post (pull > stop > rm > run). My main issue is that I’m not confident I have my options correct.

docker run -d --name="homeassistant" -v /home/user/docker/hassio/homeassistant:/config -v TZ=America/New_York --net=host homeassistant/homeassistant:stable  

Is there a way to make sure I have them correct?

Will I have to set up all of my volume paths again?

I just created a little project which makes it easy to update DockerContainer (& Homeassistant Container) via Homeassistant Update entities:

MqDockerUp: A tool to monitor and update your docker containers from Home Assistant - Share your Projects! - Home Assistant Community (

1 Like