Can not integrate Netatmo

I am a complete novice with Homeassistant. I am currently converting my Magenta SmartHome to Homeassistant. In the course of this, I would like to connect my Netatmo weather station to Homeassistant.
At first glance, it looks quite simple. I’m adding the Netatmo integration in HA. A new tab opens in the browser with the Netatmo page. After logging in, I am asked whether I want to add the third-party app Homeassistant. I press the “Yes, I want to” button, the browser closes and I’m back on the page for adding the third-party app with the button I just pressed. I can now repeat this ad infinitum. But nothing happens.
I am on the current version of HA and run the whole thing on an HP thin client T630.
Does anyone have any ideas?

1 Like

Same problem.

Same Problem !!!

I got the same problem here as well!

Same problem. Watching this topic. I also tried with a Nabu casa URL and in incognito mode but no luck :frowning:
I have other instances running with Netatmo weather but this new instance and new set of probes doesn’t work yet.

This is solved in de next version of Home Assistant: Netatmo integration cannot go trough add process · Issue #103867 · home-assistant/core · GitHub

1 Like

THANKS ! Now it works!!!