Can´t use Media player in action

Hi everyone,

i´ve got ha problem.
i Try to use the new action “play media” in an automation to stream my Doorbell to a Nest Hub.
But i can´t use a Media.

first all the devices I try to use is grey and not black

and after i use one and i try to put a media i get this fail

can anybody help me what i´m doing wrong??

thanks for your help and sunny greatings


It seems not every player platform supports this.

Hello Nickrout,
thanks for your answere.
Do you know which platform support a Nest Hub?

It is supported here, in that my nest hub can be chosen in the automation ui. (and my google chromecast, and my nest speaker).

Perhaps your nest hub is turned off, in which case it will be grayed out.

Also this automation action is just using the media_player.play_media service, so can you use that service in the services ui in developer tools? ie here Open your Home Assistant instance and show your service developer tools.

Hello nickrout
Thanks again for your anwere.
All my google home and Nest devices works well and they are on.
Now I saw that I use google home in my intregidians and the stand that google home doesn‘t load.
But now I just can find the google assistant. When I try to reinstall it.
Sorry I’m not so fit in ha.

Sunny greatings from Bavaria.

Surely your problem is that Google cast is not loaded. Cast is the integration that you are trying to use.

Hello again,

oh men i think i´m to dump for HA :slight_smile:
i tried to reinstall the Google cast. it doesn´t work.


Than i tried to delete Google cast. That did not work either.
i push the delete button and restart HA but Google cast still there.

i´m using HA 2022.10.1 could it be that HA to new for the integration?

thanks for your help.


Logs, see How to help us help you - or How to ask a good question

Hello again,
sorry Nickrout for the German error message. :frowning:
i thought after the Oktoberfest everyone can speek german. :rofl: :upside_down_face: :wink:

Now i tried to downgrade my HA.
After i downgrade to 2022.2.6 I was able to delete my Cast integration.

after a restart i intallated Google Cast again.

But it still doesn´t work. in the Log i get this message.

Logger: homeassistant.config_entries
Source: custom_components/cast/
Integration: Google Cast
First occurred: 07:26:46 (1 occurrences)
Last logged: 07:26:46

Error setting up entry Google Cast for cast
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/”, line 327, in async_setup
result = await component.async_setup_entry(hass, self)
File “/config/custom_components/cast/”, line 48, in async_setup_entry
await home_assistant_cast.async_setup_ha_cast(hass, entry)
File “/config/custom_components/cast/”, line 30, in async_setup_ha_cast
user = await hass.auth.async_create_system_user(
TypeError: async_create_system_user() takes 2 positional arguments but 3 were given

what can i do to run my Google Cast again?

Thanks for your help and sunny greatings from Bavaria.