Cannot install HA OS (RPi3)

I am trying to install on my Raspberry Pi 3 with the image.
Have tried several os images (release 2023.11.* for Rpi3 32bit, 64bit, etc )
It fails every time. Also tried another public DNS ( / and route traffic through VPN (Amsterdam).

Could someone explain, why it so hard to clear install HAOS and how to fix the issue?

Thanks a lot for help!

Installing HAOS in a RPi is usually very simple and just works, so there is something else going on here.

Which RPi3 really matters. The HASS installation instructions call this out as the RPi3a a different beast from the RPi3b.

HASOS has a realistic minimum requirement of 1Gb of RAM, and really needs 2Gb+. The RPi3A+ only has 512Mb of RAM, and although the RPi3b+ works (and is ARM64), it is still a little underpowered for complex add-ons and ESPhome compiles.

Posting screenshots is discouraged as it makes offering support very hard - I can’t copy the failing URL to check it here.

Sometimes HASS installs can take a while to reboot, resize partitions, and download additional components, such as the current Home Assistant release. The errors look like you have a failed HASS docker container download.

There are several other posts here referencing issues with (GitHub docker container registry) with some suggesting storage issues on your device, IPv6, or DNS (no, it’s not always DNS):