Cannot remove songpal - no entries in configuration.yaml

HI all.

Question: How do I remove Songpal from my installation?

A while ago I tried to install Songpal, but that was not so interesting so I removed everything I added from the configuration.yamll. Now when I reboot my system, I get this error in the frontend:

Invalid Config
The following components and platforms could not be set up:
Please check your config.

I have no trace of songpal in ny configuration.yaml but in the home-assistant.log I still got errors concerning songpal.

So, how do I remove songpal from my installation?

Remove songpal from your config.yaml:

Remove lines like this:

  - platform: songpal
    name: my soundbar
    endpoint: http://IP_ADDRESS:10000/sony

Have you tried commenting out Discovery

@petro I do not have any text in my confinguration.yaml thas says “songpal”. A search results in 0 items.

@jmart518 I have no songpal-enabled devices that can be discovered.

Can you post your config to pastebin or a link to the file?

just add the ignore entry for it, check the discovery docs to see how to do this. if you have a sony device at home chances are that is why you see this, my sony tv is found by it so i disabled discovery for this component.


@dshokouhi That seems to have solved the problem. I also have a Sony-TV so that must have been the culprit.

Thanks a lot!


I have the same issue too. it/an error has been introduced in v65.x. if it is due to songpal or something else i don’t know but there is a bug-fix that lifts the songpal package to v0.7 that seems to fix it. (cant try myself as I’m on

1 Like

FYI Post for people having the same error as me.

I noticed a long time ago (should have sorted it a lot sooner!) that I had multiple log entries for …

2019-02-07 17:43:22 ERROR (MainThread) [homeassistant.components.media_player.songpal] Unable to get methods from songpal: Got an error for getSupportedApiInfo: NoSuchMethod (12): getSupportedApiInfo
2019-02-07 17:43:22 WARNING (MainThread) [homeassistant.components.media_player] Platform songpal not ready yet. Retrying in 180 seconds.

I couldn’t for the life of me figure out what was producing these errors. I have a oldish Sony Bravia TV and am using the Sony Bravia pre-shared key Custom Component. I tried commenting out all the media_player components I have setup in my configuration.yaml but was still getting the message.

as dshokouhi pointed out I got rid of these errors by adding an exclusion to the discovery component…

    - songpal

P.S. I am running 0.87 on HASSIO RPI3