Cannot save url and password


I need help with an irritating problem.

I cannot save the url and password in the app. However, I do get access both at home and remotely, i.e. I can connect and have access to almost everything in Home Assistant (except configurator and node-red). The problem is that I have to enter the url and password at least once a day.

It has worked before and I am not aware of any change that I made. The url and password is saved in my iPhone.

I have previously posted a long question with as much detail as possible but received no response.

I am again trying to get som help as the problem is really irritating.


Not sure why you are not being offered the option to save the login but you really should get a password manager.

One that works with iOS and your choice of PC web browser.

Not just for this problem with Home Assistant.

Enter the master password once per session in the password manager app, program or plug-in and have click/tap (or iOS fingerprint) access to unique, long and stupidly random passwords for each of everything you need to log in to.

Just dont ever forget your master password.

Thanks - I have solved password management with Keeper. Works great under iOS 12 where I can get Keeper to fill in the url and password, but it is a hassle anyway. Also some functionality is lost as I do not get the status and option to use location and notification settings.

1 Like

You could see if creating new credentials (a new user) fixes it, or - as a drastic solution - delete them all and create a new owner account.

The other thing to try is the Beta version of the app. I’ve found it very stable. In fact, try this before the new owner suggestion.

Wow - it worked!!! So happy. Thanks a lot. Do you in any way why I do not get access to the cionfigurator via my iPad?

Glad to hear it. For future reference of myself and anyone else who reads this - which one of the three options I suggested worked?

I don’t use Configurator. Are you using http or https (duckdns with lets encrypt)?

Which version of the App are you using? The old app didn’t work with configurator but the new one (beta) works. Are you using old app?

I solved the problem using the Beta version of the app.

As for the configurator:

I access via https.

It works on my Mac but not on the iPad.

Using the beta I still do not get access to the configurator.

Are you using the app or a browser on the ipad?

Switch to the beta app on that too if you aren’t already.

I am using the beta app.

If with exactly the same (double checked, all top menu options) settings as your iPhone - can you ping the ipad from your HA server (via SSH)?

I’m sorry but I do not know how to do that.

But I am not sure about my ssh-setup.


I am using the beta version 1.5.0 (on both my iPhone and my iPad). I used to get SSL errors but they are now gone.

I get acces to everything but the configurator and node-red in the devices. However on my Mac I get access to both the configurator and node-red as long as I am on my network. I do not get access remotely.

I am too much of a non-technical guy to know what to do.

Somebody has indicated that the SSH setup can be a problem. I have SSH set up with password which I know is not recommended. When I am looking at using the authorized key I get info on how to do that using Putty. However, I do not use Putty. I do not know if using an authorized key could be the solution and in that case how I go about setting it up from my Mac.

Some further information.

I can reach node-red remotely using duckdns from my iPad within Safari (not the app). I cannot reach configurator the same way.

I have set up node-red and configurator with panel_iframe as follows:

    title: Configurator
    icon: mdi:wrench
    url: https://192.168.x.x:3218
    title: Node-Red
    icon: mdi:arrow-expand-right
    url: https://192.168.x.x:1880