Can't get HA running on VM (Proxmox)

I’m trying to install a new instance of HASSOS on a VM on my Proxmox server. I cannot get it to work.

I’ve tried a manual installation with the latest QCOW2 image about 4 times now (starting from scratch each time). I’ve also found whiskerz007 install script (which seem awesome by the way and does successfully install).

The problem is… post install, it boots, gets an IP address from my DHCP server but the frontend doesn’t come up and networking appears to be failing. I’ve tried ~6 installs, same issue. I can’t login to the frontend with hostname:8123 or ip:8123. I cannot even ping the IP address that was assigned by DHCP.

From the CLI, any commands I type (i.e. “info”, “docker info”, etc.) are met with “Error: System is not ready with state: setup”

If I “login” to the host system, I can ping my gateway but nothing else, even on the local LAN. I am able to successfully change the IP address to a static, same result, I can ping my gateway but nothing else. Well, it quickly says “… is alive!”, I’m not sure I believe it’s actually sending a ping.

Any thoughts on how to troubleshoot this? Is there a log somewhere explaining why it’s in a “state: setup” or why networking isn’t working?

Thanks in advance!!

Same issue here but on Hyper-V

I’ve worked out it seems to be a DNS issue.Screenshot_20201027-220925
Those aren’t servers DHCP are giving out on my router.

Nothing further so far, have run a few nslookup tests and they don’t resolve anything. If I browse to it in a web browser I get “refused to connect”.

Have you followed along with this?

So… I’ve figured out my issue.

Appreciate you guys making the suggestions above. It isn’t DNS in my case (although that didn’t “just work” either).

The HASSOS implementation of Docker is using the network. So am I, for everything.

Gonna start a new topic to ask this but if anyone comes across this - is there any way to tell Docker to NOT use certain subnets? Namely

If this helps anyone in the future - I created a new subnet just for Home Assistant, used and Home Assistant comes up, services start and I can do the initial setup at IF I use a client on that same subnet.

But, the rest of my network is still on and the HASSOS instance refused to talk to my devices because it thinks they should all be in it’s docker network from what I can tell.

So… turns out this is solved elsewhere in the forum. You can tell docker to use a different address for that bridge network and it survives a reboot. Looks like I’m good to go. I created the daemon.json file per the last reply in this post…

1 Like