Can't get the backup to work

Not sure if it is supposed to go here, but here goes…

I run HA on a Rpi3+ on an SSD. A few weeks ago, without warning HA stopped working. I couldn’t access it any more. Reboot didn’t solve the issue. But, as I have the automated backup to google setup, I wasn’t worried…yet
I started out by loading a fresh HA install on the SSD through RPI imager. After that was started I choose to restore from a backup. I choose to restore the full BU, which is about 3GB. I anticipated a lengthy process, and in the end let it running for 5 full days and then I stopped it.
I repeated to do the fresh install and figured I may go for a partial restore then and selected everything, except the mariadb addon. I figured that the big database might be the issue and I don’t care that much about the old data anyway. But again, days passed with the system seemingly busy with restoring.

I stopped it again after days and did another fresh install on the SSD. Now I choose to do a partial backup, but only to restore the top option (the core I think?). I figured it might downgrade the install to the version I was using when HA stopped and when that is restored, try a restore from that version. But that also was stopped by me after 3 days or so.

Now I don’t know what to do anymore. The thought of having to re-install all my sensors and switches from scratch makes me want to throw everything out. I thought I was save with having weekly scheduled full backups, but it doesn’t seem to work. So, now i’m turing to you guys, to see if I have any options left.

I have to warn you, that i’m not at all a linux programmer or anything, so I probably can’t follow you guys with ‘under the hood’ kind of solutions. Unless they are perhaps described step-by-step.

One thing that came to mind is the version of the HA is was running when it stopped. I think it was version 10.5, but obviously can’t check that anymore now. The fresh installs I’m doing with RPI imager are v11.1. I don’t know if that’s an issue or not.

Beside i suggest you read the First Post in this Forum How to help us help you - or How to ask a good question. Then you might get an idea of what People would like to know, And see , instead of your repeating text saying about the same 3 times.

  1. Did you ever checked your logfiles, after, fresh Install and During/After the “Restore” attempts ?
    Logfiles says sometimes more, even if your not a programmer, and sometimes(Often) it’s what people wonders … What does your logfiles says ?
  2. There has been a few other “Issues” lately with Pi3 and upgrades, even thou it’s doubtful it will help you., in your case.
  3. I suggest you try to First!, install 2023.10.0 ( or 10.5 ), and then apply an “Backup” which you suspect is working … which means, don’t try to backup to the previous/latest backup you can find, go a little further back., or even further ( 1-2 month )
  4. Yes your DB (any DB) could involve “issues”, i would wait with that, if possible
  5. A backup is a tar(zip) -file, which you can open in any unzip/untar program, and from there actually be able to find some of your “old” configurations, and many files are “readable”, others you can actually “copy/paste” … If you know what you are doing.
  6. EDIT: this felt out somehow
    6+ Start a fresh install 2023.10.0(or earlier), then install all the addons/integrations, which have no i.e device-specific-configurations , like samba, file-editor etc etc.then try to update these
    Then go on to i.e partial-updates
    Don’t update to 2023.11.0


Dont even try to restore from this, download the backup-files, so you have them local, copy/paste them to you backup-folder, or somewhere reachable for your HA

1 Like

Here’s an ongoing thread where I’m trying to help someone with a restore issue:

I’ve seen:

  • Database restores reported that took days.
  • Reports that a fresh install might fail restoring a backup immediately, but the restore might work if you go through the full “new user on-boarding” and then restore.
  • Restores fail due to large media files in /media (fixable but needs some *nix skills)
  • Restores fail due to bad database data (fixable but needs some *nix skills)

I have to warn you, that i’m not at all a linux programmer or anything, so I probably can’t follow you guys with ‘under the hood’ kind of solutions.

Sorry to be the bearer of bad news but we can’t help if you don’t give us the evidence (logs, errors, etc) and beyond that, there are only ‘under the hood solutions’.

1 Like

Thanks for all your answers, much appreciated!

  1. No, unfortunately I have not seen any log files. In all honesty, I wouldn’t know where to go and see them if the system is all the time showing me the restoring view
  2. This is interesting. I would like to do that, but how do I do it? Where are older versions in the RPI imager? I only see the latest there (v11.1)
  3. Okay, so my thought are correct on that, so I will leave that out
  4. I haven’t tried looking into that file, but can copy pasting be done on a normal windows machine? I have no Linux knowledge at all I’m afraid
  5. Again, I would like to install an older version that I WAS running before the issue. If you could point me to where and how I do that with RPI imager then I can go from there and try your suggestions

Thanks for your reply. This is surely worth trying to do!

And about that evidence. Yes, of course I would like to provide that to get better help, if I only knew how to.

  1. logfiles can be found in i.e UI, under /SettingsSystem/Logs
  2. You have to connect a monitor and a keyboard to your PI, and learn to “work” through the “Console” (it’s like CMD in windows) … yes it’s Linux !, but by typing -h you get a -help info, and AO is to read the screen, it’s not Greek :slight_smile:
    4 Yes winzip or 7-ZIP owrks fine
    5 i don’t know how to use RPI imager, have you looked through all options ?, for “older/privious” ha -versions , or does RPI imager have a “Console”, where you can type commands ?

@Henk99 Releases for 2023.10.0 you find below ( Scroll to the bottom )

PS: just change the version number in the url, to get an older …or newer

@Henk99 And here you find an “alternative” way of installing onto your disk, from i.e windows ( Note: some people had problems using Balena, i have only used it ones, and it went ok )

1 Like
  1. I don’t know how to get into the UI while this restoring is in progress. So far, I had to break off the restores because they took so many days that I felt it wasn’t right.

  2. This sounds very daunting to me already. Apart from that, I don’t have a spare monitor to use for that unfortunately.

  3. I’m going to try into this angle first I think. Try to get that version I was running installed. Thanks for that link to the older versions. RPI imager is just a handy windows program that let’s you install all kinds of RPI OS’s. HA is only one of the options it presents, but at this point in time, it only shows version 11.1.

Nine days? Damn, you’re patient.
Is the backup an .img or .tar file?

If it’s a .tar file then you can use 7Zip to extract your .yaml files.

1 Like

Haha, that’s not entirely true…
I had to travel for work and just thought I’d leave it restoring while I was gone. Hoping it would be long finished when I would be back. I wouldn’t have waited that long if I was at home looking at that screen!

The full backup file is a TAR file. Which files in that backup should I restore, once I get to them?

I just looked at one of my backup tar files. You will find all of your .yaml files in homeassistant.tar.gz\homeassistant.tar\data\

You can use these files to rebuild your system- one device at a time.

Have you tried a partial restore of just the core? Then add some folders, then some integrations.

Yes, tried to do only the top option, the core. But that also took more than 24 hrs and then I stopped it. Perhaps I should try this option longer?
I think my next trial will be to install a fresh version 10.5, instead of the v11.1 that is installed by RPI imager. Hopefully, that will allow restoring the backup, which is made in that version.

So, I got a little further in my quest…

This time, I only did a partial restore and only selected the top option (core only) to be restored. I have let it run for almost a day, but finally it finished. I was very happy to see that basically my whole configuration was there. The only thing that was not working was the MariaDB addon.

I have reinstalled and configured this addon now and all seems to be working again. I’m very relieved I didn’t have to re-do my whole HA setup from scratch.

In the full backup that I have, I still have some months of data in the old MariaDB folder. Is there any way to put that back through Winscp or something? I have already looked around on the SSD folders with Winscp, but I couldnt find a folder with a similar name as mentioned in MariaDB addon.json (“location”: “/data/addons/core/mariadb”).
If I look with winscp in the folder root\data , it’s empty.

It’s not a big deal, if I can’t restore the old DB, but if possible, I could use some help :wink:

To summarize, thanks a lot all. I’m very happy it’s working again!

There’s a web front-end for SQLite which gives direct access for SQL commands, but don’t know about MariaDB.

Wow! Makes me glad that I am running on an Intel NUC. Restores take only a few minutes.

I avoid working directly with databases. It’s just too easy to totally brick the system.

What about

/supervisor/addons/data/core_mariadb ?

From/In your Backup-file

NOPE: sorry above thats just the .json ( old mariadb configuration )