Cant get Zigbee2MQTT to run container (Docker Synology) *SOLVED

Can you get into the terminal for the docker container for Z2M?

If so, try this: ls /dev/ttyUSB0 and ls /dev/serial/by-id/ and see what both of those commands do.

the first command opens the folder. the second returns; ls: cannot access '/dev/serial/by-id/': No such file or directory.

since I am dumping so many logs anyway… When I copen up the terminal through the docker UI. The terminal freezes pretty much instantly as the container crashes.
This is what it shows at that time;

(I have reached the limit of replies I can send in a day :frowning: So I will be back in 19 hours…

You do know only ZHA or Zigbee2MQTT can use the Skyconnect at the same time ? So you have to disable ZHA before starting Zigbee2MQTT.

I have to admit I only figured this out last night after my latest post. I disabled the ZHA integration in the home assistant devices & Integrations. And then launched the container. But I still get the same error as above.
Maybe I should disable it and then reboot HA And all the containers?

It seems MQTT has a page on the error I get but no luck for me yet.

OMG I FINALLY FOT IT WORKING!!!

Turns out all I had to do was REMOVE ZHA instead of disabling it.
Now using

  port: /dev/ttyUSB0
  adapter: ezsp

did the trick!

Thanks everyone for your help! I am up and running! :smiley:

1 Like