Can't integrate Hassio with SmartThings

I have searched the forum and anywhere else I can (wide open net) and haven’t found a solution to this problem. There was a similar post from mamssw on June 11, but they were utilizing Let’s Enrypt addon and NGINX says it isn’t necessary with their addon. Their scripts are almost identical to mine (except Let’s Encrypt). The reply they received wasn’t helpful as neither of us use NabuCasa. I tried Let’s Encrypt before NGINX too. Way too much information about what doesn’t work, along with the knowledge that there are 5 thousand ways to set up Home Assistant and none of them actually easy. I tried Raspbian with HA in a Python environment also before abandoning that setup.
I am running Hassio on a Raspberry PI 3, with DuckDNS, NGINX, and Configurator addons. I initially had problems just setting up HA so that I could access it via HTTPS (, but I can do that now. According to the logs, DuckDNS and NGINX are working properly.
My configuration.yaml contains
base_url: https://
# ssl_key…
I found a post here that said to # the http: comments and had originally done this for all and got the message The base_url for the http component must be configured and start with https:// when trying to integrate Smart Things. #ing the ssl paths apparently allowed me to access via https and #ing the base url makes no difference either way as does using http, https, or just domain. No affect on ST integration (same message)
Ports 443 and 8123 are forwarded. I do not have to use with :443 or :8123 since 443 is forwarded.
I am probably doing (or not doing) something simple. I hope someone will pity me for my ignorance and complete lack of any luck whatsoever. Again, is Configuration.yaml the only place that makes reference to http… base_url…https?

Update: I turned logging on in home asistant and get this (redacted) when I try to integrate smart things: 2019-07-13 17:14:24 DEBUG (MainThread) [homeassistant.components.smartthings.smartapp] Setup endpoint for http://192.168.0.xx:8123/api/webhook/be88b4e804xxxxxx223ddc9908ca3a270f892ef33#####08238b23beac69f

I also see this : 2019-07-13 16:51:17 INFO (MainThread) [homeassistant.setup] Setting up http
2019-07-13 16:51:17 INFO (MainThread) [homeassistant.setup] Setup of domain http took 0.0 seconds.
Should that say https somewhere and possibly the ip address? Where is it getting this from - Configuration. yaml has
base_url: (currently), but i have tried almost anything including # ing this entirely.

As an afterthought, because I did this on my local network (which is http:) I accessed HA from my cell at https: via duckdns and it doesn’t register anything in the log and of course still gives me the http/https error

Have you followed this exactly, and gone through all the troubleshooting tips?

I have actually checked this part and tried a few dozen times. The token is easy to generate and I don’t have an MQTT bridge since I never had home assistant working. Entering the token into the smart things integration is where I get the error - The base_url for the http component must be configured and start with https:// and therefore I don’t get to the install app portion. It says to have " Home Assistant setup for remote access via a domain name secured with SSL." I am assuming the should be replaced with my and I can access HA remotely if I enter this, but not if I add the “www.” and/or the “/docs/configuration/remote”.
In any case, I think I am missing something in step 3, which I believe refers to the http: entry in configuration.yaml. I have an entry for my duckdns domain there (even though it’s not indented here properly because of the edit restraint)
I am willing to try other installation methods, as I have already tried most and failed. It seems like they had an all-in-one solution previously, but what kind of fun was that? After all, IT is nothing if not ever-changing and unpredictable.

If you properly quoted your code it would be possible to read it. See item 11 here How to help us help you - or How to ask a good question

What are you talking about? Why would you add www or /docs/configuration/remote to your url?

1 Like

Why would I enter exactly what’s printed? Because the other way wasn’t working and I was told to follow the steps “exactly”. I only did that AFTER I tried the way I thought it should be.
Luckily, all the trying to convey what I was or wasn’t doing wrong and writing and rewriting lines to Configuration.yaml apparently paid off. I went back to Configuration.yaml and pushed the line with http: all the way left and indented the base_url with two leading spaces. This produced " The base_url is not accessible from the SmartThings cloud/aka the internet" when I tried the ST integration via token. I searched that and found a thread that had more info. I removed the port from the base_url : and tried the token again - voila!! I knew it had to be something simple, but thought I had already tried all the syntax and formatting junk. Now at least I’m to the FUN portion of Home Assistant - right???
Thanks for the help and ,more importantly, for your patience and desire to help.

I cannot see where you think it says to enter that stuff, or are you confusing a link to another part of the docs?

Anyway, pleased you have made progress.