Can't startup HA again or auto run or install HACS

Hi all
I recently installed my HA to a vm and followed the debian guide.
It was running and then i tried to install HACS.

Firstly i can’t figure out how to get back and run the ‘hass’ command to start it? e.g.

(homeassistant) [email protected]:/srv/homeassistant $

How do i switch this to a service so in the Web UI if i hit restart it’ll restart, last time i had to run the hass cmd?

Then following the
i tried to run the wget as homeassistant but i can’t run it as this user.
Then i tried to switch to the user that i installed everythign with but it gets a “cannot write to ‘-’”

Any help would be appreciated.

Docker is the way. Until then you need to create a systemd unit for it.

1 Like

Thanks. @Tinkerer
I might kill my install and try the Docker version as I’ve got some log errors.
Haven’t really used docker much. I’ve provisioned this VM for HA, do you have a link i could follow, to give as much of it’s resources to the HA docker install?

As always, start with the official docs.

You can just install Docker on that VM if you want. If your VM host runs Linux then it’s likely to be a lot better to install Docker on the host. You can’t do that if the host is running Windows.