Can't update hassio to 0.105.x

Tags: #<Tag:0x00007f781139ede8>

Got eactly the same error out of the config check…
I think it’s better to wait

Just tried a config check on my current installation version to test for potential bugs in the config checker, and unsurprisingly, it passes…

Had the same issue with 0.105.1 but tried again with 0.105.2 and it worked on the first try.

I’m back. Fresh install on Rasp Pi 3b+. HassOS 3.9.
So hassio is 105.2, but I still cannot start Addons. Get a red button when I click start.


Somthing is definetly off.
I’m using a 64Gb SD card just formatted in exFAT using SD formatter.

Here is the error, after I uninstalled and tried to reinstall. No idea what is going on here.

20-02-07 10:45:58 ERROR (SyncWorker_12) [hassio.docker.interface] Can’t install homeassistant/armv7-addon-mosquitto:5.1 -> 404 Client Error: Not Found (“no such image: homeassistant/armv7-addon-mosquitto:5.1: No such image: homeassistant/armv7-addon-mosquitto:5.1”).

Edit:
Restarted Supervisor and MQTT installed and started. Other addons did not start.

Errors are random. No cannot install DuckDNS.
Anybody know what these errors mean?
20-02-07 12:13:38 ERROR (SyncWorker_9) [hassio.docker.interface] Can’t install homeassistant/armv7-addon-duckdns:1.10 -> 500 Server Error: Internal Server Error (“readlink /mnt/data/docker/overlay2: invalid argument”).

Update:
Ran the command - hassio su repair - I was able to install DuckDNS but still not able to start any addons.
For those trying to update, there was another command that you can try - hassio ha update
That might help.

it’s similar with me:

System log
20-02-07 18:10:24 INFO (SyncWorker_6) [hassio.docker.addon] Start Docker add-on hassioaddons/appdaemon3-aarch64 with version 5.0.1
20-02-07 18:10:24 INFO (SyncWorker_10) [hassio.docker.addon] Start Docker add-on homeassistant/aarch64-addon-configurator with version 4.2
20-02-07 18:10:25 INFO (SyncWorker_13) [hassio.docker.addon] Start Docker add-on hassioaddons/log-viewer-aarch64 with version 0.7.0
20-02-07 18:10:25 INFO (SyncWorker_2) [hassio.docker.addon] Start Docker add-on homeassistant/armv7-addon-ada with version 0.9
20-02-07 18:10:30 INFO (MainThread) [hassio.tasks] All core tasks are scheduled
20-02-07 18:10:30 INFO (MainThread) [hassio.core] Hass.io is up and running
20-02-07 18:10:35 INFO (MainThread) [hassio.api.security] /host/info access from a0d7b954_appdaemon3
20-02-07 18:10:35 INFO (MainThread) [hassio.api.security] /host/info access from a0d7b954_logviewer
20-02-07 18:10:45 INFO (MainThread) [hassio.api.security] /dns/info access from a0d7b954_logviewer
20-02-07 18:13:00 INFO (MainThread) [hassio.homeassistant] Updated Home Assistant API token
20-02-07 18:26:00 INFO (SyncWorker_4) [hassio.docker.interface] Restart homeassistant/raspberrypi3-64-homeassistant
20-02-07 18:27:42 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
20-02-07 18:32:58 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.105.2
20-02-07 18:32:58 INFO (SyncWorker_10) [hassio.docker.interface] Update image homeassistant/raspberrypi3-64-homeassistant:0.104.3 to homeassistant/raspberrypi3-64-homeassistant:0.105.2
20-02-07 18:32:58 INFO (SyncWorker_10) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-64-homeassistant tag 0.105.2.
20-02-07 18:38:37 INFO (SyncWorker_10) [hassio.docker.interface] Stop homeassistant application
20-02-07 18:39:38 INFO (SyncWorker_10) [hassio.docker.interface] Clean homeassistant application
20-02-07 18:39:40 INFO (SyncWorker_13) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-64-homeassistant with version 0.105.2
20-02-07 18:40:10 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
20-02-07 18:42:21 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
20-02-07 18:42:26 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
20-02-07 18:43:11 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
20-02-07 18:43:16 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
20-02-07 18:43:56 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
20-02-07 18:53:59 WARNING (MainThread) [hassio.homeassistant] Don't wait anymore of Home Assistant startup!
20-02-07 18:53:59 CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback!
20-02-07 18:53:59 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.104.3
20-02-07 18:53:59 INFO (SyncWorker_11) [hassio.docker.interface] Update image homeassistant/raspberrypi3-64-homeassistant:0.105.2 to homeassistant/raspberrypi3-64-homeassistant:0.104.3
20-02-07 18:53:59 INFO (SyncWorker_11) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-64-homeassistant tag 0.104.3.
20-02-07 18:54:01 INFO (SyncWorker_11) [hassio.docker.interface] Stop homeassistant application
20-02-07 18:54:01 INFO (SyncWorker_11) [hassio.docker.interface] Clean homeassistant application
20-02-07 18:54:03 INFO (SyncWorker_10) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-64-homeassistant with version 0.104.3
20-02-07 18:54:33 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
20-02-07 18:56:33 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
20-02-07 18:56:48 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
20-02-07 18:59:09 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
20-02-07 18:59:44 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation in progress
20-02-07 19:03:35 INFO (MainThread) [hassio.homeassistant] Home Assistant pip installation done
20-02-07 19:03:40 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
20-02-07 19:03:40 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.104.3
20-02-07 19:03:41 INFO (SyncWorker_10) [hassio.docker.interface] Cleanup images: ['homeassistant/raspberrypi3-64-homeassistant:0.105.2']```

Hi all,

2020-02-07 20:00:39 WARNING (MainThread) [homeassistant.loader] You are using a custom integration for garbage_collection which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.
2020-02-07 20:00:40 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=70 from 2020-02-07 18:49:59.112347)
2020-02-07 20:00:42 ERROR (MainThread) [homeassistant.core] Error doing job: Unclosed client session
2020-02-07 20:00:46 ERROR (MainThread) [homeassistant.core] Error doing job: Unclosed client session
2020-02-07 20:01:33 WARNING (MainThread) [homeassistant.components.binary_sensor] Setup of binary_sensor platform meteoalarm is taking over 10 seconds.```

Hi all, well these are the logs of my upgrade to 0.105.2 Hassio in a proxmox environment
Will talk to devs as well....

The following all failed. Stuck on the preparing Hassio page overnight.

  1. Fresh SD card 64 GB
  2. Old SD cards formatted with SD formatter or the guiformatter
  3. It worked once but the errors mentioned above returned, so I had to start from scratch
  4. Now trying Hassos 3.7 instead of 3.9

It is strange that only a few of us have this issue.

HassOS 3.7 done under 10 mins.
Error - cannot Start Addons still occuring.
Hassio version 0.105.2

Guys, I figured it out, at least for me. Try try until you go crazy or succeed.
IPv6 - turn this off on your router or set static DNS.
That’s it. All issues solved and updates now working.

So what where your steps? Don’t fully understand the steps you took to get it working for yourself. Perhaps you can clarify your self a bit more, to help us out?

I got it installed by running the command
hassio homeassistant update —version 0.105.2

Only issue now is supervisor tells me an update is available to 0.104.3
I don’t see all the nice new icons for supervisor either

20-02-08 10:15:32 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.104.3
20-02-08 10:15:32 INFO (SyncWorker_4) [hassio.docker.interface] Cleanup images: ['homeassistant/qemux86-64-homeassistant:0.105.2']```

This is what I get after a upgrade.
Running Hassio in Proxmox. 15% of the 32Gb storage used.
Supervisor and Hassio to latest version upgraded successfully.

Tried upgrading now at least 10 times, still no success.

As you can see above, I tried everything I found online.
What worked for me was, disabling ipv6 on my router. On my router I can enable or disable ipv6.
Seems to be working fine now. I’ll report if I have any more issues.
I also read that having a static DNS can fix these issues.
Scratch all that above.
ipv6 on or off had temporary effect.
Two things:

  1. The only thing that worked was a fresh install of Hassio on a card formatted with SD card formatter. With the latest version ofcourse.
  2. I got the addons to work on all cards by the following. Delete addon, restart HA (under configuration>server controls>restart. Then once the system is back up, install the addon and start. Don’t click anywhere else, if you want to add another addon, restart and follwo the same steps. This has got to be a bug in the nes HassOS.
    If that does not work start Portainer from the addons and unhide all containers and remove the container of the addon that does not start or install with errors.
1 Like

Hi,
I had the same problem and resolved it.
if you have netatmo integration in your configuration.yaml file, comment it, restart HA and try again.
From 0.105.2 netetmo is integrated :slight_smile:

Hope, it helps

2 Likes

@mmychu will try again, did these steps 8-2-2020 already.

I have had some upgrade problems in the past and only recently rebuilt my system due to a microSD card failure (it went “read-only”… weird for a microSD card)

So, are we all saying that the upgrade (on a RPi3) still doesn’t work and only a full re-install works?

cannot update from 104.3 to 105.2. Here’s my log when launching the check tool:

starting version 3.2.8
[12:35:46] INFO: Don't worry, this temporary installation is not overwriting your current one.
[12:35:46] INFO: Installing Home Assistant: latest...
[12:35:46] INFO: Please be patient, this might take a few minutes...
Fatal Python error: initsite: Failed to import the site module
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site.py", line 73, in <module>
    import os
  File "/usr/local/lib/python3.7/os.py", line 27, in <module>
    import stat as st
ModuleNotFoundError: No module named 'stat'
[12:35:47] ERROR: An error occurred while installing Home Assistant:

Same issue…

Just leaving here my situation, in case it helps to debug:

Raspberry Pi 4 running 104.3. Update to 105.2 failed. The system is not responsive (and I can’t access the logs, since I did not have the SSH add-on installed).

Fortunately, I had a backup ‘before updating’ so thought that the fastest way was to reinstall HassOS and restore.

System up, I do a wipe and restore… System not responsive
hmmm…
I flash HassOS again… System up, Do a restore all (Including HA 104.3 this time, in case it’s the new version…) System not responsive…

My system has fixed IP address (in HassOS configuration) and fixed DNS.
I don’t have the add-ons that I’ve read on this thread that cause problems.
I have:
Configurator
NodeRed
MariaDB (the DB is running on a different system to avoid SD wear)
Mosquitto

I’ll try to tinker a bit more today… It’s the first time that an update fails on me…
R