Can't upgrade to 2021.11.3

Hi, I tried several times to upgrade from 2021.11.2 to 2021.11.3 (mostly because the frontend does not load fully after 2021.11.2, and I hope the upgrade will fix that) and all I get from Supervisor log is the following:

21-11-13 10:58:14 ERROR (SyncWorker_1) [supervisor.docker.interface] Can't install 404 Client Error for http+docker://localhost/v1.41/images/ Not Found ("no such image: No such image:")

Both the system and the raspberry have been rebooted multiple times, but the issue still remains.

Check your network and especially the DNS that Home Assistent is set to use.

And the space left on your SD/SSD/HDD

the space left is only 9.4GB, I wonder why. it’s a 64GB SD card!

Open an ssh shell and enter:

ha su repair
1 Like

now there’s 43 GB of free space and it upgraded successfully. thanks!

Please consider marking my post above with the Solution tag. It will automatically place a check-mark next to the topic’s title which signals to other users that this topic is resolved. This helps other users find answers to similar questions. For more information, refer to guideline 21 in the FAQ.


This did not fix it for me :frowning: and I have the exact same error. What exactly do I need to check at my DNS settings?

You should probably create a new thread for your question and then type what you have tried.
This one is solved already, so many will not open this thread up again and your problem might not be the same, even though it looks like it on the surface.

Try this one and bring the result to the new thread.

Open up a SSH on the HA installation (maybe use the SSH web terminal addon).
Then type ha resolution info

You should get something like the below text if everything is fine.

See this: