CC2531 and SSD incompatibility issues

I do several test scenarios and I can achieve a conclusion: CC2531 and a SSD can’t be connected together to a Raspi4.

I have HA OS running on a Rpi 4 8gb on an SD card and all went fine. I have only 1 zigbee device connected (Sonoff MIni).
When i try to migrate to an SSD its when problems begin.

With both (CC2531 and SSD) connected to any USB 2.0 OR 3.0 or veiceversa i cant connect to the zigbee devices.
I’t seems a problem of signal interference between usb’s.
Even I try a usb extensor for the CC2531, with no luck.

I go back, remove the SSD and put the SD back, and all went fine.

So i think the only solution to use a SSD on my Rpi4 it’s to buy another USB zigbee coordinator, not the CC2531.

Anyone have the same issue?
Anyone is using an SSD with a coordinator, both connected to usb? Wich device (coordinator) do you have? Im seeing the SONOFF usb donggle, but dont know if it will work with SSD.

You should put your zigbee stick on a usb extension cable and keep it as far away as possible. It is an interference problem, but this usually solves it.

No, it hasn’t fixed it.
I’ve already tried a usb extender and it didn’t work.

Funny then that there isn’t one in your picture.

I wouldn’t use the cc2531 in any event. See here for recommended devices. Supported Adapters | Zigbee2MQTT . If you want to completely electrically separate it from the pi, get an ethernet based one.

Interference has been mentioned in many threads, I’m sure you will find more info.

1 Like

The picture is from one of the many scenarios that i’ve tested.

Now im with ssd to usb, and cc2531 with a 3mtrs usb extensor and looking in zigbee2mqtt logs saw this:

[21:14:17] INFO: Handing over control to Zigbee2mqtt Core ...
> [email protected] start
> node index.js
Zigbee2MQTT:info  2022-05-28 21:14:23: Logging to console and directory: '/config/zigbee2mqtt/log/2022-05-28.21-14-21' filename: log.txt
Zigbee2MQTT:info  2022-05-28 21:14:23: Starting Zigbee2MQTT version 1.25.1 (commit #unknown)
Zigbee2MQTT:info  2022-05-28 21:14:23: Starting zigbee-herdsman (0.14.27)
Zigbee2MQTT:error 2022-05-28 21:14:24: Configuration is not consistent with adapter state/backup!
Zigbee2MQTT:error 2022-05-28 21:14:24: - PAN ID: configured=6754, adapter=6754
Zigbee2MQTT:error 2022-05-28 21:14:24: - Extended PAN ID: configured=00124b001cdd495c, adapter=00124b001cdd495c
Zigbee2MQTT:error 2022-05-28 21:14:24: - Network Key: configured=01030507090b0d0f00020406080a0c0d, adapter=01030507090b0d0f00020406080a0c0d
Zigbee2MQTT:error 2022-05-28 21:14:24: - Channel List: configured=11, adapter=20
Zigbee2MQTT:error 2022-05-28 21:14:24: Please update configuration to prevent further issues.
Zigbee2MQTT:error 2022-05-28 21:14:24: If you wish to re-commission your network, please remove coordinator backup at /config/zigbee2mqtt/coordinator_backup.json.
Zigbee2MQTT:error 2022-05-28 21:14:24: Re-commissioning your network will require re-pairing of all devices!
Zigbee2MQTT:error 2022-05-28 21:14:24: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2022-05-28 21:14:24: Failed to start zigbee
Zigbee2MQTT:error 2022-05-28 21:14:24: Check for possible solutions
Zigbee2MQTT:error 2022-05-28 21:14:24: Exiting...
Zigbee2MQTT:error 2022-05-28 21:14:24: Error: startup failed - configuration-adapter mismatch - see logs above for more information
    at ZnpAdapterManager.determineStrategy (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/manager.ts:229:35)
    at ZnpAdapterManager.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/manager.ts:63:26)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:100:27)
    at start (/app/index.js:110:5)

After seeing this message, i saw this:

Channel List: configured=11, adapter=20

So, i edit the /config/zigbee2mqtt/configuration.yml, and change the line channel to 20 (it says 11).

channel: 20

and now it works!!

You should also shield both the SSD drive as well as the Rasberry Pi (by using metal enclosures), and be sure to connect Zigbee Coordinator in a USB 2.0 port (not USB 3.0) via a long USB extension cable.

Understand and remember that Zigbee signals are weak and are very sensitive to RMF/EMI/RMI interference so the technology relies on a strong Zigbee network mesh (meaning many Zigbee Router devices) and it makes it much easier to troubleshoot and find real problems if have already optimized your setup and environment to work around that.

Recommend implement workarounds for EMF interference, read these tips which apply to all set ups:

(check out whole too with your perticual set up)

and later also follow best practices:

PS: Also know CC253x hardware is obsolete so recommend that upgrade to CC2652P dongle, see ex:


I had a similar problem when I first tried to migrate to a SSD.

For other reasons, I got a Sonoff ZigBee controller stick (thank you, radio migration!) and just last night tried again with the exact same SSD and everything works perfectly fine.