Change Listening mode of media player

Thanks, error in manifest.json - Missing “,” was causing problems


A few DEFAULT_SOUND_MODES are not working as expected on the Onkyo TX-NR636. Which YAML are you referring to to adapt the changes in step 3?

Hello, I have had a VSX-LX504 for a week and am desperate until I found dfas here. Should it look like this?

The question arises why the “sound_mode_list:” does not work. Am I making a mistake there?

You have a sound mode list, what is not working?

when I enter the sound mode list, I get this error message.

I have no idea what you mean by “when I enter the sound mode list”

is that your yaml config? If so I think the key is sound_modes: not sound_mode_list:

yes that is the yaml config. The key is sound_modes: But the format is also wrong. That is how it goes.

It will look like that. But that is always wrongly described above.

Thank you very much for your hint. I would have found myself dead :upside_down_face:

Are there plans to get @koying’s code into the standard onkyo integration? Have you submitted a PR at all?

1 Like

I have been using this code since May 2023 with an Onkyo TX-NR717. It has been working great, however, I have never been able to get “stereo” to work. It does nothing when I select it. I can call it with a shell command “stereo: onkyo --host --port 60128 LMD00” but selecting via the sound mode selector doesn’t work for me. Has anyone else run into this and found a solution?

I used Node-RED to change the listening mode

Thanks. Not sure that will help with getting the “stereo” option to work in the listening mode drop down selector in the media card. To clarify, picking any other option, including all the default selections in koyings code, will work. Selecting “stereo” doesn’t do anything.

I can confirm that it does not always switch to stereo.

For example, if my source is set to radio, the sound_mode will switch to stereo.

If the source is set to an HDMI source, like Bluray, it won’t switch to stereo, but it will switch to All Channels Stereo.

This kinda makes sense.

I usually have it switched to Direct, because I exclusively use it for playing video files from the media player.

That is interesting. My input is usually on STB/DVR as my Apple TV is on it or CD/TV. I tried radio and phono and I still could not select stereo from the drop down.

can call it from a shell command which is fine - just curious why selecting from the drop-down doesn’t do anything. I’ve tried a few variations from “stereo:Stereo”. All the other sound modes work. It could be something specific to the TX-NR717.

In mine there is “Stereo” and “All Channels Stereo” - I believe the latter also puts the stereo signal on rear/side speakers.

You can modify onkyo custom component code in file like I did. There is a condition to execute raw LMD00 command (means stereo mode) instead of executing “listening-mode stereo” command which also doesn’t work for me.

    def command(self, command):
        """Run an eiscp command and catch connection errors."""
            if command == "listening-mode stereo":
                result = self._receiver.raw("LMD00")
                result = self._receiver.command(command)
        except (ValueError, OSError, AttributeError, AssertionError):
            if self._receiver.command_socket:
                self._receiver.command_socket = None
                _LOGGER.debug("Resetting connection to %s", self._name)
      "%s is disconnected. Attempting to reconnect", self._name)
            return False
        _LOGGER.debug("Result for %s: %s", command, result)
        return result
1 Like

Hey, thanks! This worked.

Can someone show me an example of what the manifest.json should look like? The one I downloaded from koying has a lot of data in it.

Okay. So my bad, I had somehow downloaded the wrong files. That’s cleared up, however where do I put the version number?