Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007f2040f6a420>

#488

I had this working but it has since started giving me the below error whenever a broadcast is attempted… any ideas what to do?

Error sending message. Response 500: INTERNAL SERVER ERROR:

NoneType: None

I tried stopping the add-on and restarting, didn’t help


#489

Can this component handle multiple language?

I have my Google home in English and Italian. I wish to broadcast in English, but it speaks the broadcast message using the Italian accent, which is bad


#490

Is there any update on the : Broadcasting From : PRoblem?


#491

It is done in the backend by google. Unless they give an option via the api it cannot be removed at this time.


#492

Thanks man! I recalled myself Hal on Google.

Now let’s get the roomate to freakout when 7 Googles minis have Hal announcing stuff!


#493

Hey @AndBobsYourUncle i have a quirky situation

when i call http://hassio.local:5000/command?message=turn on all lights it works flawlessly owever if i call
http://hassio.local:5000/broadcast_message?message=resume spotify i get a 500 error. Any Idea why this is the case?


#494

Im trying to create a couple automations around the message command, has anyone tried sending a command that asks for a pin, set a delay and respond?

I can start my car with google and Id like to create a couple scripts for opening the garage starting the car and handing the lights, thermostat, etc…

I have a routine that works perfect everytime just saying ‘start the q60’, Infiniti comes back and asks for a pin. I say the pin, it startsd. Ive tried setting delays and a few other things but no luck yet. But I do see the commands making it to infiniti, I see the ‘remote engine start failed’ mentions in my history.

I thought I was finally going to be able to get this to work, Ive wanted this automation forever. Please help if you have some ideas, thanks!


#495

Is it possible to get the predefined messages (dinner time, movie time, I’m home etc) to work as well?


#496

I’m wondering the same thing, have you found a solution @sunglass_guy?

My use case: Because Nest Secure can only be turned on with Google Assistant, I’m using this add-on to turn on the alarm via HA by sending commands like Set Nest Secure to Away and Guarding. It works, which is awesome, but I have no way of confirming that it works. What I’d like to do is use this add-on to ask Google What’s the status of my security? and then parse the response to determine if it’s actually on or not.

If that’s not possible, I’m curious if anyone has any other suggestions? E.g. is it possible to send these commands and actually hear the Google Assistant’s response through one of my Google Home Minis? Another option is to check the Nest home_away state (because it gets set to away after the alarm is on), but that doesn’t happen unless you’re leaving the house and the countdown to actually turn on the alarm has finished.

As an aside: Not sure why Nest is making this so hard. I get why they wouldn’t want to expose an API to disarm the system, but what’s the risk in letting third-party applications turn the alarm on?


#497

Can you arm Nest Secure with a Routine in the Google Home app? If so, you could run Android-x86 in a VM and use Tasker/Autoinput to get the Home app in the VM to run the routine on a specific Assistant speaker, in which case the response is spoken through that speaker. I do something similar to turn off the Home Hub displays in my master suite at night, because the only way to do so is with a routine running on that device (You can’t just say “turn off display on XXX”, for whatever reason).


#498

Had a similar issue - found any fix for it?


#499

not yet. I think I need to re-do the auth setup


#500

Tried that but no such luck on my end.


#501

This add-on has stopped working for me. The log is below which says that the auth file has been deleted… but it is definitely still there…

[Info] Install/Update service client_secrets file
Traceback (most recent call last):
File “/hassio_gassistant.py”, line 144, in
credentials.refresh(http_request)
File “/usr/local/lib/python3.5/dist-packages/google/oauth2/credentials.py”, line 136, in refresh
self._client_secret))
File “/usr/local/lib/python3.5/dist-packages/google/oauth2/_client.py”, line 237, in refresh_grant
response_data = _token_endpoint_request(request, token_uri, body)
File “/usr/local/lib/python3.5/dist-packages/google/oauth2/_client.py”, line 111, in _token_endpoint_request
_handle_error_response(response_body)
File “/usr/local/lib/python3.5/dist-packages/google/oauth2/_client.py”, line 61, in _handle_error_response
error_details, response_body)
google.auth.exceptions.RefreshError: (‘deleted_client: The OAuth client was deleted.’, ‘{\n “error”: “deleted_client”,\n “error_description”: “The OAuth client was deleted.”\n}’)

Does anyone know what to do to get this going again?


#502

Hi all,
I had managed to get this working without any issues.
Today, a notification I expected didn;t happen so I tried triggering a broadcast manually again (via the API) but nothing happens, the Google Homes in the house stay silent.
I tried uninstalling and going through the OAuth process again but no dice.

I can confirm that the request males it to the Google Servers (the API metrics shows my call happening without errors, too!)

Anyone else having issues with this?


#503

I actually just realised that the “command” endpoint seemed to work (eg I can do “/command?message=turn on all the lights”)

But for some reason the boradcast stay silent, which is a shame as I was keen to use this to give me notifications

And it looks like the normal Google Home “broadcast” feature works if I just speak it out loud.


#504

Have you checked my activity for any clues? https://myactivity.google.com/myactivity

IPV6 was also a issue at some point, not sure if that has been fixed now. Search in this thread for more on that.


#505

Thank you! That fixed it! I had searched this topic but did not find this comment. Cheers


#506

What is the fix? I’m getting the same behavior, but don’t know what to do about it.
Thanks in advance!


#507

The fix is for me was to disable IPv6 on my router