Home Assistant Community

Community Hass.io Add-on: Google Assistant Webserver (broadcast messages without interrupting music)

hassio-addon
Tags: #<Tag:0x00007fcf5009ab60>
#529

Does this work with Chromecast devices (like a chromecast audio)? Currently trying to get it working and Google says the broadcast feature only works on google home’s, not chromecasts.

#530

Great add-on! The only problem is that it doesnt seem to work with Spotify on any Google speaker or any device?

Commands like this works great, with any lights:
/command?message=turn on the spotlights

But commands like this:
/command?message=play music on spotify on kitchen speaker
/command?message=play spotify on office speaker
/command?message=play my playlist club music on living room speaker

…gives me {“status”: “OK”} and Google Assistant recieves the commands but gives me reply like this (I can see the reply in my activity log):

  • “Sorry Im not sure how to help with that”
    or
  • “Sorry I cant help with that yet”
    or
  • “Sorry I dont understand”

This is really weird, as the commands are obviously being recieved by Google Assistant, but it just doesnt do anything. Besides Google Home Minis and Home Hub, I also tried with Onkyo amplifier (built in chromecast) but same problem.

Any idea whats wrong?

Thank you

#531

Media controls don’t work at all with this addon, but they do with this container: https://community.home-assistant.io/t/google-assistant-webserver-in-a-docker-container/

1 Like
#532

Interesting, thank you!

I also just realized there should be another workaround for this. By using the Webserver Addon to call a custom Routine in Google Home. In the custom routine within Google Home/Assistant I add an action, something like “Play Spotify on Living Room Speaker” and theoretically this should work as the action request is handled by Google Home Assistant and not by the HA addon. I Cannot test this atm as Im not at home, but will confirm later.

The whole reason for doing this is because I want to be able to wake up any or all Google Minis/Hub devices at home with a button card in Lovelace, and make them active sources in all the available Spotify playlist addons for Home Assistant. This could solve a dealbreaking issue for many people, as currently, inactive Google Home decives are not listed as Spotify sources in HA/Lovelace until I wake them up by pushing Spotify music onto each of them using voice commands (which is really a pain).

#533

You should definitely try using the routine to play music, but when I tried that a few months ago it didn’t work either.

#534

I created temporary Routines (not being connected to home Wifi as Im not home) for each speaker:
“play music on Living room speaker” routine called “Spotify in Living Room”
“play music on Kitchen speaker” routine called “Spotify in Kitchen”
…etc

And running the routines through my smartphone Google Home app (not through home wifi) works great, as Spotify changes to the speaker at home I assigned for each routine.

But the problem is that running the routines with the Webserver addon doesnt seem to work:
/command?message=Spotify in Kitchen

this gives me the activity:

  • “Sorry Im not sure how to help woth that”

So it seems like the Webserver plugin is not able to start Routines :frowning:

I will look into the container-solution you suggested instead, @claytonjn and will report back. Thanks!

#535

It can do Routines, but not if there is any Media or Casting involved. This currently only works with the above mentioned GA Webserver Container.

#536

Ok, you got my attention!
Who is capable and wants to create an add-on for the assistant-relay?
Nobody?
:0(
@frenck :sweat_smile:

1 Like
#537

hopefully someone… because this add-on has been troublesome for me, looking for an alternative

#538

Wassup homie?

#539

So and so…
I tried to study how to do it (addon google-relay), but I don’t have the knowledge to make an addon.
You are the addon man :grin: sorry if I tag you :slightly_frowning_face:
You also made templates to create addons, but I’m not a developer, would you do the add-on google-relay for us?

Anyway, thank you for everything you have created… thanks a lot!

#540

Not anytime soon… I’m pretty stacked up with things in progress…

#541

yes yes of course… good job! :+1:

#542

log:
[Info] Install/Update service client_secrets file
[Info] Start WebUI for handling oauth2
[17/Mar/2019:19:56:48] ENGINE Listening for SIGUSR1.
[17/Mar/2019:19:56:48] ENGINE Listening for SIGHUP.
[17/Mar/2019:19:56:48] ENGINE Listening for SIGTERM.
[17/Mar/2019:19:56:48] ENGINE Bus STARTING
CherryPy Checker:
The Application mounted at ‘’ has an empty config.
[17/Mar/2019:19:56:48] ENGINE Started monitor thread ‘Autoreloader’.
[17/Mar/2019:19:56:48] ENGINE Serving on http://0.0.0.0:9324
[17/Mar/2019:19:56:48] ENGINE Bus STARTED

Can someone please help. I am getting the same messages in my log. How do I authenticate? Where must I go to get the token? Is it my Client secret?

Thanks.

#543

Hi! This is some pretty awesome work! I’m using Hass-io, a google home and google home mini. I was able to get everything up until this point setup for using the command option. However, I can’t get the broadcast message playing on my devices. Am I missing something? I am trying both from the browser and from my automation.
Here is the log from the Add-on:
INFO:werkzeug:192.168.1.23 - - [03/Apr/2019 15:54:31] “GET /broadcast_message?message=doorbell HTTP/1.1” 200 -
DEBUG:root:None

#544

If your Google Home is on the same local network WiFi, then try disabling IPV6 on your router. I heard that causes problems, and it’s completely down to how Google decided to try to limit the broadcasting feature.

#545

Awesome! I know I currently have that turned on. I’ll try it when I get home!
Update: Thanks @AndBobsYourUncle!!! I disabled ipv6 and restarted both of my google home devices.

#546

I can’t get the addons to start up at all. And I’m getting no log output from the addons of Hassio Supervisor to indicate what the problem is.

I’ve generated an OAuth google_assistant.json which I’ve placed in /share/google_assistant.json. I try and start the addon via the Hass.io control panel but it just doesn’t spin up. And running a log check from terminal produces nothing. Where am I going wrong as I seem to be doing everything recommended in the setup instructions.

core-ssh:~# hassio addons logs fe49a976_google_assistant_webserver

core-ssh:~#
#547

Did you have any luck fixing this? I have the same problem.

#548

Nope. I can’t work out why it’s not working. And the lack of log output makes it practically impossible to determine what’s going wrong.