Home Assistant Community

Community Hass.io Add-on: Node-RED

hassio-addon
hassio-repository
Tags: #<Tag:0x00007f374f7e1b10> #<Tag:0x00007f374f7e1930>
#304

Every time I get node red working and make any update it goes to hell. I updated to 77.3 and started to getting
4 Sep 15:18:31 - [error] [server:Home Assistant (http://hassio/homeassistant)] Home assistant connection failed with error: Connection to home assistant could not be established with config: http://hassio/homeassistant<password redacted.

This happens so often I am about ready to abandon node red. I have read all of the threads in the forums and most don’t make any sense because most posts assume you are a software genius…

I have tried to set the server to my ducks address, https://hassio/homeassistant, https://192.168.1.104:8123 and nothing works.

Why does node red break so often and is there anyone that might help.

I have deleted all configuration nodes, restart node red and and still get

[error] [server:Home Assistant (http://hassio/homeassistant)] Home assistant connection failed with error: Connection to home assistant could not be established with config: http://hassio/homeassistant<password redacted.

This make no sense.

Thanks

1 Like

#305

I have the same… Not starting, no message in the log. What´s goingon? I realy like the Nodered idea but afte having all automation in there and now niet working…

0 Likes

#306

Seems like a new Hassio Supervisor is released: 129

It did change a lot! Which might be part of the issues. This needs to be checked with the Hassio devs. The add-on uses the official supported and recommended way of connecting to one Assistant. Why it keeps breaking… Yeah well… I like to know that as well.

2 Likes

#307

I don’t remember if I’ve posted on this thread already, so this may be redundant.

A few weeks ago, I had NR and HA running on the same pi, and was getting significant delays when I asked Alexa to do stuff. I have alexa local implemented in NR.

Moved NR to an unused pi3 I had. Was pretty straightforward. Started with a fresh stretch lite, updated and upgraded to make sure everything was the latest.
Think I also needed to install git (apt-get git)

Then installed NR using the instructions from the NR webpage. Installed the third party tools, like alexa local, copied my stuff over, just by copying with samba but I think there is an export import feature that is how you are supposed to do it.

Setup connection to HA using the same password you use to login with, and it connected.
After that, no more connection problems. I thought I was having it one time, but it turned out my HA crashed. So I’ve added a ping test in NR, to notify me if my HA PI crashes.

So if you’re having NR/HA connection or time lag issues, I really recommend trying NR on another pi

0 Likes

#308

If you want to run node red on another dedicated pi, I wrote this up
node red install

Did it from memory of what I did a few weeks ago, so hopefully it works for you. Should be right.

0 Likes

#309

I’ve seen they have released supervisor 130 which contains a related bugfix.

0 Likes

#310

Did upgrade to supervisor 130 and it is once again working.

0 Likes

#311

I have also thee error with NPM after installing alexa.local node

Does this node not work with the current release?

0 Likes

#312

Error: bind EADDRINUSE 0.0.0.0:1900

Something else is already using port 1900… a port can only be used once. Find out what is using that port (e.g. another add-on) and decide which one to keep (or disable the 1900 port on the conflicting add-on by making the field empty).

0 Likes

#313

I’m on supervisor 130 and it’s not starting NR and no error messages…

0 Likes

#314

Eddie_chen I can tell you the communication between NR and Hassio is a finicky beast. Once I upgraded to supervisor 130 I set up my duckdns address in this format (https://ducksaddress.duckdns.org:8123. I set the password to my hassio password. I then had to go into each flow and double click each node that has the little blue triangle and say DONE which then set the servier and cleared the blue triangle. Once I did this for all nodes that required the procedure I DEPLOYED them and they started working. In the past I have used https://hassio/homeassistant with my password. I have read the forums and you get different many answers as to how to set up the server. Try different ways until you hit the magic bullet.

Good luck

0 Likes

#315

I can’t even get to the screen with all the flows. I’m stuck at the Hass.io add on detail screen trying to get NR started. There are no error messages, clicking on start and nothing happens.

0 Likes

#316

Eddie_Chen. You didn’t give much information but here is what may be happening. If you are trying to open the NR front end from the Hass.io add-on page and you are using ducks dns you should see the https://duckdns.org address you use to access hassio. If you have not port forwarded 1880 try http://192.168.1.xxx:1880 where the tcp address is the one assigned to you pi. Another issue I ran into is the browser you are using. I had the best luck with firefox. Chrome often left me hanging with a blank screen.

Post the http address you are trying to go to some maybe I can help.

0 Likes

#317

There is another unofficial implementation of node-red that I have found works well and does not trip over all these authentication problems: https://github.com/korylprince/hassio-node-red/

0 Likes

#318

Sorry for the lack of details. I have Hass.io running on a RPi3, not using any dns service so both HA and NR are running on 192.168.0.102 port 1880 for NR.

NR was running fine yesterday, this morning I restarted the RPi, then noticed my automations in NR wasn’t working. Checked the Hass.io add on page and NR wasn’t didn’t start up on reboot as it usually would. I hit the start button (next to uninstall), nothing happens. Hit the refresh button for the logs, nothing. Tried this several times and reboots and restarts, nothing.

I’m on Supervisor 130 and Hassio 0.75.2

1 Like

#319

My nodered IS working, have checked the log and is full of below errors.

I am with HASSIO 0.77.3 and supervisor 130

10 Sep 15:13:01 - [warn] [api-call-service:Toggle Watchdog] Error calling service, home assistant api error
10 Sep 15:13:01 - [error] [api-call-service:Toggle Watchdog] Error calling service, home assistant api error

0 Likes

#320

Eddie_Chen: Well I don’t know what’s going on. Here is my configuration for NR. Maybe there is something in there that will help. I have fought with NR a lot but alway had information in the log that helped me. Are you looking at the log at the bottom of the Hass.io: add-on details page or are you looking at the system log? I have never has NR not begin to start and produce log entries as it builds the nodes etc.

{
“log_level”: “info”,
“credential_secret”: “a;kdjfladskjflasdjf;askdjf;”,
“users”: [
{
“username”: “budlyte”,
“password”: “mypassword”,
“permissions”: “*”
}
],
“http_node”: {
“username”: “budlyte”,
“password”: “mypassword”
},
“http_static”: {
“username”: “budlyte”,
“password”: “mypassword”
},
“port”: 1880,
“ssl”: true,
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”,
“require_ssl”: true,
“system_packages”: [],
“npm_packages”: [],
“init_commands”: []
}

Blockquote

0 Likes

#321

This morning I noticed lots of errors (added to delays and automations not running):
"Error calling service, home assistant api error"

I’m running the same versions as you

0 Likes

#322

I am experiencing the same issues - it is a shame that Node Red sometime that unreliable. With the majority of the automation in node red it is a real issue for me. Makes me think to go back to YAML.

Any chance somebody can have a look into this?

0 Likes

#323

It’s interesting to me why more people aren’t having connection problems with NR to Hassio. I looked at my router last night to see what name was attached to the PI3. When the pi requested it’s TCP address from the router, the router attached the name HASSIO to that address. I tried https://hassio:8123 and was able to connect to HA so I think in some cases the router does some DNS conversion. I need to do some research on this. Trying that same address in NR and nothing. Just get back continuious messages that it can’t connect. It may be something to do with USERID/Password. I did try the password but still didn’t work.

Would be great if someone more knowledgable than me could comment on this.

0 Likes