Home Assistant Community

Community Hass.io Add-on: Pi-hole

hassio-addon
hassio-repository
Tags: #<Tag:0x00007fcf4faf2910> #<Tag:0x00007fcf4faf2780>
#387

@HypnoToad Not as an option in Pi-hole.
The easy workaround would be: Just give that specific device different DNS servers manually.

#388

Did you get this working? I’m trying the exact same thing. Other add-ons do work (logs viewer, idea, terminal) but the pinole proxy doesn’t seem to work with Caddy

EDIT:
I think it might have something to do with that pinole doesn’t run on https

#389

Thanks that was worked, I’ve manually put the google DNS servers in the device I use for testing and it bypasses pihole.

I wish I had installed it sooner, it’s suprising how much get blocked by pihole. :slight_smile:

#390

Hello,
1st of all thanks for the brilliant code for home assistant and for the add-ons.
I’ve installed the pi-hole and configured some hosts definition for all the devices in the house but unfortunately on the dashboard i still got the IP of the devices and not the hostname.
There are no issues with the logs and the configuration is ok.
Host configuration :slight_smile:“hosts”: [
{
“name”: “PC1”,
“ip”: “192.168.0.6”
},
{
“name”: “PC2”,
“ip”: “192.168.0.104”
},
{
“name”: “Router”,
“ip”: “192.168.0.1”
}
]

The dashboard tile for Top Clients (total) and Top Clients (blocked only) are still displaying the IP and not the hostname.

I’m not using the Pi-hole for the DHCP service because router is responsible for that.

Thanks,

#391

Is it possible to have Pi-Hole and Adguard Home installed and used at the same time in Hassio?

#392

Hello,

First of all, thanks for this addon, i really like the product!
I only have one question.
Installing this addon and get it working is all a piece of cake.
When i setup the ip of the raspberry as DNS server on a windows laptop it work just fine.
Later on i tried to setup pi-hole as DHCP server, but thats not working for me, it just kills my internet on the entire network after a few hours.
What i did:

  • Disable DHCP on my router
  • Enable DHCP on pi-hole
  • Settings on Pi-hole, DNS > Enable “Listen to all interfaces”
  • For now everything is working fine, the adds on the Android devices are gone to, this is how it should be.

The trouble starts when i want to use internet a few hours later, i can’t connect to the wifi and i can’t connect to the my router, i can’t connect also when i’m connected directly with a LAN cable.
The solution to get back online is to reset the router to factory settings again…

What is going wrong here?

Thanks!

EDIT: I can’t just put the DNS server in the router, thats disables by my internet provider…

#393

when you connect to the router using a LAN cable while your internet doesnt work, do you still get a DHCP address?

#394

No, i get the message “connected without internet”…
Can’t connect to the router do i can’t see anything.

#395

If you are plugging in with a LAN cable and still getting provided a DHCP address have you tried manually entering your internet service providers DNS on the network card?

#396

Yes tried that, could connect to the router.
I think it is because of a shitty router-modem from my internet provider.
When i don’t have an internet connection my lan connection also is gone, thinking of buying a quality router myself…

#397

Sounds like that’s a good idea. I also have an average service provider router which I intend on changing out at some point.

#398

Greetings Hass.io folk. I finally got around to adding PiHole to my HA instance. I am interested to understand if I need to worry about sd card space and management/housekeeping. Are the logs rolling or do I need to regularly purge etc?

#399

Hi, is the implementation of ingress expected? Thank you.

#400

Hi, I use my pihole instance (not in hassio) also as a DHCP server and I assign static IP addresses for all my devices.
I wish to move from a separate pi3 with pihole (and dhcp) to this addon

In pihole the file is in /etc/dnsmasq.d/04-pihole-static-dhcp.conf

Can I achieve the same with this addon?

If I try to add it manually in pihole web-ui (the hassio one) I receive this when I save a static IP address

There was a problem applying your settings.
Debugging information:
PHP error (2): fopen(/etc/dnsmasq.d/04-pihole-static-dhcp.conf): failed to open stream: No such file or directory in /var/www/html/admin/scripts/pi-hole/php/savesettings.php:68
#401

Hi Everyone,

I am having trouble installing this add-on. Clicking on “Install” within the add-on store in Hassio just gives me a red button. When checking to Hassio logs I see this error:

ERROR (SyncWorker_14) [hassio.docker.interface] Can’t install hassioaddons/pi-hole-armv7:3.0.2 -> 500 Server Error: Internal Server Error (“readlink /mnt/data/docker/overlay2/l: invalid argument”)

When looking through similar errors on other threads, I thought I had a more fundamental issue with my Hassio install, but all other add-ons function normally, I am able to install other add-ons, and via Glances I have checked to see that I have more than 20GB of free space on my local file system.

Does anyone know how to solve this issue? It seems pretty basic in that the Hassio supervisor cannot mount the requested docker image. Any ideas would help.

Thanks

#402

Help! Any assistance on my above message would be very helpful. Is my only option to start fresh and restore an image???

Thanks

#403

Hi with Pi-hole Hassio addon it is possible to switch pihole off temporarily with a url command ?

The normal version requires a simple url
http://yourpiholeipaddress/admin/api.php?disable=300&auth=PWHASH

How could I achieve the same with the hassio version?

Il need this because family sometimes need to connect to some specific website that doesn’t work if pihole is on, I wish to have a quick way to disable it momentarily

#404

You might want to consider switching to AdGuard if you are interested in that…
This got merged yesterday:

Expected to land in Home Assistant 0.95

1 Like
#405

Hello, does it exist a way to stop and start the PI-HOLE addon for example with an Automation?

I’ve tried to call “Hassio.addon_start” or “Hassio.addon_stop” with this parameter:

{
“addon”: “a0d7b954_pi-hole”
}

but HASSIO returns me:
… invalid slug a0d7b954_pi-hole (try a0d7b954_pi_hole) for dictionary value @ data[‘addon’]

I tried it and it doesn’t work even with

{
“addon”: “a0d7b954_pi_hole”
}

Thanks in advance for any clarification
best regards

#406

I was hoping this feature would be added to Pi-Hole or Adguard. Thanks again as always.