Config file on SD card

I had the same problem where my SD card didn’t boot anymore (not even network) but I could still read it on the PC. I was able to recover my configuration file using a special tool. I forgot the name but can check tonight when I get home.

1 Like

Would really appreciate it mate. No luck with anything I have tried so I have just reprogrammed all the basics for now.

I haven’t had time to redo the majority of stuff.

So this is the tool I used and the location on the SD card where you can find the configuration file:

10 Likes

For mac users: https://backstage.paragon-software.com/home/extfs-mac/ helped me

EDIT: Never mind, I figured it out. I followed the Paragon suggestion above and it was much easier.

I’m using Paragon too, got mounted resin-root and resin-updt but I’m unable to find the config files:

  • Nothing on /var/lib as @Dingle shows
  • Nothing on /resin-data
  • Nothing on backups
  • Not even searching for “configuration.yaml” I find it

Thanks team - this thread saved me!

Hello all,

I had the same issue and was desperately searching for the config files on the SD card. Using a Linux system I finally found them under

//hassos-data/supervisor/homeassistant/

Might be helpful for others searching too :slight_smile:

Andreas

9 Likes

Thanks, you saved my day

Thanks all, found the files on ths sd-card my Windows 10 computer using LinuxReader https://www.diskinternals.com/linux-reader/

Edit: Installed Paragon and it worked even better, allowed me to edit the files as well.

1 Like

I had the same issue and was desperately searching for the config files on the SD card. Using a Linux system I finally found them under

//hassos-data/supervisor/homeassistant/

I am currently trying to recover my data after my MicroSD mount broke off of my Raspberry Pi. I am able to access the ‘…/supervisors’ and view my files so this was super helpful!!

One issue I am having though, is I am trying to copy //hassos-data/supervisor/ssl and I am getting a permission denied for the fullchain.pem and privkey.pem files. I’m trying to copy all the files to a folder on my laptop (Running Xubuntu on a Thinkpad) so that I can follow this guide and put all of my stuff on Github. I am still kind of new to Home Assistant so I don’t know if these files are critical to the configuration or not.

Thanks to all, this post saved my long time effort

Thanks! very helpful.
It was inside the supervisor folder for me.

Used Disinternals Linux Reader and found if under /mnt/data 1/ Supervisor

What files should I keep?

Any json files are necessary?

Also there is a folder for backups; are those the image backups that I made?

thanks

After hours of searching the disk. Found this thread

Thank you, life saver! :+1:

I want to thank you for posting the path where the information is. You saved me hours of work. I really appreciate it

Thank GOOOOD you found this. I was literally clicking and going through every folder via DiskInternals Linux Reader and I was trying the folder directory, but every post I came across asking for such was met with the typical petty response of “if you’re using hassio you shouldn’t need access to this” or the famous “you don’t know what your doing” etc. Thank you!!

You can take the SD card, and try to mount it on a Linux system or VM. When I played with it on a test system, I was able to mount /dev/sdc and change to the /supervisor/homeassistant directory. As best I can tell, this maps to the /config directory in hassio.

I tired a Virtual Ubuntu box on Windows 10: Problem was no USB mapping without enhanced mode. In enhanced mode, I couldn’t get into the VM. 2 hours wasted.

I then tried DiskInternals Linux Recover: that looked promising, I could see files! But after falling into that rabbit hole and the hassos-data/supervisor directory being empty, I gave up fiddling with settings to try and restore data. Another 2 hours wasted.

How I finally got in to the config… I got another SD card imaged with Ubuntu, booted it up on the PI, then plugged in a memory card reader with the old SD card and the config was there waiting for me all along. I wish I had done that first time!