Config file on SD card

Hi silvrr,

It is booting up enough to show an IP on the network but SSH or samba share do not seem to work with it. I have no idea what I have done.

Is there no way to recover these files straight from the micro SD?

Cheers,
Patrick McKinnell

If you have a linux box It should pull up all the partitions and you can search through it. However, on Windows Im not sure how to view the other partitions.

Hi silver,
I don’t have a Linux box but I do have other raspberry possible running raspbian. I’ll try plugging a card reader in when I get home from work.

Windows definately does not show anything.

Cheers,
Patrick

If you don’t have a linux box, you could try installing VirtualBox or another VM host of your choice, then installing a lightweight linux distro like Alpine in there. You’ll need to tell the host software to attach the SD card to the VM guest, and then probably manually mount the SD card, but it should be possible to access it. I know that’s a lot of steps but at least they are all free :slight_smile:

I had the same problem where my SD card didn’t boot anymore (not even network) but I could still read it on the PC. I was able to recover my configuration file using a special tool. I forgot the name but can check tonight when I get home.

1 Like

Would really appreciate it mate. No luck with anything I have tried so I have just reprogrammed all the basics for now.

I haven’t had time to redo the majority of stuff.

So this is the tool I used and the location on the SD card where you can find the configuration file:

11 Likes

For mac users: https://backstage.paragon-software.com/home/extfs-mac/ helped me

EDIT: Never mind, I figured it out. I followed the Paragon suggestion above and it was much easier.

I’m using Paragon too, got mounted resin-root and resin-updt but I’m unable to find the config files:

  • Nothing on /var/lib as @Dingle shows
  • Nothing on /resin-data
  • Nothing on backups
  • Not even searching for “configuration.yaml” I find it

Thanks team - this thread saved me!

Hello all,

I had the same issue and was desperately searching for the config files on the SD card. Using a Linux system I finally found them under

//hassos-data/supervisor/homeassistant/

Might be helpful for others searching too :slight_smile:

Andreas

10 Likes

Thanks, you saved my day

Thanks all, found the files on ths sd-card my Windows 10 computer using LinuxReader https://www.diskinternals.com/linux-reader/

Edit: Installed Paragon and it worked even better, allowed me to edit the files as well.

2 Likes

I had the same issue and was desperately searching for the config files on the SD card. Using a Linux system I finally found them under

//hassos-data/supervisor/homeassistant/

I am currently trying to recover my data after my MicroSD mount broke off of my Raspberry Pi. I am able to access the ‘…/supervisors’ and view my files so this was super helpful!!

One issue I am having though, is I am trying to copy //hassos-data/supervisor/ssl and I am getting a permission denied for the fullchain.pem and privkey.pem files. I’m trying to copy all the files to a folder on my laptop (Running Xubuntu on a Thinkpad) so that I can follow this guide and put all of my stuff on Github. I am still kind of new to Home Assistant so I don’t know if these files are critical to the configuration or not.

Thanks to all, this post saved my long time effort

Thanks! very helpful.
It was inside the supervisor folder for me.

Used Disinternals Linux Reader and found if under /mnt/data 1/ Supervisor

What files should I keep?

Any json files are necessary?

Also there is a folder for backups; are those the image backups that I made?

thanks

After hours of searching the disk. Found this thread

1 Like

Thank you, life saver! :+1: