Home Assistant Community

Configuration.yaml

#1

Hello :slight_smile:

i’m really new to Home Assistant and i need some help.
i conected WinSCP to my raspberry pi and tried adding something to the configuration.yaml file but i got an error (error code 3)

after some digging around on the internet i installed the vim edditor on my raspberry and that worked allright but anytime i add something to the .yaml file save it and reboot the pie my Home Assistant page wont load.

0 Likes

#2

You need to use an editor where you can see hidden characters like tabs, carriage returns, etc. That is because Yaml is very strict, so you need to use something like Notepad++ with Winscp or install Samba so that you can reach those files via a share and edit them, seeing if there are any invisible characters keeping your HA from starting.

Change to the /home/homeassistant/.homeassistant/ directory and “tail” the home-assistant.log file to see why it is not starting:

tail -f home-assistant.log

0 Likes

#3

i can see the files and open them with notepad++ in WinSCP but when i try to save them i get an error message saying i don’t have permission to edit the file

0 Likes

#4

Who are you logged in as?

0 Likes

#5

the default pi user

0 Likes

#6

I solved this issue by the “dirty” way login in with WinSCP as Root to my raspi, that way you can change every file!

by default SSH is not enabled for root so you have to edit a file:

0 Likes

#7

Are you using Winscp and do you have “ignore permission errors” enabled? Take a look at the Bruh Automation video on Winscp here: https://youtu.be/hFDVB2H6TNo?t=176

0 Likes

#8

Having “ignore permission errors” does not help, ill check out that video tho see if anything helps

0 Likes

#9

You honestly might want to look at the whole video so you can get an idea of everything he did. HA is quite alot to handle even when all steps are followed…

0 Likes

#10

Followed all his steps but nothing helps, do i need to setup the sambo server for winscp to work ?

0 Likes

#11

Got it to work :slight_smile: now when i insert some code in the configure.yaml file my home assistant wont load

0 Likes

#12

Check the journal sometting might me wrong in your configuration

0 Likes

#13

Change to the /home/homeassistant/.homeassistant/ directory and type:

That will possibly show you why home assistant is not loading.

0 Likes

#14

did you try your code in http://www.yamllint.com/ ?

0 Likes

#15

Even though you seem to have your setup working regarding the file editing, you might consider using the HASS Configurator. It’s quite easy to setup and helps keeping the yaml-syntax correct since it’s showing you the whitespace characters.

2 Likes

#16

Thank you guys so much for your help, i got it to work by installing Samba file sharing got my home assistant up and running ! :slight_smile:

1 Like

#17

@Johannesr95 If you got that working, you might also want to try @danielperna84 's Hass Configurator…

0 Likes