Configure WiFi connection

Unfortunately this did not work…which makes no sense.

nmcli radio

shows that I have wifi adapter (shows Enabled), as do all 4 columns/settings (all show Enabled)

nmcli con show

shows an entry for wireless with a UUID – but the adapter has just – showing and it is White - whereas the Ethernet is Green.

I am dumbfounded and lost.

Curtis

This worked for me from an SSH terminal while device was still on eth0. You just invoke it as

ha network update ... (also removing the extra space before ipv6-method)

Launch a reboot, disconnect ethernet cable, and there she is on WiFi!

Hello. I’ve tried this method, and I get this on network info:
vlan: null
wifi: null

I’m using a mini PC. Any ideas of what’s happen?
Thanks in advance.

Thank you!! My desktop is MacOS, and it will not remount the flashed SD card without repairing the file system, which makes it unbootable. I was thrashing around with the CLI before reading this, works great! Thank you again!!

Thanks. This worked as expected and is way better way to set up WIFI than going through USB stick configuration file.

How can I delete previous WiFi connections & PSKs?

HA 2022.9.0b I have the WiFi set up and working on a Pi 4b. I use it as a connection to a sandboxed network however if the access point is not available it connects to previously connected AP. This is not desirable, but I see no way to “forget” previous connections.

Running HA 2022.9 on rpi3B, I can’t get make the switch from connected eth to wlan; I tried several things:

  • on UI (Settings->system->network) setting wlan IP4 fixed IO and ssid fails on save and all entered is forgotten.
  • above (@vctr) suggested HDMI connects fails; there is no HDMI signal; apparently not enabled on HA.
  • ssh (over eth) and ssh app are working, but above suggested nmcli command is not present
  • Suggested (HA doc on github) boot device file /CONFIG/network/my-network gets completely erased after booting the rpi, including the directories. Has boot changed since 2 years?
  • adding a network-config file to root of boot fat partition appears to be ignored, but I’m unsure as I cant see or log boot console output.

I have the impression that quite a lot has changed since past years, and solutions that did work, no longer do.
Any pointers to uptodate docs?