Consistent disconnect from HASS

They are both running on the same host (Raspberry Pi 3B). What I don’t get is the timing of the events; very regular and timed intervals. This was not an issue with version 2.

hass address is local ip?
could be that there is a difference how hassio connects AD3 to HA versus AD2 connection to HA.
did you deinstall V2?

Yes, local IP. I uninstalled v2 and installed v3 after. Nothing else was changed in between, except an upgrade from 0.62 to 0.62.1.

I already tried uninstalling and reinstalling Appdaemon 3. Same issue. I can try it again if needed.

you can use that same IP in a browser to connect to HA without trouble?

Yes, of course. No other issues to report… The only thing I already reported previously is a new error message introduced in HA v0.61. It’s also a regular event, every 8-10 minutes (not that consistent), but the timing does not match the disconnections between AD and HASS. The HASS error I get is:

Error doing job: Task exception was never retrieved
10:37 AM components/ (ERROR)

See the following post: "Error doing job: Task exception was never retrieved" (was Version 0.61+ and ISY994i)

I don’t think they are related. Like I said, it worked fine with AD v2.

i would suggest contacting frenck to ask if it could be a hassio problem.

I have the same issue on a new install, both hass and appdaemon in docker, more or less default configs on both services

hassio is also docker if i am correct.
i think its a connection problem that is not from inside AD, but from a docker or hassio configuration.
problems like this make me stay away from hassio, docker, venv, etc. :wink:

If it’s related to HASSio and/or Dockers, what I don’t understand is the exact frequency (every 2 minutes and 12 seconds) and the fact that I did not have this issue with version 2 of Appdaemon.

Robban, do you have the exact same frequency?

No, it retries every 5 seconds

2 complete different addons, so 2 different docker packages, with different configurations.

5 secs is logical, 2 minutes and 12 secs isnt (for me at this moment), but it still seems that you are not connected at all. could be that yours has a longer time because you dont use dashboard.

Retrying every 5 seconds, I get it; that’s because AD never connects to HASS (because of its configuration) and it’s retrying. Robban’s issue above is quite different than mine. But 2 minutes and 12 seconds, consistently, that’s not normal. I will play a little more with it to try to pinpoint this issue.

Got it. But I still don’t understand why it’s behaving this way. If I put in my FQDN (ie. in the plugins section of appdaemon.yaml, everything is working normally without disconnections. If I put in http://myLocalIP:8123, it does not work and disconnects every 2 minutes and 12 seconds. That is really strange…

Do you guys use your local network IP or your domain name in the configuration? I would prefer to use my local IP so that I can avoid DNS issues altogether and everything stays local.

i use it, but have no hassio.
do you have ssl in your home assistant?

if not i am sure that it is a hassio problem.

Yes, I use SSL everywhere, except on my local network…

if SSL in inside hass it can be the problem.

NGINX terminates the SSL handshake. There is no SSL inside HASS.

thats what i asked :wink:
then i can only think that somehow the hassio docker isnt making a right connection to your hass.
did you recheck the url if you didnt make a typo? (grassping at possibilities, as you see :wink: )

No typos. I used the same line as version 2, that is:


That created the disconnection issues with HASS. I then tested:


and that worked fine. No more error messages. I then decided to simply try:

ha_url: http://hassio/homeassistant

and that worked !!! I’m leaving it like that (without port 8123). I’m still not sure why my local IP and port wasn’t working. HASS works fine in a browser using my local IP address.

Problem solved. Thanks!

1 Like