Controlling JVC projector via LAN

Dear Home Assistant users,

I’ve recently started using this program to automate stuff in my new house. I started out with Hue and ConbeeII, then I added RFXcom to control various 433 Mhz switches. Recently I’ve added some Tuya automated curtains which I plan to flash in the future. So far it’s been a difficult but satisfying journey. I’m still very much a ‘noob’ how ever.

Now I’m trying to automate my JVC projector (it’s an old one, X35 but should still work with these commands) using IP commands over LAN and at the moment I’m at my wits end. I’m hoping some of you might be able to get me in the right direction. Here’s the problem.

I’ve researched how I need to go about this. I’ve read this thread about using hex codes sent over lan to controle the projector: Controlling JVC projector through TCP/IP using hex commands

And then I stumbled upon this thread. JVC Projector Component I installed the integration (thank you bezmi) and apparently I’m able to read the state of the projector via developer tools / states but I’m not able to control the projector using the commands. I’m just looking for a way to turn the projector on and off. (I’m planning to automate it with the lights and curtains). When I send the command to turn off/on via services in the developer tools nothing happens. As far as I can see I’m not getting any error messages in my log. Does anybody have any idea how I go about troubleshooting this?

Or is there perhaps another way to achieve my goal? Perhaps via a command line switch? (it’s something I read about as well). Or should I forget about it completely and try to use some IR blasting?

I’m able to control the projector using my Windows machine and a program I’ve found via the AVSforum: JVCControl So I know the projector is reachable and controllable via lan.

I’m running Home Assistant (the OS) on a dedicated Raspberry Pi 4.

Any help is greatly appreciated. :slight_smile:

1 Like

Hi @Upke, have you found a solution to this? I am encountering the same issue as well.

Hallo Pinkesz,

Unfortunatly I did not solve this issue the way I wanted. At first I tried using the Broadlink IR blaster. But I couldn’t get that working reliably so I bought a Logitech Harmony hub and it works like a charm.

1 Like

Apologies for the late reponse, I rarely get time to look into these things. You’re right that the commands I’ve implemented for power should work with your projector. The homeassistant component actually relies on my simple python module.

There are instructions on that page on how to install it and simple usage. If you could try sending a command with this python library, we can figure out whether the problem is on the homeassistant end or the communication side of things.

Thanks for replying, it looks like an issue with my projector, the integration works for a bit and then the projector freezes up (requires a power cycle), one day I’ll get a new one try it again.


This looks interesting. I just tried searching for jvcprojector under integrations on HACS and nothing came up.

Am i doing something wrong?

I believe you have to add it as a custom repository as I haven’t made efforts to include it as part of the “official” add-on repos.