[Custom component] AsusRouter integration

@Vaskivskyi works with 0.17.1 !!! :+1:t2::+1:t2::+1:t2:

My HA haven’t detected this update. Is that available already?

I’m running HA 2023.1.1.

Now I can see it.

@EdwardTFN, sorry, was already writing a reply. HACS checks for updates with some periodicity. But you can always reload HACS and it will show updates immediately

@sesame26, great! Hope, you won’t have any problems with AsusRouter


:loudspeaker: Do you want to add AsusRouter to HA Core integrations?

:+1: Vote for the feature request!


@Vaskivskyi, any idea here? It started when I’ve updateom from v0.16.x to v0.17.1.

2023-01-09 13:03:40.811 WARNING (SyncWorker_0) [homeassistant.loader] We found a custom integration asusrouter which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant

2023-01-09 13:05:06.155 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry ASUSRouter for asusrouter

File "/config/custom_components/asusrouter/__init__.py", line 24, in async_setup_entry

File "/config/custom_components/asusrouter/router.py", line 680, in setup

ValueError: Unique id 'asusrouter_7c:10:XX:XX:XX:e0_guest_5_ghz_2_1' is already in use by 'switch.router_guest_5_ghz_2_1'

@EdwardTFN, oh, it seems like it happens to some users but not everyone. Also didn’t get it during tests with migration… Issue #450.

I will try to reproduce it and fix it today, so everyone can properly migrate. In case you don’t want to wait, it will work if you just remove and set up integration again.


No problem. I can keep the issue until you have a fix, so you can use my case as a testing bed if you want, otherwise I will remove and setup again as this is not a big issue as well.

@Vaskivskyi I am getting these errors every few hours or so

2023-01-09 14:40:12.230 ERROR (MainThread) [custom_components.asusrouter.router] Error fetching ports data: None

2023-01-09 14:40:12.233 ERROR (MainThread) [custom_components.asusrouter.router] Error fetching gwlan data: None

2023-01-09 14:40:12.241 ERROR (MainThread) [custom_components.asusrouter.router] Error fetching parental_control data: None

2023-01-09 14:40:38.231 ERROR (MainThread) [custom_components.asusrouter.router] Error fetching ram data: None

2023-01-09 14:40:38.235 ERROR (MainThread) [custom_components.asusrouter.router] Error fetching wlan data: None

2023-01-09 14:41:10.230 ERROR (MainThread) [custom_components.asusrouter.router] Error connecting to ‘’ for device update: None

2023-01-09 14:41:40.230 ERROR (MainThread) [custom_components.asusrouter.router] Error connecting to ‘’ for device update: None

2023-01-09 14:42:10.229 ERROR (MainThread) [custom_components.asusrouter.router] Error connecting to ‘’ for device update: None


Are the sensors stuck or did they recover and started updating?

Do you connect to your device with the SSL option or without? It is recommended to use an SSL connection since it is more stable on most devices

@Vaskivskyi the sensors are available when I check, I not use SSL, to be honest I also have no idea how to do this, if I check the SSL conection box I get a “unknow error”

This error originated from a custom integration.

Logger: custom_components.asusrouter.config_flow
Source: custom_components/asusrouter/config_flow.py:863
Integration: AsusRouter (documentation, issues)
First occurred: 19:20:27 (3 occurrences)
Last logged: 19:21:59

Unknown error of type ‘<class ‘homeassistant.exceptions.ConfigEntryNotReady’>’ during connection to (‘Cannot connect to host ssl:True [None]’, None)
Unknown error of type ‘<class ‘homeassistant.exceptions.ConfigEntryNotReady’>’ during connection to (‘Cannot connect to host ssl:False [None]’, None)

@Vaskivskyi Ok did see also needed to change the port, now did set-up with the SSL box checked and the Check SSL Certificate box unchecked… I hope this is the correct way to do it :slight_smile:

0.17.2 :hammer: Migration improvement


:bug: Bug fixes

  • Fix removing duplicates on unique_id migration (reports #C371, #443, #450)

:open_book: Translations

:hatching_chick: Github / HACS

@EdwardTFN, please check the update. Migration should work better now.

@sesame26, yes. This should work well. Just make sure, that SSL is enabled in your router settings. But if it works for your now, than it’s fine

The issue was fixed!

Thanks again for your great work, @Vaskivskyi.

1 Like

Since the lastest:

Logger: homeassistant.config_entries
Source: helpers/entity_registry.py:695
First occurred: 21:27:45 (2 occurrences)
Last logged: 21:36:38

Error setting up entry for asusrouter
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 382, in async_setup
    result = await component.async_setup_entry(hass, self)
  File "/config/custom_components/asusrouter/__init__.py", line 24, in async_setup_entry
    await router.setup()
  File "/config/custom_components/asusrouter/router.py", line 680, in setup
  File "/usr/src/homeassistant/homeassistant/helpers/entity_registry.py", line 749, in async_update_entity
    return self._async_update_entity(
  File "/usr/src/homeassistant/homeassistant/helpers/entity_registry.py", line 695, in _async_update_entity
    raise ValueError(
ValueError: Unique id 'asusrouter_24:4b:fe:e4:ff:80_temperature_2_4_ghz' is already in use by 'sensor.rt_ac86u_temperature_2_4_ghz'

Debugging doesn’t show anything else.


Forget it. Working with 0.17.2!

0.17.3 :bomb: A new bugfix for older devices


:bug: Bug fixes

  • Fixed issue for the devices with missing label_mac value from NVRAM (some older devices with Merlin builds) preventing AsusRouter from start (report #451)

:package: Dependencies

  • Bumped asusrouter library to 0.17.0

@Ostracizado, sorry, I was already typing that with the latest version everything should work fine

Users with no problems regarding the mentioned issue do not need to urgently update.

P.S. Sorry for the double release today. Did not want to go to sleep and keep users with an unresolved bug.


0.17.4 :bug: One more


:bug: Bug fixes

  • Fixed bug in the backend library bothering some users with older FW

:package: Dependencies

  • Bumped asusrouter library to 0.17.1


Is it just me or is the documentation hard to understand? I would love to see some code examples in the documentation. Like one thing i want to know is how to i use parental control or device control? Is it not possible to make a list with ”flex-table-card” with name/ip/Mac/parental control for an example? Right now the only information i have found is make a automation and a Button that triggers it to turn on/off parental control that would make me have to create 40ish automations and that aint that great solution…

Search the Forum for flex-table-card, i know it’s there, unfortunately, i deleted the “flex-table-card” i made on “trackers” ( remember flex-table is rows (with columns) from 1 and the same sensor/entity so i doubt you can squeeze in “parental” options, as i don’t see this in the “Trackers” attributes
And it’s basic text-table, last time i looked at it

Quite common some people make Groups, for certain i.e. devices, and “apply” an automation or in other means a script etc., to the Group.
So the first think for you to consider is, do you need a group or groups for your “Parental” feature “turn on/off”, will all be turned on/of at same time/conditions, or what ? , Your “plan” is what sets the requirements, 1 automation ?, 2, 40 ?

I don’t use parental control, but I do have a dashboard using flex-table-card which might be easy to add additional info you need:

type: custom:flex-table-card
  - devices+
  include: sensor.aimesh_router_connected_devices
  - data: devices
    modify: x.ip
    hidden: true
  - data: devices
    name: ' Device Name'
    icon: mdi:devices
    modify: x.name
  - data: devices
    name: ' Address'
    icon: mdi:ip-network
    modify: x.ip
  - data: devices
    name: ' MAC'
    icon: mdi:barcode-scan
    modify: x.mac
  - data: devices
    name: Connection type
    modify: x.connection_type
  - data: devices
    name: AiMesh node
    modify: >-
  style: |
    ha-card {
      box-shadow: none;
      background: none;
1 Like