[Custom component] AsusRouter integration

I have a


Does this mean that I block ALL internet or do I enable the option to block internet for devices that had been added for blocking to internet?


it will block internet connection for all the devices connected through this router. This is the full analogue to this switch in the Web UI

For separate clients (even if for all of them), you can either use per-client switch entities (e.g. combine them in a group) or the service call

1 Like

0.27.1 :adhesive_bandage: Ignore wrong parental control rules


:octopus: GitHub release ←

:rocket: Features

  • Added a check on parental control rules before adding them as entities (report #753)

:christmas_tree: Please, refer to the full release log for version 0.27.0 3 messages up from here

1 Like

I do not see any Asusrouter services in the dropdown when I go into Developer Tools/Services?

Are the switch entities for specific devices created when you create the parental control rule in HA GUI? If not, how are device specific switches created?

Hello, @automateitall,

The switch entities are directly linked to the parental control rules in the device settings. So if rules are set for the device, they will appear in HA. Also, if you use a service to add new rules directly in HA, they will be written to the device + switches in HA will be created.

As per the services, asusrouter.device_internet_access should be available if your device is configured as a Router.

In case, it does not work for you when configured as a router, please, open an issue.

It’s currently not available in other modes the same way as the other parental control features. In case, you would like to have it working, please, let me know. I don’t have direct access to any device set up as an Access Point or Media Bridge, so I don’t know which features can work for such devices. But I can work on it

In any case, you should see at least the service asusrouter.remove_trackers available for any HA configuration. If not, please, open an issue with details on your device and HA configs set for the integration


Something strange happened. I’ve updated/rebooted via HACS a few times over the past several weeks. Earlier today I checked and there were no updates available in HACS. Just now an update from 26.0 to 27.1 was available. Updating and rebooting has partially fixed my issues. The asusrouter services are now listed in Developer Tools.

Removing the device internet block works in Node Red as it has in the past. However, I now get an error when trying to block internet access via Node Red. Here is the JSON and error I get when I do the call service “device_internet_access”.


The issue is fixed in the new 0.27.2 version. I am sorry for this bug. Unfortunately, I can’t perform tests with NodeRED usage of all the features due to the limited time I have for the development, so all the testing is only done directly in HA

0.27.2 :computer: Client devices improvements


:octopus: GitHub release ←

:rocket: Features

  • Added device connections to allow:
    • device_tracker entity merge into the created device
    • merge device with the existing instances from other integrations

:bug: Bug fixes

  • Fixed issue with calling device_internet_access from NodeRED without device name (report #C706)

:coffee: Support AsusRouter

Monetary support:

Non-monetary support:

By the way, you might also be interested in:

1 Like

Thank you for all your hard work on this. You’ve tried to make it easier for us all to use your awesome integration with the new switches, so that is the route I’ve taken and it works great. Still using Node Red, but my call service is a simple switch toggle now.

Thanks again!

1 Like

Hi guys. I am not able to install integration. All what I can reach is "unknown error:
Credentials are OK, not using SSL.

2024-01-04 20:14:12.919 ERROR (MainThread) [custom_components.asusrouter.config_flow] Unknown error of type ‘<class ‘asusrouter.error.AsusRouterConnectionError’>’ during connection to (‘Cannot connect to Failed in _send_request’, None)

Anybody notice that devices seem to periodically go to away then back home pretty frequently since the last update. I use this a presence sensor and just updated this morning to 0.27.2. My device keeps saying I’m away then home and then away again. Wasn’t doing that before the update.

what ip number did you type in ?

both and http://router.asus.com as well

with the same result

I have the same issue since I updated the integration today: Unknown error of type ‘<class ‘asusrouter.error.AsusRouterConnectionError’>’ during connection to (‘Cannot connect to Failed in _send_request’, None). No matter what I input same result.

@kajmaj, please, check your device settings. Make sure, access is allowed from the IP address of your Home Assistant instance. Check the Administration - System tab all the way to the bottom

The Enable Access Restrictions should be either set to No, or the HA IP be in the list of allowed

You can also try HTTPS access, which in general works better and allows concurrent connections (if connected via HTTP in Web UI already, the integration might not be able to connect because of it

Also, the device log might tell you if there are any errors and why.

1 reboot of the device also shows to help with at least 50% of the issues.

If nothing helps solving the problem, please, open an issue on GitHub and include the info about your device (model, FW version)

@smitius, which version did work fine for you before the update? There were no changes to the sign-in functionality for a long time. Please, try connecting both with and without SSL.

Please, also try a single reboot of your device (and then integration reload).

In case the issue stays, please open an issue on GitHub (link above).


From which version did you update? Lately, the client state functionality was adjusted for the cases when devices are getting stuck forever.

In case your devices seem to “blink” please make sure you are setting reasonable (or using the default) values for updating connected devices in the integration (Configure - Connected devices - Device update). The default is 30 s for update and 45 s to consider the device home (so, 2 times the client should report offline to actually change device_tracker to offline).

In case you are using the default values already, please try to check whether this happens to some specific devices or all of them.

hmmm, can’t really say, im on latest version, but didn’t had any issues when updated, so i never had to go through that “sequence”
I do however have some web-socket errors on http, could be related to latest Core update 2024.1.0 , no mention of asusrouter or issues connecting… and everything seems to work here thou

I believe I just took the defaults. On the Configure>Connected devices>Device Update? Is that Devices/AiMesh update* or Wait time(force update → check) seconds*. If it’s the 1st one, is the default 5 seconds for Wait time(force update → check) seconds*? And version, I usually keep things pretty current. So, would be the last 1 or 2 releases.

Some further details I’m seeing.
I only have/monitor my 2 Samsung S22 phones connecting to the network. Even thought they show/seem connected in my Asus RT-AX88U Pro, it seems like if I lock the phone, that shortly it shows up in HA as away. Then I unlock the screen, then it shows as Home. I don’t believe this was happening before. I believe I kept the default device configurations when I installed it. I’ll keep monitoring and see if I can see a trend any further of what might be causing this.

The problem started right after updating the component yesterday. I was on previous release for a while since May '23 I think. Did full reboots of everything, still the same issue. SSL/plaintext change make no difference, settings in router are ok - there was no change on router/fw/conf side. I made sure HA instance can curl the router endpoint web - so all works fine. I’m on merlin fw and RT-AC68U if that matters.

Thanks, it seems that ‘https’ solved the issue :+1:t2:

1 Like

@bh56, @smitius, please open new issues, so that we can troubleshoot everything properly.

@kajmaj :+1:

I have the beta firmware on my GT-AX6000. I have no experience with the ASUSWRT integration prior to today. Unless I’m missing something, I am completely unable to log in to set up the integration.