[Custom component] AsusRouter integration

Thanks @Vaskivskyi , after deleting the time rules, the switches showed up as they should. Thanks!

But still, the block internet switches rarely work for me. Are there any router settings i need to reconsider for this to work?

Is it possible to see the names or count of users connected to one of the vpn servers?

Hey, so I’m not sure if something broke or it was intentional, but after a recent update the Guest Network connected devices disappeared; my guests are on a different subnet on the primary router, but were reporting until recently.

I figured I would ping you here, rather than open an issue tracker on GitHub. It seems to have occurred after one of the recent major updates but I’ve been busy so I can’t nail down when it occurred.

I’m running YazFi, so if anyone has any ideas, please jump in. It’s not a necessity for me and if something similar is happening for others I can open up an issue report.

Thanks for the amazing integration, it’s crazy it hasn’t been accepted into the main HA library yet. It’s really lightyears ahead of the AsusWRT integration in terms of stability as well as features…

I just installed it and did not get upload/download sensors, even disabled.

GT-AX6000
Merlin: 3004.388.6_beta1_rog

Tried rebooting the router and reloading the integration.

Also upload and download speed are missing.

Hello. Sorry for the delay, guys. Unfortunately, lately, I don’t have almost any time to go through the messages. Please, open issues on GitHub, so that I see them faster.


@jhummel, please, check whether the parental control rules work properly with 0.30.0 which should be available in HACS shortly. If not, please, open an issue so that we can debug and fix the problem


@kramttocs, yes, VPN server entities have a clients attribute. It’s in the following format:

Format
{
  "1": {
    "enabled": true,
    "name": "Name2",
    "address": "xxx/32",
    "allowed_ips": [
      "xxx/32"
    ],
    "client_allowed_ips": [
      "xxx/24"
    ],
    "state": true
  },
  "2": {
    "enabled": true,
    "name": "Name1",
    "address": "xxx/32",
    "allowed_ips": [
      "10.55.0.23/32"
    ],
    "client_allowed_ips": [
      "xxx/24"
    ],
    "state": false
  }
}

Each client has a parameter state which corresponds to connected (when true) or disconnected (false)


@modelstudent101, please check whether the issue is the same with version 0.30.0 and open an issue on GitHub, so that we can troubleshoot it and fix it. The Guest networks should not have been influenced in any of the last updates, but sometimes things break. Sorry for that


@bmorgan, please add to this issue [Bug] Missing sensors · Issue #780 · Vaskivskyi/ha-asusrouter (github.com). It looks like some users lost the network interface sensors. This will be fixed as soon as I understand why this happens only in some cases

1 Like

:open_book: On the new features

Install update

The install update allows one to automatically install the available FW update without a need to go to the device Web UI. The behaviour of the feature is the same as the update button in the Web UI - the FW will be automatically downloaded from the server and installed.

There is no real progress for this state (like in the Web UI) - instead, HA will take 2 minutes to show the update as installing.

This feature might not work if the device itself cannot download the FW files automatically.

P.S. Nothing in this progress is HA-dependant. The update process is fully done by the device. The integration can just send a request to perform an update.

Full release note & more devices support for notes

Allows one to see the full release log directly in the HA which is now also available for a wider range of devices.


0.30.0 :computer: Firmware control & quality features

2024-03-20

:octopus: GitHub release ←

:rocket: Features

  • Added color_mode property to the LED entity to fully comply with HA 2024.3.x requirements (report #807)
  • Added button.{}_check_for_updates entity
  • Added support for a release note in non-AiMesh mode to support more devices
  • Added support for a full release note in the update entity description in the HA UI
  • Added installation of a new firmware from the HA UI (supported by any FW update that can be installed automatically from the web without a need to upload the file manually)

:bug: Bug fixes

  • Added a check on the VPNC client data availability before processing it (report #802)
  • Added explicit string conversion on saving parental control rules (reports #773, #805)

:package: Dependencies

  • Bumped asusrouter library to 1.8.0

:coffee: Support AsusRouter

Monetary support:

Non-monetary support:

2 Likes

@Vaskivskyi it works very well now, thank you!

1 Like

@jhummel, great, that it works for you now :+1:


:book:

While the work on AsusRouter never stops (even though is slowing down when there is no free time in my life, there might be something useful for users of the multi-gig routers who want to use all the fast ports for LAN. An example of GT-AX11000 Pro with 2.5 + 10 Gbps ports both in LAN + 1 Gbps remapped to WAN. Potentially applicable to other routers as well

For those who don’t like to read, at the end there is a recap of what to do in several simple steps

1 Like

0.31.0 :rocket: Merlin 388.7 support

2024-05-01

:octopus: GitHub release ←

:rocket: Features

  • Added support for Merlin 388.7

:package: Dependencies

  • Bumped asusrouter library to 1.9.0

:coffee: Support AsusRouter

Monetary support:

Non-monetary support:

2 Likes

Great, rt-ax88U pro now works. Thanks!
But, i have a strange situation…
i have rt-ax88 pro as main router (on IP 192.168.0.1) and two AP’s (RT-AC86U) on IP’s 2 and 3. When i add those two their entities are mixed into both… on “hubs” page they are correctly stated as 192.168.0.2 and 3, entities are also correctly generated (i have “button.rt_ac86u_reboot” and “button rt_ac86u_reboot_2” etc), number of entities is also correct on this page, but when i click on either one of them all entities from both AP’s are shown - so each name is doubled (see picture). When i want to rename one device they are both renamed - if i agree to rename all sensors with renaming device again all sensors are renamed from both devices.
What’s also weird that i have some sensors from my main router here…? (bottom of my pic)

Any clues what can be wrong? Do i have just “bad luck” by having two identical routers as AP?
Note that i don’t have them in AiMesh, i just have devices as AP.

It is not related to having 2 devices of the same model, but with the way the integration realises these are actually 2 separate devices. I have an RT-AX88U and a RT-AC87U which appear as the same device, as is your case. I also had 2 TUF-AX5400 which appeared as separate devices.

Well, the point is that integeration “kind of” realises that they are two integrations - it creates two hubs, but “kinda” doesn’t, since when i rename one device both are renamed into same name (with all sensors from both devices)…

With latest HSA 2025.5.0 I see this error when restart HA:

2024-05-02 09:24:08.260 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry 192.168.100.1 for asusrouter
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/config_entries.py", line 575, in async_setup
    result = await component.async_setup_entry(hass, self)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/config/custom_components/asusrouter/__init__.py", line 27, in async_setup_entry
    await router.setup()
  File "/config/custom_components/asusrouter/router.py", line 413, in setup
    await self.update_pc_rules()
  File "/config/custom_components/asusrouter/router.py", line 706, in update_pc_rules
    await self.bridge._get_data_parental_control()  # pylint: disable=protected-access
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/config/custom_components/asusrouter/bridge.py", line 348, in _get_data_parental_control
    return await self._get_data(
           ^^^^^^^^^^^^^^^^^^^^^
  File "/config/custom_components/asusrouter/bridge.py", line 274, in _get_data
    return process(raw)
           ^^^^^^^^^^^^
  File "/config/custom_components/asusrouter/bridge.py", line 421, in _process_data_parental_control
    rules = raw.get("rules")
            ^^^^^^^
AttributeError: 'NoneType' object has no attribute 'get'

0.32.0 :hammer: AiMesh improvement and HA fixes

2024-05-21

:octopus: GitHub release ←

:rocket: Features

  • Added support for the full AiMesh reboot with button.{}_reboot_aimesh entity
  • Improved logging on connection errors

:bug: Bug fixes

  • Fixed the blocking function call which was logging a warning in HA logs since 2024.5.x (report #823)
  • Improved handling of empty data (report #C756)

:package: Dependencies

  • Bumped asusrouter library to 1.10.0

:coffee: Support AsusRouter

Monetary support:

Non-monetary support:


@poudenes, the issue should be fixed now. Please, check it


@Protoncek, @mihsu81, unfortunately, a multi-device setup is still not working properly in some cases. Mostly happens with 2 of the same models, but sometimes with different ones as well. Due to the lack of any device pair, I cannot yet promise any timeframe for the fix.


If you experience any issue with AsusRouter, please, open an issue on GitHub. Currently, I have a rather limited amount of time to check the forum (and GitHub as well) due to some personal reasons. But on GitHub, at least tracking the issues I haven’t yet answered to is easier to handle

2 Likes

Thanks, i went back to AiMesh config anyway, since i found out that my iot devices work better in aimesh than in AP mode, and here i have all my devices shown correctly.

Only thing i miss now are temperatures of mesh devices (only main temp’s are shown)… but that’s not so big deal.

1 Like

0.32.1 :bug: JSON fixes & documentation

2024-05-28

:octopus: GitHub release ←

:bug: Bug fixes

  • Fixed JSON parsing for missing values (report #832)

:books: Documentation

  • Added info on HTTPS connection as a preferred method for the integration
  • Added info on the number of connected clients and its correspondence to the Web UI
  • Updated supported devices

:package: Dependencies

  • Bumped asusrouter library to 1.11.0

:coffee: Support AsusRouter

Monetary support:

Non-monetary support:

1 Like

Hello,

as suggested in a topic I recently open, I’d want to know if there will be the chance to implement the sensors which read the dsl features.
If I connect to my modem and go into the menu and click first on “1”, then on “2”, I see the real speed of my internet connection (“3”), that in this moment is 151619 kbps in download and 21600 kbps in upload:

So it would be nice if the integration could also read those two parameters.

Anyone else experiencing issues where after a random amount of hours the integration can no longer connect with the router?

I had to start from scratch a few weeks ago, but for the life of me I can’t get any of the Asuswrt integrations to behave stable. Thought it was integration related, so tried Asus Router this time, but same behaviour.

Last night this happend:

Logger: custom_components.asusrouter.router
Bron: custom_components/asusrouter/router.py:492
integratie: AsusRouter (documentatie, problemen)
Eerst voorgekomen: 03:15:51 (1 gebeurtenissen)
Laatst gelogd: 03:15:51

Cannot get clients from ‘192.168.0.2’: (‘Reached maximum allowed timeout for a single connection attempt: 425.0. The last error: (“Cannot connect to 192.168.0.2 on port 8443. Failed in _send_request with error: Cannot connect to host 192.168.0.2:8443 ssl:False [Connect call failed ('192.168.0.2', 8443)]”, None)’, None)

After that I’m unable to reload the integration and I have to reboot the router to get it to work again… Router is an AX88U on latest stable merlin version.

I’m really puzzled as nothing has changed on the router/network side of things.

Hello all,
Thank you for this great integration. Brilliant work. I have a new zenwifi mesh system since i got very annoyed with the Tplink X60.

It all works fine. I managed to get all 100+ devices in a tracker and a table. And all the upload and download speeds and other info shows up perfectly.

Except all my wired devices. They don’t show up and download speeds. All other attributes work fine.
They are simply not in the attribute of the tracked device.

Can anyone help me with solving this, if it is at all possible?

I’ve just bought a pair of ET12 mesh routers and got them set up without issue however I’m struggling to get WireGuard client info into HA. Clients set up and working no problem but not displaying correctly in HA, missing all attributes.

I’ve scanned over this thread and saw a comment around OpenVPN showing client connection status etc but nothing for a WireGuard clients.

Anyone help?