[Custom Component] Tapo: Cameras Control

Is there anyone that can help me with opening ports in the amplifi app (the router on which HA and the camera reside) - I attached the configuration file of the router as it is now.

For a brief moment I had the camera showing up in my HA, but I had no streams. I decided to delete the integration again and start all over, but now it won’t let me add the camera again. I have given it a static lease. The IP address you see is the address of the HA installation.

have you rebooted your system ?

Lots of times - all of them.

remove the static ip, from your cam, and your router, start over again, with “default” DHCP, let the system work !, then you can “play around” setting mac-binding and whatever

All to no avail. Removed the camera from the tapo app and started over again. It is driving me nuts.

next time you try to add your cam to this integration, then look in your logfiles, if you dont succeed , choose “full logfile”, if there is not enough “info”, then change your log-level to debug ( you can even try to “add” debug for the integration )

You must understand that NOONE can help you with your lame description.

OK, I am sorry for asking and not being more knowledgeable. I did not know what more info was needed, and if more info was needed, what it would be. I did not know about these log files, and even with the instruction I don’t know how to get them out. I got the ONVIF integration to integrate my camera into HA, but I do not get a stream.

this Topic is specific for the Tapo-Camera-Control Integration , do you not have this Integration ?, if not you should search in the Forum for ONVIF help

Yes indeed, the more “Specific” information you can provide, in a structured manner, the better

In regards to this integration (Tapo: Cameras Controll), you should then first follow the installation instructions, and then follow the instructions for adding your cam. If any of this fails, you can ask for help, providing the “steps you have performed, and where/how it fails for you” Also then with a sample of relevant “logfile/error codes”

In general, with this integration, (default) you should not open any Ports, to WAN, but that depends upon how you have your ha-system And Your Router configured, you show a picture of PORT-forwarding, dont “play” with this if you’r not familiar with the consequences.

How your system/router is configured only you know, and should you need help with that , it’s the general Forum, if there aint are a specific Topic for your router ( i can say, i haven’t even heard of the name)

So with your limited knowledge, Don’t start with the most complicated, just start with adding your device, in correct/preferred integration. IF that is ONVIF , then read the official ha-docs for this, and ask questions in regards to this on the Forum
If it’s for this Integration (Tapo:Cameras Control), again start with basin(getting your cam installed in this integration)
When things works the “default” way you can move on to more advance features, such as port-forwarding, ONVIF etc. … in respective Topic’s or common integration/configuration Topics

1 Like

I have the right integration, which is why I posted in this forum - I just tried something else to see where the problem lies. If it is with the camera or another problem. If I could HA get to ‘see’ and interact with the camera, than the problem with this specific integration. I can follow a readme and I can read helpfiles. So yes, I did follow the github page. I you start the TAPO integration it also specifically states that you should be sure that the ports are forwarded, just like the github page. I’m not knowledgeable about this thing, but I am not dumb :slight_smile:

Thank you for taking the time to reply. I shall ask no further questions.

Just try to be specific, and dont expect people will understand/know what you mean by showing a picture of some Router-Setting ( which you dont specify what means ) i.e is it local, or wan-lan port-forwarding ? etc.
and don’t “fly” around various topics, first you mention open ports in your router (showing a picture noone would understand, unless they have your specific brand/version)
Then you mention you had the camera showing in ha (but no streams), so seems like you managed to get it in this integration, and before you get help, you delete it, and can’t add it ( change in subject ) etc.

I tried to explain to you how to provide concrete “Details” if you expect any help/assistance

Then you start to talk about ONVIF … And still you haven’t checked any logfiles

So, im not questioning what you can, i just give you advice how to proceed, and advice you not to do things you don’t understand … i was thinkin about your port-forwarding, as that picture did nothing but “scared” me, spite i (and others) didn’t know what you was trying to show with it

PS: i hope you have “reversed” your router-setting, as i doubt you initially want to open all these ports to to the world, meaning anyone can “probe/scan” these ports for potential info/weaknesses

Delete those rules. Readme specifically highlights in bold and capital letters that you should not port forward ports to wan.

As for your issue accessing Rtsp stream, Google how to access Rtsp stream on the camera and verify it works first.

So I’m using this integration to get the controls for both my cameras but I also use frigate and have it stream RTMP to go2rtc and use that stream for Home Assistant also. So my question is there a point in having this integration disable the camera feeds and only use it for control as I guess this makes my setup use double connection to my cameras? Or is that what the custom feed option are? If I add my RTMP feed there will this integration stop streaming from my cameras?

I have no clue if it’s even hardware or network intensive to have multiple connections to the cameras but what I can tell from Frigate the point of RTMP is to only use one connection to the camera with Frigate and then rebroadcast it?

Hi there, i buy a Tapo C320WS some weeks ago, because of HA integration. But i never get motion sensor to work. Motion detection works in tapo app. For mee it seems that the onvif bug is still the problem. But thes bug is there for weeks and i read new posts of people with working motion detection. Is there a way to get it working for my cam?
I have a new test Installation on Rpi4 with Beta Channel activated, and only the integrations installed i need for the cam, so i can test/change everything (if i know how to do). I read something about downgrade the tapo firmware or add a line to onvif/client.py (ONVIF Integration: Tapo C320WS Motion Detection sensor not appearing · Issue #85902 · home-assistant/core · GitHub) but i have no idea where to go for this workarounds.
Any help is welcome.

Hey! This should now be fixed in Release 5.1.0.beta.3 · JurajNyiri/HomeAssistant-Tapo-Control · GitHub

Please test and let me know if it worked!

How did you create the following entity?
It is not available on my C310.

Hi there,

I have updated to Release 5.1.0.beta.3 and restarted both the camera and home assistant a handful of times.

The motion sensor does not appear in the list of sensors and has not since I first installed the camera and integration some time ago. I have troubleshooted by deleting the custom integration, readding it, readding the camera, I have also changed the sensitivity level, turned motion detection off and on again with no changes.

Is there any other steps I can attempt to troubleshoot this issue?


My camera is a model C225 with firmware 1.0.17 - does this still affect it?

I do not know. You can try onvif component and steps as explained on the link.

Firstly, I want to say thank you for this great integration. I am using it for a while now and it works great.
However, there is one issue I am having and I cannot figure out what I am doing wrong. I have a Tapo C320WS camera (FW 1.3.0) on a completely offline network. HA is running on the same network on RP4. I can see all the entities and HD and SD live feeds. The motion sensor entity is not present right after the camera is added, but this is a known thing and is fine. The problem I have is accessing recorded videos. When I add the camera they work very well. They take a while to download, but this is not a problem. However, when the camera detects a motion (and the motion entity appears) it also records new video. From the moment that this new video appears in the media tab, I cannot download any videos anymore. It says that the recording is currently in progress. I can only watch previously downloaded videos.
Am I doing something wrong? I have seen that there is no open issue about such a problem yet, so I am assuming that for others it is working. I tried the integration version 5.0.0 and 5.1.0 beta 3, but the result is the same. In the settings of the integration, I have all the settings enabled (motion sensor, automatic time sync, stream and sound threshold detection).
I installed the integration manually by copying the tapo_control folder to the custom_components folder on HA (I do not have HACS installed).
Does anyone have any suggestions as to what I should do to solve the issue?