[Custom Component] Tapo: Cameras Control

Oh, sorry… I missed that.
Thanks for the help

1 Like

I installed a C200 camera this week. Loving the integration!

1 Like

The recorder settings are all explained in here.

However, to answer your specific question:

# Example filter to include specified domains and exclude specified entities
      - alarm_control_panel
      - light
      - binary_sensor.*_occupancy
      - light.kitchen_light

Just substitute your own domains and entities in the include:and exclude: sections as required.

My own camera SD feeds have an entity name like camera.garage_camera_sd_stream

I have a c310 where the motion alarm has stopped working. It only shows ‘unavailable.’
It has worked fine before.
I have restarted both the camera and home assistant.

What could be the reason for this?

Check your logs, check your entity under the integration, Just Posting

“It Dont Work” !!!

Sounds like a “Guessing Contest” , im sure you can do better, if not, then read the Welcome-Post, an get ideas to what you can do to help us help you

First of all: fantastic integration!!

Second: would there be a way to send an email to a certain address with a screenshot when movement is detected?

I’ve tried reading almost all the topic but couldn’t find any hint on this and I am not skilled in HA enough, unfortunately :frowning:

Thank you

Hey team,

I love the integration, but can it be deactivated to save recordings? I use Frigate for that and have double records :frowning:

I have a C320WS. It can detect motion, people, and vehicles. It seems that HA can only see the motion detection. Is it possible to create an automation on just the person and vehicle but not the motion? I can troubleshoot further but wanted to confirm that it is possible.

Thanks, Wayne

No it isn’t.

hello, i have 3 C210 installed in my home and i have an automation that:

  • when someone of the family enters home, moves the cameras to the “privacy” preset and turns on privacy mode
  • when the last family member exits home, disables privacy mode and moves the cameras to the “normal” preset so we can check what our cats do :slight_smile:

It works. But it works since i put a lot of delays (something like 10 seconds for each one) between each preset selection / privacy mode toggle.
Otherwise, i get errors on errors.
My question is if i can use something different than a ugly delay to check when the camera is ready to accept a new command…


I have the same, camera does not report it’s ptz position, delay is the best way.

I have integrated Tapo cameras successfully, thank you very much.
But I have a question: how can I get the video recordings to be saved in my NFS folder that I have added to HA?
Do I have to add something to the yaml configuration file?
I don’t have an sd card and I want everything to be saved on my server with NFS.

You will need to buy SD card allow recordings and then follow readme for sync (it is a sync, recordings will get deleted once no longer present on SD card). In order to do it without you are looking for NVR solution which Hass is not (look into frigate).

Thank you for your quick response sir. It has saved me hours of frustration. I guess I’ll have to buy an SD card.
Or go for one of those NVR solutions like frigate but I don’t want to complicate things and I want to keep everything simple so I guess it will be an SD Card.

I had the same issue, there is a new motion entity, available in the integration, the current one is not available anymore.

1 Like

Hello, I have an issue with the add-on installation. The add-on is rejecting my cloud password even though I’ve confirmed it by logging out of the app to make sure it was correct. I disabled two-factor authentication to be sure, but it didn’t make any difference.
I updated the Tapo C210 yesterday.
What can I do?

@JurajNyiri, it seems to be that Tapo is rolling out some new authentication method for all of their devices.

I see in the app, that I have an update for my Tapo P100 plug as well, and that says Enhanced device security.

The other Tapo integration for plugs has already multiple issues with similar content that you you linked above.

I would suggest to everybody using this integration to do not update any firmware to a newer one at the moment, until somebody finds out the new authentication method.

Otherwise I wouldn’t be surprised if this is an aftermatch of the previous CVE reported for the C210 cameras, which was fixed in the firmware 1.3.6.


If someone could get a link to the latest firmware that would be appreciated:

POST https://[IP_ADDRESS]/stok=[TOKEN]/ds

	"method": "get",
	"cloud_config": {
		"name": ["upgrade_info"]