[Custom Component] Tapo: Cameras Control

I’m about to follow your instructions, thanks!

1 Like

In case of the issue persisting in 5.4.5, there are instructions in Upgraded Firmware 1.3.9 on Tapo C200 and get Check tapo tag failed when trying to connect · Issue #456 · JurajNyiri/HomeAssistant-Tapo-Control · GitHub what to do to help me fix the Tapo tag issue (not padding, that is already fixed in 5.4.5!)

It is possible 5.4.4 broke the auth that once worked on 5.4.3 by now - ironically - succeeding auth with 3rd party credentials instead of requiring cloud password but then failing since camera (no longer?) expects it. If that is the case, 5.4.5 will not work as well, and we need your help in the issue. Once the logs are there as I requested I can quickly fix this.

I tested it with version 5.4.5 and it works fine.

Thank you so much for the integration. Totally new to HA, and after some struggle I’m finally able to get motion detection working on my C320WS (running Firmware: 1.0.5 and version 5.4.4 of the integration).

What finally worked for me was to allow access to camera port 1024 and allow the camera to access port 8123 on HA (with HA and camera set up on different VLANs) as described in https://github.com/home-assistant/core/issues/91661

This was besides already allowing camera to access ports 443, 554, 2020 on HA mentioned in the README, and 8800 mentioned elsewhere. 8800 and 2020 may have been unnecessary in my case - will test again with those disabled.

Since upgrading to 5.4.5 I am now regularly getting a notification to reconfigure random cameras. The motion detection cell keeps becoming unavailable on random cameras too.

This is the error in the logs

This error originated from a custom integration.

Logger: custom_components.tapo_control
Source: custom_components/tapo_control/__init__.py:452
Integration: Tapo: Cameras Control (documentation, issues)
First occurred: 16 November 2023 at 13:06:12 (10074 occurrences)
Last logged: 21:30:36

Error communicating with Tapo Camera. Status code: 500
HTTPSConnectionPool(host='', port=443): Max retries exceeded with url: /stok=c30897fbef3e17c37ae02af5f50efa58/ds (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at 0x7f1b6594a610>: Failed to establish a new connection: [Errno 113] Host is unreachable'))
('Connection aborted.', RemoteDisconnected('Remote end closed connection without response'))
'utf-8' codec can't decode bytes in position 2-3: invalid continuation byte

Logs are full of:

2023-11-17 01:30:14.935 ERROR (MainThread) [custom_components.tapo_control] 'utf-8' codec can't decode bytes in position 2-3: invalid continuation byte

Just seems to be one issue after another.

  1. Use the newest version, you are using 3 versions old release.
  2. Read the error message. Host is unreachable. Fix your network.
  3. There has been no changes to onvif motion events. Check your network.
  4. Post proper logs with proper description to github if you are still having issues.

With the information you provided, nobody can help you. Read How to help us help you - or How to ask a good question .

Just seems to be one issue after another.

TPLink released a new firmware introducing new encryption through completely proprietary, obfuscated and undocumented algorithms / apis. I added initial support for it within 1 day and spent 10s of hours since then fixing all the issues, even though my camera did not receive the update at that time. If you do not like the integration, do not use it. If you do and encounter issues and want to help, do so constructively or not at all. I, nor anyone else contributing and helping in issues is paid and we do this for free and completely voluntarily.

This literally popped up in my HA this morning :roll_eyes:

My network is fine. The cameras are always reachable in the Tapo app.

Yes, you’re right, I should use github more. Sorry for venting at you :slightly_frowning_face:

I really do like the integration, and believe me I appreciate how much time and effort goes into this. I’d love to help, but it’s way above my skillset, as it is for many other users. So we rely on people like you with the skills to create custom integrations such as these for us. However, you need to understand our frustrations when we spend hours creating scripts, automations and scenes that use your custom integration only to have them stop working for what we feel is something outwith our control.

You have actually helped thanks. But I will read this link again and endeavour to be a better question asker :laughing:

Trust me, I understand. I am not the cause why the integration broke. TPLink updated firmware. You are free to use the same firmware and never upgrade the integration, or Home Assistant, and have a flawless working system forever (just block wan from camera, please). If I did not make the update for the new firmware, nothing would work.
I experience the same frustration multiplied by having to resolve it, with very limited hw (only C200) that I have, with which I often cannot replicate the issue others are having. If I can’t replicate it, I need the users experiencing the issue to provide as much information as possible, in some cases even access to the camera or rely on other developers who appear and help solve the issue since they can replicate it. See for example Hub does not work on the newest firmware and 5.4.8 · Issue #455 · JurajNyiri/HomeAssistant-Tapo-Control · GitHub just from today, literarily minutes ago.
There are multiple users daily who do not take the time to write proper description with as much detail as possible, properly describe their problem or even provide logs. They simply often say something along the lines “No work. I mad. I demand fix.”. And/Or do not read readme, search other issues before asking etc. Just look at this invalid or duplicate issues.


Hi All, is there a simple way to connect a camera in a different house , on a different router and wifi to my Home Assistant instance at home? We have a cabin in the woods and would like to monitor that camera from home…
I tried entering the IP of that camera, but since its a totally different setup, the
IP is already taken by another device at home.
Thank you !

You will need to port forward the ports and have public ip, but it is not smart as this will expose your camera to the world, especially if you do not know too much about these things. Ideally just use the Tapo app.

Motion detection issues after any update solved for me by reenabling motion detection in TAPO app

Since they added this new encryption, is there certain models one should avoid? I am considering buying C420S2 and use it as a baby cam, but want to integrate it into HA at some point when our new house is done

Almost got it working through Smartthings… The Tapo Cameras and Thermometers are linked to my Smartthings account on my phone, and with the Smart Things integration I got the thermometer data into my Home Assistant instance at home !
Just the camera feeds are not working… I can see the binary_sensor for motion only… so close !

So should i suggest you install this " Tapo: Camera_Control integration " or should you Re-Direct your questions, to the Smarthings-Integration ?

So close ! , and yet far far way off

Hi guys! First of all, thank you, it is a fantastic integration!

Can you help me please? Inn docs you said we can use the camera as media source. Could you please give an example, how can I use it? Home assistant does not list the camera as a media source for me. (C225)

Right, so originally I created this post, because I thought that the integration required me to sign up for the Tapo cloud account. Needless to say, I was wrong, and after pondering a bit more, I realized that the app actually has a password, so all good now.

Thank you so much for an easy (although it took me like 10 minutes) integration.

You don’t need any paid-service account
If your App passwd dont work, then just create an account

ohhh, right, just saw you “changed” your post above , while i was typig :wink:

Yeah, I had a couple of minutes of blonde, although I actually have a very limited quantity of hair… :slight_smile:

And apparently a very limited amount of patience, before “crying out loud” :wink: :slight_smile:

Would not call it “crying out loud”, but yeah, something like that :laughing:

1 Like