Deepstack UI

we need to see this

I have this error on home assistant

Deepstack error : Connection error: HTTPConnectionPool(host='', port=80): Max retries exceeded with url: /v1/vision/detection (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x6916ba10>: Failed to establish a new connection: [Errno 111] Connection refused'))

I tried with ip_adress:localhost but résult is thé same . Deepstack is open and works on docker . I test with python command and result is ok
Have you an idea ?

Hi rob
Do you had time for
Looking errors message when running deepstack ui ?

Are you running home assistant and deepstack UI on the same host? If you are not using docker compose then it will be necessary to configure the machine IP, rather than using ‘localhost’.

Hi rob,
Home assistant runs on raspberry 3+ (192.168.1.xx:8123) and deepstack runs on docker ( When I write in my config yaml IP_adress: localhost or with Port:80 , i have an error too.
When I use python script test

 import requests

image_data = open("test-image3.jpg","rb").read()

response ="http://localhost:80/v1/vision/detection",files={"image":image_data}).json()

for object in response["predictions"]:


I have a good response.

On deepstack console container I have a response 200 from POST/ v1/vision/détection
Have you an idea ?

My guess is that somewhere a port is not exposed or mapped correctly. Currently you are running home assistant and deepstack on separate machines. In order to debug the issue you first need to get to a workable state, then iterate towards your actual setup. My advice is to get a single docker-compose for home assistant & deepstack on your laptop, then keep making changes until you are pointing to your actual home assistant instance.

Hi Rob,

Do you had time for
Looking errors message on your API (Streamlit) ?
I have tried another but i have always the same message.

@giloris did you even read my last message on this thread? The issue is not with the app, it is your setup

I don’t understand . your streamlit ui and home assistant are lied ?
I believe I need just loading a picture and Run your program(independently to home assistant ) To make recognition !

This thread is about the deepstack ui, but I think we somehow ended up talking abou the deepstack-home assitant integration. I understood you had the deepstack ui working but were getting errors using deepstack and home assistant, correct?

Tbh this expereince is convincing me that docker is not the user/beginner friendly solution for deploying applications that I hoped it was.

I have installed deepstack and deepstack_ui on docker and run well.
But when i open UI on browser (from docker) .
I upload an picture and i have this persistent error :

File "/usr/local/lib/python3.8/site-packages/streamlit/", line 322, in _run_script
    exec(code, module.__dict__)

File "/app/", line 88, in <module>
    predictions = process_image(pil_image, dsobject)

File "/usr/local/lib/python3.8/site-packages/streamlit/", line 591, in wrapped_func
    return get_or_create_cached_value()

File "/usr/local/lib/python3.8/site-packages/streamlit/", line 575, in get_or_create_cached_value
    return_value = func(*args, **kwargs)

File "/app/", line 38, in process_image
    dsobject.detect(image_bytes)File "/usr/local/lib/python3.8/site-packages/deepstack/", line 124, in detect
    response = post_image(url, image_bytes, self._api_key, self._timeout)

File "/usr/local/lib/python3.8/site-packages/deepstack/", line 89, in post_image
    raise DeepstackException(

For my another problem i will resolve it . I will install deepstack directly on raspberry.

Hi rob
i resolved my problem and deepstack runs very well and i scanned my first picture . My home assistant session connected on cloud ( and not on my local network.
But i not resolve the problem on deepstack ui (streamlit) i have theses errors when i open browser on docker.
Can you help me ?

I installed Deepstack in the Docker of a Synology NAS. The HASS deep stack object runs in the Home Assistant on an RPi. That works very well so far. Now I would like to use the Deepstack UI in the Home Assistant. The deepstack UI is also installed in the docker of the Synology NAS. Unfortunately I don’t get any further with the configuration. What has to be set in the Deepstack UI and how do I make the UI visible in the Home Assistant on the RPi?
Bildschirmfoto 2020-11-11 um 15.19.53
Bildschirmfoto 2020-11-11 um 15.20.06

Good news. I have found the right settings.
Local-Port and Container-Port should be identical -> 8501
Add variables to the Environment if not available:
DEEPSTACK_IP = (docker instance)

Deepstack for windows beta now available. No service though. Start it up in PS.

I use windows for docker anyway for more control.

Had to adjust my AI to detect the cat as a bird. 90% more detections with bird for the cat. I guess AI is expecting big birds??

I just added basic face recognition to the UI

@giloris you cut-off the error message at the Exception, please include it

@Cavekeeper glad you resolved your setup

@yonny24 you can use this UI to determine the correct confidence thresholds for various objects

Hi Rob and Happy New Year!! Is it already available in the docker image? I’ve updated the container but this functionality is not present yet and looks interesting

And how do we enter Face recognition mode in the UI?

1 Like

thank’s for your job Rob,
would it be possible to have an option to see how many people are registered in the database with the number of photos associated with the profile and maybe choose to delete one?
Maybe even just correct the name, because through this interface I entered a slightly wrong name and now I would like to delete it.

Hi Rob, I have the following problem in my configuration:

Deepstack error : Deepstack connection error, check your IP and port: HTTPConnectionPool(host=‘’, port=83)

I understand that it is a problem with the ports. In my case I have Deepstack installed on Home assistant through a virtual machine on a Synology NAS.
The IP of the Home Assitant virtual machine is and the IP of the Synology Nas is, could you tell me which ports I should open for communication between DeepStack and Home Assitant?