Default ports for Mosquito add on

I couldn’t start my Mosquito add on until I changed the default ports in the add on config UI. I bumped each of the four ports up by +2, and then it allowed me to start. By trying to use the default ports, is Mosquito conflicting with the built in broker? Is this how you’re supposed to get the add on working by changing the ports?

So I guess this is solved then?

Ah my bad, I couldn’t reload that topic for some reason, though your link works. And I’m not sure if it’s solved because I’m not sure which broker is being used. At this point I suppose I could use different ports if I knew Mosquito is being used. But I haven’t seen anyone else with the port conflict issue.

Does anyone know what the default ports the embedded MQTT broker uses? I’m at a loss why the default Mosquito ports won’t allow it to fire up.

1883/tcp using 1883 for Host won’t let the server start. Changing that to 1885 does let it work. But I suspect this shouldn’t be the case that I need to change it.

This is now showing in the Mosquito log (from the add on page for Mosquito). I’ve no idea what is, although it pings from my RPI terminal. Is it HA running in docker? My LAN uses 172.16.68.x.

1531751855: mosquitto version 1.4.15 (build date 2018-03-04 15:35:59+0000) starting
1531751855: Config loaded from /etc/mosquitto.conf.
1531751855: Opening ipv4 listen socket on port 1883.
1531751855: Opening ipv6 listen socket on port 1883.
1531751855: Warning: Mosquitto should not be run as root/administrator.
1531751856: New connection from on port 1883.
1531751857: Socket error on client <unknown>, disconnecting.
1531751857: New connection from on port 1883.
1531751857: New client connected from as 399feda0-e2fb-4b9d-af01-d1a378edbf2d (c1, k60, u'myuser').

I installed Hassio using

curl -sL | bash -s – -m raspberrypi3

Do you think this has anything to do with the issue?

Found the problem. I had a nodeserver running outside of hassio that was using that port. Disabling the service fixed the issue.