Depreciated! Lovelace: Sonarr Upcoming

Does the sensor exist? Look in dev tools > dev state.

It does not. (I’ve had the regular Sonarr addon working prior to this, which is now disabled)

How many days ahead is the sensor configured to look? If it’s not configured it would just be the default 7. Can you confirm that there are episodes to be released during the time frame? Do you use the default sonarr upcoming sensor? Does it show any upcoming episodes?

Thanks for the answer - I changed to 20 days back and it works.

There’s something new about the movie plugin :slight_smile:

Are you getting any other errors besides “Cannot read property ‘state’ of undefined” ?
For some reason the component isn’t loading, but beyond that I am at a loss.

Log Details (ERROR)

Thu Aug 30 2018 12:31:53 GMT-0500 (Central Daylight Time)

https://xxxx:8123/local/custom-lovelace/sonarr-upcoming-card/sonarr-upcoming-card.js:25:43 Uncaught TypeError: Cannot read property ‘state’ of undefined

Also, yes - I just re-enabled the regular Sonarr addon and changed days to 7. Lots of episodes upcoming, but still the error I listed above.

Yup, that just tells us what we already know. The component isn’t loading. Only things I could suggest would be to double check your indentation and make sure the component is inside the sensor folder which is inside the custom-components folder. The component is just a slight modification of the regular Sonarr component, so if it works then mine should too. Another thing you could try would be to view the RAW code of the component on github here and copy and paste that into the component on your system. Maybe when installing you copied from the displayed code and not the raw?

Thanks. I’ve quadruple checked everything and still no idea. Thanks for your help with this. If you’re really interested, I can zip up my configuration.yaml, sensors.yaml, lovelace-ui.yaml and PM you so you can take a look.

Go for it, I like a good puzzle!

Just sent you a PM. I even spun up a new Hassio server with nothing but this addon, and still get the same error. Only other thing I’m seeing a lot of in the logs is this - and looks like it may be SSL/DuckDNS related?

Error doing job: SSL error errno:1 reason: HTTP_REQUEST
Traceback (most recent call last):
File “uvloop/sslproto.pyx”, line 504, in uvloop.loop.SSLProtocol.data_received
File “uvloop/sslproto.pyx”, line 204, in uvloop.loop._SSLPipe.feed_ssldata
File “uvloop/sslproto.pyx”, line 171, in uvloop.loop._SSLPipe.feed_ssldata
File “/usr/local/lib/python3.6/”, line 689, in do_handshake
ssl.SSLError: [SSL: HTTP_REQUEST] http request (_ssl.c:841

Try this out of curiosity. Put your API key in quotes.

-platform: sonarr_upcoming_card
 api_key: "thisismyapikey11011"

Doesn’t seem to be working.

Thanks for your help on this. I’ll just wait around and see if it ever starts working for some reason. I did pull these from the Chrome dev console if that helps. Otherwise I’ll just wait until new versions are out and hope something fixes it.

This project is now depreciated. I must apologize as this was only released 2 days ago. There were calls for it to be expanded, so I decided to make the card generic so that more components could be made to supply the info. That and I have too much free time on my hands. For those familiar with the card here’s what’s new:

  • Radarr support!
  • You can now change the language for the days of the week & date format.
  • Anything beyond a week will now also display the date to accommodate movie releases.
  • Slight changes were made to the styling to allow for multiple instances of the card.
  • Both the components and card can now be updated with Tracker-Card and Custom-Updater

This addon has been replaced by Upcoming Media Card.

Find it’s thread here:
and on github here:

Ok so I implemented the new cards. Loving it. Really nice work! Thanks mate.

why is This is no longer supported or maintained.

See first post:

Is there any chance somebody could help me figure out how to setup the sonarr sensor?

The sensor is showing up but im getting this:

localhost cannot be reached from the state.

I downloaded the windows app on my laptop, but I do use a Raspberry Pi for my HA (running Hassio)


This thread is for an old component/card that no longer exists. For the Upcoming-Media-Card thread go here:

localhost would only work if sonarr is installed on the same machine that’s running hassio. you need to use the IP address of the machine sonarr is running on.