"device not connected to local push notifications"

Hi, I had this problem yesterday and couldn’t find a reason for this since the device was connected.
I closed the companion app and opened again but no difference.
Rebooting the device solved this.

Is there a way in HA to detect this and notify about it?

what do the companion app logs say when the issue happens?

I also had Device not connected to local push notifications on an automation. It’s simple

and I have 3 phones with HA app installed yet

It makes no sense, at least 2 phones were even on the same wifi.

Same here. Any solution to this problem??

local push notifications depends on Persistent Connection, if you are on the google play store version of the app you may want to ensure the setting is set to Never.

Settings > Companion App > Persistent Connection

If you need the connection then please check the logs I mentioned earlier.

Settings > Companion App > Show and share logs

it will show a failure for why the persistent connection could not be made. If no failure is shown then force stop the app and open it again to see if there is an error. Again this is IF you have Persistent Connection set to anything other than “Never”. If you are on the minimal version of the app then you do want it set to “always” so you can get notifications. In that case you will see an error in the logs if the app could not establish the connection.

Hi there,
I have exact the same Problem but i didn’t use the google play version.
My Setup is basend on the f-droid Version (minimal)
I enabled the setting, persistant connection → always but if I try to send an message through home-assistant I get the error: “device not connected …”

The only difference with my Setup is, that I use a VPN-Tunnel to connect to home assistant, but that should not matter.

Thanks for your help!

The Problem persist: a job for the developers of HA? Perhaps the solution in the next HA update 2022.12....?!!!!

@Lohgerber did you take a moment to read the thread before posting? If so any reason why you skipped over my last post requesting logs?

I am trying to help but nobody is reading my post on what to do for troubleshooting.

Thanks for trying to help! I’m experiencing the issue for a couple of days now. When it occurs, no entry is added to the companion app’s log.

Just in case anyone uses something similar, I resolved this issue by adding a whitelist entry for some Google firebase domain in my ad blocker. Apparently it was newly added to one of the filters I use and once it was, this issue happened, but it’s been fine since I whitelisted it.

and what is your persistent connection set to?

I changed it from always to never. Either way it doesn’t work.

The app settings say there weren’t any notification atempts lately (0 successful, 0 failed, left / max: 500 / 500).

please force stop the app, open it again and then get us the companion app logs with the option set to never

I sent you a DM

@dshokouhi solved the issue for me by pointing me to the fresh app start manual: Troubleshooting | Home Assistant Companion Docs

Thank you!!

Is anyone still having issues with this. I can’t get notify.notify to work. Have tried the fresh start, changed settings etc. It all started when I changed phone, it was from android to android and the previous one had no issues. I can only get a notification if I explicitly add the devise id to notify. Where else could I look please?

Edit: Also noticed I don’t have a websocket channel on the new phone but do on the old

the companion app logs would be the best place to look for FCM and/or websocket errors.

Force stop the app and open it again then…Settings > Companion App > Show and share logs

thats fine at one point in time the default setting for websocket was set to screen on so the channel would be created, since then the default is never so the channel will not be created unless its turned on.

Thanks for the quick response. No errors associated with them are showing.
Could it have anything to do with the new phone being setup using the google function of transferring apps, would a clean install do anything? I have deleted the device and onboarded again but no joy.

what did the firebase lines say? it will either initialize successfully or fail

@dshokouhi it says successful
FirebaseApp: Device unlocked: initializing all Firebase APIs for app [DEFAULT]
FirebaseInitProvider: FirebaseApp initialization successful