DNS stopped working

Hi, I hope I chose the right category to start this topic. If not so, I’m sorry.
Yesterday, my Home Assistant lost the ability to connect to the internet - all of sudden. I tried to restore an older backup - no result. I’m attaching logs from Supervisor and DNS. Can someone help me, please?

Home Assistant version: 0.117.1
Platform: RPi 4

Supervisor log:

20-11-01 10:50:12 WARNING (MainThread) [supervisor.misc.tasks] Watchdog found a problem with CoreDNS plugin!
20-11-01 10:50:12 ERROR (MainThread) [supervisor.misc.tasks] CoreDNS plugin is in failed state, resetting configuration
20-11-01 10:50:13 INFO (MainThread) [supervisor.plugins.dns] Starting CoreDNS plugin
20-11-01 10:50:13 INFO (SyncWorker_7) [supervisor.docker.interface] Cleaning hassio_dns application
20-11-01 10:50:14 INFO (SyncWorker_7) [supervisor.docker.dns] Starting DNS homeassistant/aarch64-hassio-dns with version 2020.10.2 -

DNS log:

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] corefile.sh: executing... 
[12:00:14] INFO: Cleanup old corefile
rm: can't remove '/config/corefile': Read-only file system
[cont-init.d] corefile.sh: exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

Might be related to: Suddenly HASS cannot connect to internet ressources (DNS issue?)

I’m doing a fresh install of the image on a pi 3b and it won’t boot for me either so here’s hoping you find an answer.


I got exactly the same issue with the same dns logs. For me the consequences are that HACS won’t restart neither all integration requiring network (cozytouch for me).
What is strange is that the hassio_dns container is recreated and started continuously :

CONTAINER ID        IMAGE                                              COMMAND                  CREATED             STATUS                      PORTS                    NAMES
2d5ab29ab0fe        homeassistant/armv7-hassio-dns:2020.10.2           "/init"                  30 seconds ago      Exited (1) 22 seconds ago                            hassio_dns
4cb0cb0901b8        homeassistant/raspberrypi3-homeassistant:0.117.2   "/init"                  20 minutes ago      Up 20 minutes                                        homeassistant
3dfa00ade982        homeassistant/armv7-hassio-observer:2020.10.1      "/init"                  22 minutes ago      Up 22 minutes     >80/tcp     hassio_observer
0df2063c9ffa        homeassistant/armv7-hassio-multicast:3             "/init"                  About an hour ago   Up About an hour                                     hassio_multicast
187fe273c5a8        homeassistant/armv7-hassio-cli:2020.10.1           "/init /bin/bash -c …"   About an hour ago   Up About an hour                                     hassio_cli
4d948af006c5        homeassistant/armv7-hassio-audio:17                "/init"                  About an hour ago   Up About an hour                                     hassio_audio
a033fd0cd5be        homeassistant/armv7-hassio-supervisor              "/init"                  2 days ago          Up About an hour                                     hassio_supervisor

I just updated to hassio 0.117.2

I resolved the issue by deleting the container hassio_dns with

sudo docker image rm -f <id_of_hassio_dns_image>

Then I pull an old image of the hassio_dns with

sudo docker pull homeassistant/armv7-hassio-dns:9

I then go to the hassio supervisor page and click on update.
Then I restarted the homeassistant version

1 Like

This Supervisor update fixed it (after reboot): https://github.com/home-assistant/supervisor/releases/tag/2020.10.1

FYI: At least my issue posted in the link is unfortunatelly not fixed by @James-CZ solution…

I found out my issue which occured at the same time was due to HA getting io errors on the 128gb microsd card I had installed which is strange given I pulled it from an asus phone where it’s been working fine for over a year. I put a 32gb “purple” microsd intended for a security cam into the pi and HA came up without issue. The only annoying part is every tutorial kept telling me to do a “remote install”…it was only when I hooked up a monitor they assured me I didn’t need that I could see the issue. Something to keep in mind for others encountering weird errors.

I found I didn’t like the docker arrangement because I wanted to add homebridge which has been “abandoned” so I’ going to install Raspian (or whatever they call it now) and do manual installs of both in python venv’s.