Downloading data easily

No idea. With the little info you posted it could be literally anything. Make sure to follow all instructions, do not skip a step. Make sure to hit reload when HACS prompted you to. Clear your browsers cache for good measure. Look into your HA log for errors, post them here if you find any related to HACS or the card.

Did you build your card to work as a selectable card in the UI? If not @jonbondy has to configure is as a manual card using yaml.


No errors in the Supervisor log. In HACS under Front End I can see the History Explorer Card. I can get the documentation to display via the Lovelace button. The triple-dot menu button reveals Information (shows the same documentation), Repository (which gets me to GIT), and Update Information, Redownload, Open Source, Open Issue, Request for Removal, and Remove, none of which seem appropriate.


I did not build a card: I downloaded it. I attempted to create a Manual card in Overview and paste some YAML in, but was told that the type custom history-explorer-card could not be found.

Thank you, both, for your help




1 Like

I was responding to Alex with that comment. He’ll know what I’m asking.

When I go here

I see the preferred way to install is via HACS, and then there is a section on Manual Install. I assumed that the HACS install avoided the need to do the Manual Install also.

It wouldn’t be in the supervisor log, but in the HA core log (not sure how to access that on HAOS, but a Google search should tell).

It normally does. Did you clear the browser cache ? Did you hit reload when HACS asked you right after installing the card ? If not, uninstall the card, reinstall and make sure to hit reload.

I just allowed one of the updates (Core, Supervisor, whatever) and now everything is visible and working.

Sorry to have wasted your time! And thanks for the Card!


No worries, good to know it works now. Let me know how you like the CSV export.

I see “No visual editor available for type ‘custom:history-explorer-card’.” and no way to edit the YAML. I added an Entity and the YAML did not change. I usually tweak things until I like them and then grab the YAML as a backup. The added Entity is not visible in the YAML at all.

I can add a 2nd Entity, but it appears in a 2nd graph. Since there is only one place where I can specify the X axis as 30 days (which worked for the 1st graph), I don’t see how to tell the Card that I want both Entities on the 1st graph at 30 days, rather than the 2nd one at 1 day.

Your example graphs are beautiful and wide and detailed, but mine remain small and cramped like all of the other HA Cards.

So. Still some things to work through on my end, if not on yours.

There is a Cancel button but no Save button. If I hit a few times, that seems to save things.

You don’t need the YAML. Just leave it at the default. This card is intended to be used only through its UI. The YAML is only needed to finetune it. Just add the entities with the entry field at the bottom.

Go the dashboard settings, set view type to ‘Panel’.

Thanks. If I can’t edit the YAML, how will I make the modifications, like

type: custom:history-explorer-card
combineSameUnits: true

which you specify in

In my application, it would be nice if I could have 2 graphs, one with total house watts (both phases) and one with just the hot tube watts (both phases). I can either have 4 graphs or 1. Perhaps my situation is unusual.

Thank you for the work you put into this!


Then you need to configure them in the YAML, which allows you to group and combine them in any way you like. There are examples at the end of the Readme.

a bit off topic, but I tried to add a 2nd of your Cards to a Panel. The Panel accepted the addition, but then said that only one Card was visible in a Panel. It would have been nice if I had been prevented from doing the 2nd Add, but that is in the past. I cannot find a way to remove the useless second Card.

Use a vertical stack in in the panel to have more than one card.

As a sidenote, when you reply to someones post you need to hit the reply button below that post. Otherwise the person will not be notified. I basically just stumble over your posts in the thread by coincidence when scrolling through the latest threads.

Makes sense, but how do I remove the hidden 2nd Card? There is a warning message, but no way that I can see to remove the Card to remove the warning.

BTW, everything is working wonderfully now. I have formatted the graphs, and performed the CSV export. Really superb!

Thanks so much!

No clue. Maybe someone who knows more about the ins and outs of Lovelace knows. I would just edit the raw Lovelace YAML and remove it there.

Great !