DuckDNS - It's not just me - it's you!

I’m sorry, you’ve lost me.
You say you can connect locally and you can connect through duckdns.
That’s it, that’s the whole shebang, what else is there ?

Edit: looking at what you have posted you seem to have a superfluous “.” remove it.

Should be : -
“domain”: “

I can only connect through http, https gives me an error and when I connect without either it says that it’s not a secure connection.

Thanks I’ll try that out!

Eh ? You said you could ?

Yes, I can connect but only through a non secure connection. My browser on the remote machine says the connection is insecure.

I’m trying to make sure I’m connecting through https:// and when I do try to connect with the https it says the site can’t provide a secure connection. ERR_SSL_PROTOCOL_ERROR.

So to iterate, local access works, HTTP remote works but I want to make sure the connection it HTTPS and secure.

HTTPS doesn’t and that’s the problem.

Thanks for the patience man I’ve been pulling my hair on this all week.

Thank you so much…this has been a problem for me for many months…finally resolved!!

So, just to confirm, you followed the above instructions to the letter and you have neither an http: entry nor an https: entry in your configuration.yaml ?

Hi , I am wondering if you found any solution for this problem? I have the exact same issue. My remote duckdns connection works, but locally stopped working few weeks ago and I can not make it to work locally !

So I shall ask you the same question I asked Pavle : - Have you got an http; or https: entry in your configuration ?

Yes I do , without those my HA does not load at all.

Well, as I explained in the instructions, I don’t have either and mine works fine.

I did not have any further success trying to replicate Mutt’s configuration. Retaining the https allows me to access through my duckdns address from all locations so I gave up trying any further.

I’ve since signed up to the Nabu Casa cloud service.

hello, I am running home-assistant on docker container on raspi 3. i can access HA from outside n/w using “http” but can’t get “https” to work. it throws webhook client error. anybody successfully setup ssl on docker container on raspberry pi 3 ? would you mind sharing instructions. thanks in advance.

Well, that shouldn’t work.
It’s hard to pin point the issue with the information you have given but the instructions given above should work for you.
I don’t think you’ve followed them though as what you have said conflicts.

i have duckdns configured and working but how can i install nginx ? since i am running ha on docker container, there are no options to install add-on because there is no add-on store.

You should be able to load another source of nginx, though yo may have to read up on its configuration.

Alternatively you can just access internally and externally with the address

Or use Nabu casa

Hang on, I run in a docker environment on raspbian and I installed hassio and have a full store

no when you install ha over docker container it does not have add-on store available. you can check ha website for that. i can access my ha from outside network using, the problem i am having is making it secure using

alright so i installed nginx container on docker, using “docker pull nginx”. now i have two containers running inside docker, one is ha and one is nginx.

No, you installed hassio core, rather than hassio.
I run a pi4 with ssd, this requires raspbian, in Docker and I have the store.
Will add photos : -

to me this looks like a standalone. did you copy the ha image onto ssd ?

here are my screen shots btw
can you please share the link you used to install ha on docker ?
i used below link:


Manual supervised installer

thanks for that. I did not think about running this as I was already running pihole on my raspi 3, i did not want to screw that up lol. i will install ha using your link above. btw i followed the below link as it was also talking about docker and raspi 3.