Duckdns + Nginx + http:// local?

So I tried today to get duckdns with nginx working so I can use http:192.x.x.x:8123 to access HA from in my house.

Still couldn’t get it to work.

If I comment out anything to do with http: in my config I can access HA only through ip.

If I have the http bit relating to duckdns I can ONLY access HA through duckdns

Is there no way I can have duckdns and http:192…:8123 both working at the same time?

At the moment I have port 443 forwarded to 8123

I have seen people say you need 443 forwarded to 443 but doing that meant nothing worked.

Don’t want to move to other options really just want the above sorting out.

I have seen a thread suggesting you need to port forward to the ip of your pi but not sure how to do that.

Duckdns works
Nginx is running and nothing in the log
I have:

  Base_url: myduckdnsaddress 
  Ssl_certificate: /ssl etc etc 
  Ssl_key: /ssl/privkey etc

Try : -

for the port forwarding THIS IS REQUIRED
Look up your modem/routers instructions or enter the name into youtube with port forward

This worked perfectly thank you!