Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007fd08b6323c0>

#2342

How can I do a Push thru the app?
Was the Push Mobile intended to push a message to the App from HA?


#2343

Create a Routine in the Alexa app which has an action to do the mobile push. General instruction here.

The mobile push notification just replicates the action that you can select in the Routine.


#2344

Yes, it works.
I’ve created a routine that starts at hh:mm and I’ve got the notification.


#2345

I’ve updated the wiki, thanks for the suggestion!


#2346

The wiki says I can announce on a Alexa Whole House Audio group (WHA). How do I do that? I have all my echos in an “Everywhere” group but using announce with

target: media_player.everywhere

doesn’t work. If I list all the individual echos the announcement comes from each individual echo, not synced.


#2347

Instructions. If it still doesn’t work, can you please post the service call? WHA should work if you’re using announce. tts however won’t work with Everywhere and would have the symptoms you described when splitting the items up.


#2348

Sorry if that has been asked before. But , is this component gonna have room awareness ?

I mean, receiving the string of the last sentense spoken to an echo (so we now where it comes from) ?


#2349

Yes.


#2350

I’m up and working on 89.2 hass.io. One thing I did was I updated my Host System. I wonder if this might have had something to do with the alexapy issue for me. I was at version 1.11, and now I’m at 2.10. After that I had no issues.

Hass.io panel, System, Host System, Update.

I don’t think it updates when you update Home Assistant.


#2351

I’ve been playing around with this a bit. To clarify: I have 5 echos, 2 of them paired as a stereo pair. Using
{ "message":"test message to all echos", "title":"My title for Echo show", "data":{"type":"announce", "method":"all"}, "target":["media_player.everywhere"] }
at first only works with the echo that played last. Sending an announce to others individually makes them be included in the everywhere group. Except the stereo pair, I can sent an announce separately beforehand, but they get ignored in the everywhere group.


#2352

I’ve just managed to get last_alexa working today, but I’ve noticed a strange issue I can’t seem to figure out.

I’m using this sensor in an automation to ask Alexa what my pool temperature is, and it works flawlessly as long as I ask my basement echo dot, or my bedroom echo spot, but for some reason if I ask the echo dot in my spare bedroom, I get the wrong temperature.

My sensor is set up correctly, as when I update the sensor it gets the right device, and it replies to me on whichever device I’m asking, but in the bedroom and basement I get “The current temperature is sixty-four point four degrees”, while in the spare bedroom she responds with “The current temperature is 32 point zero degrees”

The TTS message is the same, regardless of which device is playing it, so I’m not even sure how one device could possibly get a different response than the rest:

message: The current temperature is {{states('sensor.converted_pool_temp')|replace('.', ' point ') }} degrees

#2353

Do you have that particular echo configured for metric in your Amazon configuration?


#2354

All of my echo’s are configured for metric, but this shouldn’t matter, as it doesn’t actually know it’s getting temperature data, it’s just being given what text to speak; HA is the only part of the equation that actually knows it’s reading temperature data.


#2355

Okay, is that particular echo configured for Imperial? :slight_smile:


#2356

That was my first thought, but no; they’re all set to metric. It’s so strange, it literally doesn’t make any sense to me lol.

I may try resetting that echo, since it doesn’t really have much set up on it anyway.


#2357

I just reset my spare room echo to factory and tried again and it’s STILL giving me the wrong temperature. I don’t even know where it’s getting that number from! lol


#2358

Try debug logging to verify what is sent?


#2359

Honestly, I’m a noob and have no idea where to find that log. I’m running Hassio on an Ubuntu VM in Windows 10 with VirtualBox.


#2360

So just to be clear, you are using the last echo sensor, and all three echos are using the same alexa routine.

Do you have any other routines that read back sensor information? Is it possible that the “bad” echo is reporting a different sensor? Check your alexa history in the app and see what it heard you say for each echo.

Bottom line, like you’ve stated, the echo is just responding with a string of text, so it’s not possible or a very odd bug, for it to read text differently from a different echo. Which is why you’re posing here of course. :slight_smile:


#2361

Yes, and yes.

No, I don’t have any other routines like this, and this is the only sensor that Alexa reads. I checked my history, and all three of my echo’s heard “Alexa, check the pool temperature” and all three responded “simon says “The current temperature is…””, except one echo gave the wrong number for some reason… :thinking: